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About This Book 
The DeskMate User’s Reference manual is a handy reference tool for quickly 
finding information about any of DeskMate’s menu options and tasks. 
While you’re learning the basics of DeskMate, however, you’ll want to use 
the Getting Started magazine. Then, when you are familiar with an applica- 
tion but need more specific details, use the reference manual to find 
answers to your questions. 
If you need specific instructions for using a menu option, simply locate the 
chapter for the application you are using and turn to the “Menu Options” 
section. Each menu and its options are described in the order in which 
they appear on the menu bar. 
If you need to know which options to use to complete a specific task, lo- 
cate the chapter for the application you are using and turn to the “[appIica 
tion] Tasks” section. In this section, there is a list of tasks and the options 
used to complete each task. Then, if you need more specific instructions 
for any of the options listed for the task, you can locate the option(s) in 
the “Menu Options” section. 
For additional helpful hints, be sure to see the “Other [application] Infor- 
mation” section at the end of each chapter. 
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Accessories 
Overview 
What Is It? 
The DeskMate accessories are several handy tools available to you anytime, 
anywhere in DeskMate. For example, you can use the Corkboard accessory 
to jot a note to yourself while you are working in one of the applications. 

What Can I Do with It? 
The Accessory Menu (F10) contains the following options: 

Setup is a multi-function accessory that lets you set up various DeskMate 
parameters. For example, you can adjust your screen colors or tell DeskMate 
what type of mouse, modem, and printer you are using, and turn the 
desktop sound feature on or off. 
Spell Checker is a built-in editor for your files. You can check the spelling 
of a word or an entire document. This accessory also offers suggested re- 
placements for misspelled words. 
Calculator works like a desktop calculator (with five functions). 
Phone List is a quick way to find names and telephone numbers and then 
dial them if you have an auto-dial modem. 
Corkboard lets you write notes and display them on the desktop or store 
them in the Corkboard file. 
Month is a current monthly calendar that you can use to quickly check 
dates. 
Alarm is a way to audibly and visually remind yourself of important events. 
To Do List lets you display your daily activities on the desktop. 
Clipboard is a special place in DeskMate that holds cut or copied informa- 
tion from the applications. 
Task Switch lets you switch between two DeskMate applications or a Desk- 
Mate application and another software program. 
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How Do I Use I t?  
When you select the Accessory Menu (F10), you see the different 
accessories listed on the menu (as shown at the right). 
To select an accessory from the Accessory Menu (F10), simply use the 
arrow keys to highlight the accessory you want to use, and press ENTER. If 
you are using a mouse, point to the accessory you want to use and click. 
To learn the basics about using DeskMate’s accessories, see the “Accessories” 
article in the Getting Started magazine. Then when you are familiar with the 
accessories, this chapter will provide you with a quick way to answer 
specific questions. You can look up the step-by-step instructions for each Ac- 
cessory Menu option and the options within each accessory. If you want to 
know which options to use to perform a specific task, check the 
“Accessory Tasks” section a t  the end of this chapter. 
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M e n u  Options 
Some of DeskMate’s accessories have menus that 
list the options you can use with that particular ac- 
cessory. The key that you press to see each menu ap- 
pears beside the menu name. (For example, press 
the F10 key to see the Accessory Menu.) A shaded 
option, on a menu means that the option is not 
available. Some options have accelerator keys listed 
next to them. Use these keys to perform tasks with- 
out pulling down a menu. For example in the Setup 
Accessory, when you are ready to exit, you can 
press ESC to select Exit from the Options Menu 
(F2). 
This section explains each Accessory Menu (F10) 
option, the menus within each accessory, and step- 
by-step instructions on how to use each option on 
the menus. 

The Setup Accessory 
Select Setup from the Accessory Menu (F10)  to spec- 
ify and/or change various DeskMate parameters. You 
see the following screen: 

Options Menu 
The Options Menu (F2) options let you specify and 
change DeskMate’s parameters. For example, you 

Colors. 
Mouse... 
Date and Time... 

Printer.. 
Screen saver... 

Exit 

can specify modem information, printer settings, or 
change your DeskMate date and time. 

Communications 
Lets you tell DeskMate about the telecommunica- 
tions equipment you are using. Be sure your settings 
are correct before you use the Telecom or PC-Link ap- 
plications or the Phone List Accessory to dial a num- 
ber. 

1. Select Communi cations from the Options Menu 
(F2). 
A dialog box appears. The options in the dialog 
box are described after the steps. 

box. 
2. Enter or change the information in the dialog 

3. Select OK to complete the task. 
The program saves the communications settings, 
and the Setup screen appears. 
Communications Port. Choose the appropriate 
option to tell DeskMate where your telecommunica- 
tions hardware (such as a modem) is connected. 
Usually COM1 is used for an external modem and 
COM2 is used for an internal modem. COM3 and 
COM4 are used if you have an option board with serial 
ports. 

Note: If you have only one serial port and you 
currently have a mouse connected to it, you can- 
not use the Communications option. 
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Connection. Choose the appropriate option to tell 
DeskMate whether you are directly connected (via a 
cable) to another computer or whether you are using 
a modem for communications. 
COM Interrupt. Choose the appropriate IRQ set- 
ting if you are using COM3 or COM4. You will find this 
setting in the documentation that came with the 
hardware attached to COM3 or COM4. 

Modems.  Highlight the name of the modem you are 
using. (This feature is not available if you chose the 
D i r e c t  connection type.) 
Dial  Timeout. Type the number of seconds you 
want DeskMate to wait to complete a call before the 
modem disconnects. 

Colors 
Changes DeskMate’s screen colors. The colors avail- 
able depend on the type of video monitor you are 
using. 
1. Select C o l o r s  from the Options Menu (F2). 

A dialog box appears. The options in the dialog 
box are explained in detail after the steps. 

2. Choose your desired color options. 
3. Select OK to complete the task. 

Note: If you want to return the colors to their 
original settings, select RESET. 

The program saves the color settings, and the Setup 
screen appears. 
Experiment with the color settings until you find the 
colors you want to use with DeskMate. 
Palettes.  Choose the section of your screen (back- 
ground or foreground) you want to change. The cor- 
responding color is shown next to each palette name 
in the list box. 
Highlight the P a l e t t e s  option you want to change. 
You can then use the Red, Green, Blue, and 
B r i g h t n e s s  bars to adjust the colors and create the 
color you want. Move the setting left to make the 
color lighter or right to make it darker. If your moni- 
tor can detect intensity settings, you can make all 
the colors brighter or dimmer by adjusting the 
B r i g h t n e s s  setting. 

Change colors .  You can use this option in the 
Draw application only. After you set the colors, 
choose whether you want DeskMate to save them 
permanently or only use them until you exit Draw. 
MONOCHROME DEFAULT/COLOR DEFAULT. 
Choose one of these buttons to see the appropriate 
default color settings. You might want to use the 
monochrome setting if you have a monitor that emu- 
lates color. To make full use of the shades of gray 
that your monitor displays, be sure to use the C o l o r  
D e f a u l t  setting. 

Mouse 
Lets you specify the type of pointing device you are 
using and also set a double click speed that is com- 
fortable for you. If you have a mouse (or joystick, if 
you are using a Tandy 1000) connected but do not 
plan to use it with DeskMate, use this accessory to 
tell DeskMate that you are using only the keyboard. 
DeskMate will then remove the pointer from your 
screen so that you will not be distracted by it. 
1. Select Mouse from the Options Menu (F2). 

A dialog box appears. The options in the dialog 
box are explained in detail after the steps. 

2. Specify the appropriate information in the dia- 
log box. 

3. Select OK to complete the task. 
DeskMate saves the Mouse settings, and the Setup 
screen appears. 
Pointing Device.  Choose the type of pointing de- 
vice you are using. 

S e r i a l  mouse — Choose this setting if you are 
using a serial-type mouse. 
Joystick — Choose this option if you have a joy- 
stick or a Tandy Color Mouse. 
PS/2® Mouse — Choose this option if you are 
using a PS/2-style mouse. 
Other  mouse — Choose this device if you have pre- 
viously installed a Microsoft-compatible mouse 
driver. 
None — Choose this option if you do not want to 
use a mouse. 
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Serial Mouse Port. If you chose the S e r i a l  mouse 
in the option above, choose the serial (communica- 
tions) port your mouse is connected to. 

Note: Be sure you select the correct port if you 
have already installed a serial mouse. The COM 
setting you set for your mouse supersedes the 
COM setting you have previously set for your 
Communications Setting. When you access the 
Communications Setting screen, the COM port set- 
ting currently used by the mouse is shadowed so 
that it is not available. 

Port Interrupt. If you are using Com3 or Com4, 
choose the appropriate IRQ setting. You will find this 
setting in the documentation that came with the 
hardware attached to Com3 or Com4. 

Double Click Speed. Choose a double click speed, 
and then point to the TEST button and double click 
the mouse button to see if it is comfortable for you. 
The TEST button responds if your double click speed 
is in the range you chose. If the TEST button does not 
respond, try choosing another double click speed. 

Date  and Time 
Lets you change the current date and time in DeskM- 
ate without exiting to the system prompt. 
1. Select Date  and Time from the Options Menu 

(F2). 
A dialog box appears. The options in the dialog 
box are explained in detail after the steps. 

2. Change the desired information in the dialog 
box. 

3. Select OK to complete the task. 
DeskMate saves your changes, and the Setup screen 
appears. 
Date. Type the date you want to appear on the title 
bar, using the format mmdyyyy (mm = month, dd = 
day, and yyyy = year). 
If you make a mistake typing the numbers, delete the 
incorrect numbers by pressing the BACKSPACE or DE- 
LETE key. BACKSPACE deletes the character to the 
left of the cursor, and DELETE deletes the character 
to the right of the cursor. 

Time. Type the time you want to appear on the title 
bar, using the format hh:mm:ss (hh = hour, mm = 
minutes, and ss = seconds). Then, choose either AM 
or PM. 

Note: You can also separate the hours and min- 
utes with a space. 

Printer  
Lets you tell DeskMate what type of printer you have 
connected to your computer. DeskMate refers to this 
information each time you select a print option. Be 
sure to change this information if you change print- 
ers. 
1. Select P r i n t e r  from the Options Menu (F2). 

A dialog box appears. The options in the dialog 
box are explained in detail after the steps. 

2. Choose the desired options. 
3. Select OK to complete the task. 

DeskMate saves the printer settings, and the Setup 
screen appears. If you are using diskettes to run 
DeskMate and you need to switch diskettes to print, 
you might want to add your printer driver(s) to the 
diskettes you are using to run DeskMate (your work- 
ing copies). For more information, see the “On Your 
Mark” documentation. 
Printers. Highlight the printer you are using with 
DeskMate. (You must be using a daisy wheel, laser, 
Epson-, AGM-, Tandy-, or IBM-emulation printer. For 
more information about the type of printer you are 
using, see your printer documentation.) 
When you select OK to set the printer information 
you have chosen, you might see another dialog box. 
This box will vary, depending on the printer you 
chose. One dialog box might ask you to choose the 
number of characters you want to print per inch 
(10, 1 2 ,  Condensed). Another dialog box might ask 
you to choose a specific font. This box will also con- 
tain other print options that are specific to the 
printer. 
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Both of these dialog boxes contain a P A G E  SETUP but- 
ton. If you select this button, you will see the current 
setting for Total lines per page and Printed lines 
per page, along with a suggested maximum. If you 
want to change the setting, use the Page Setup op- 
tion in the appropriate application. 
ASCII Printer (Text Only) is a generic printer 
driver and should work with all printers. If your 
printer is not represented in this list, be sure to use 
this printer selection. When you choose this option, 
another dialog box appears so that you can specify 
how you want carriage return characters to print 
and whether you want the printer to ignore bold and 
underline attributes. 
No printer. Check this box if you are not using a 
printer. 
Line f e e d  filter. The Cine feed filter option is on 
when the box is checked. Check the box if your 
printer does not automatically do a carriage return 
at the end of a line. Leave the box blank if your 
printer does a carriage return. If your printer is dou- 
ble spacing or printing lines on top of each other, try 
changing this switch. 
Printer Ports. Choose the port to which your 
printer is connected. The default port is LPT1. 
UPDATE. Use this button when you want to install 
new printers. Insert the diskette that contains the 
printer information, and select this button. 

Screen saver 
Lets you choose whether you want your monitor to 
automatically blacken (remove the images or text 
from the screen). 
1. Select Screen saver from the Options Menu 

A dialog box appears. 

which you want the screen to blacken. 

A message box appears, telling you how to 
redisplay the screen after it blackens. 

4. Select OK to remove the box from the screen. 
You can instantly redisplay the screen after it black- 
ens by pressing any key. 

Exit 
Exits the Setup Accessory. 

The program displays the screen you were previously 
using. 

2. Highlight the desired time of inactivity after 

3. Select OK to complete the task. 

Select Exit from the Options Menu (F2). 
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The Spell Checker Accessory 
Spell Checker uses a built-in main dictionary and a 
user-defined dictionary to check the spelling in a file 
or document. Select Spell Checker from the Acces- 
sory Menu (F10). You see the following screen: 

The dialog box contains menus from which you can 
select various functions within the Spell Checker Ac- 
cessory. 
You can access Spell Checker directly from the Text 
application by selecting the Proof option from the 
Edit Menu. See the “Text” chapter for more details. 

File Menu 
The File Menu (F2) options let you open files and 
exit the Spell Checker Accessory. 

I Open.. 
Exit ESC 

Open 
Lets you open a document file in the current direc- 
tory and all available subdirectories and drives. (The 
symbol [..} indicates the parent directory.) 

1. Select Open from the File Menu (F2). 

2. Highlight the file you want to open. 
A dialog box appears. 

Note: If the file you want to open does 
not have the extension .doc, the file 
type (ASCII or non-ASCII) is deter- 
mined by the contents of the file. A mes- 
sage is displayed if the document is in 
non-ASCII format. 

3. Select OK to open the file and begin the Spell 
Checker procedure. 
A dialog box appears. 
Spell Checker displays the first unknown word at 
the top of the box. The way the word is used is 
shown directly beneath the word. You can edit 
the word in the Usage: area or scroll through the 
Replacements list box and highlight the word you 
want to use. Notice that the word currently high- 
lighted in the Replacements list box appears in 
the Us age : area. 

4. If the unknown word is correct, select Add t o  
D i c t i o n a r y  from the Options Menu (F2). 
The word is added to your user dictionary. 

5.  If you want to return to the original, unknown 
word, select Restore Context from the Options 
Menu (F2). 
The unknown word reappears in the Usage: area. 

6.  Select OK to accept the word currently in the 
Usage: area and continue checking the docu- 
ment. 
The word appears in the document when you 
next access it. 

7. Select C A N C E L  to stop the spelling check. 
The Spell Checker dialog box appears. 

Exit 
Removes the Spell Checker dialog box from the 
screen and returns to the screen you were previously 
using. 

If you have added words to the user dictionary, you 
will be prompted to save the changes. 

Select E x i t  from the File Menu (F2). 
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Options Menu 
The Options Menu (F3) options let you automat- 
ically check each word as you type and check spell- 
ing for specific words. 

Auto Proof 
Checks every word you type-whether you are 
typing in a file or typing information in a dialog box. 

Select Auto P roo f  from the Options Menu (F3). 
A check mark appears by the option so that you 
know it is turned on. 
Each word you type is compared with the main and 
user dictionaries. If the word is not found, a beep 
sounds. You can then select Spell Checker from the 
Accessory Menu (F10) and use the Check Word op- 
tion on the Options Menu (F3). 

Check Word 
Checks individual words as you type. 
1. Select Check Word from the Options Menu (F3). 

2. At the Word t o  check: prompt, type the word 

3. Select OK. 

A dialog box appears. 

whose spelling you want to check. 

If the word is unknown, suggested alternatives 
are displayed. If the word is correctly spelled, a 
message is displayed. 

you were using. 
4. Select CANCEL to return to the previous screen 

Dictionary Menu 
The Dictionary Menu (F4) options let you save and 
delete words in your user dictionary. 

Edit 
Lets you remove words from your user dictionary. 
1. Select E d i t  from the Dictionary Menu (F4). 

A dialog box appears, listing the words in your 
user dictionary. Like the pages of a dictionary, 
there are headings for the first and last words 
on the page. 

2. Choose the word you would like to delete, using 
the following keys: 
PG U P  
PG DN 
OK 

DELETE 

CANCEL 

Displays the previous page of words. 
Displays the next page of words. 
Accepts the deletions (if any) you have 
made. You’ll be prompted to save the 
dictionary on disk when you leave the 
Spell Checker Accessory. 
Removes the currently selected word 
from the user dictionary. 
Causes any deleted words to reappear 
and the user dictionary remains 
unchanged. 

Save 
Saves the changes you make to your user dictionary 
after you use the Ed i t option. 

Select Save from the Dictionary Menu (F4). 
Any changes you made to your user dictionary are 
saved. 

The Calculator Accessory 
This five-function calculator calculates simple arith- 
metic equations. 
1. Select Calculator from the Accessory Menu 

(F10). 
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2. Type the numbers, using the number keys on 
the keyboard, and type the functions as they ap- 
pear on the calculator buttons. With a mouse, 
simply point to the number and function but- 
tons on the display, and click. 
If you make a mistake while typing, type C E  (or 
point to C E  and click) to clear the entry. If you 
make a calculation error, such as trying to 
divide by zero, ou see the message ERROR on 
the calculator &play. use the CA function 
before you continue. 
For example, to add 9 + 7: 
a. 
b. Select 9. 
C. select t. 
d. Select 7. 
e. Select = . 
The result, 16, appears on the calculator’s dis- 

3. Select C A N C E L  to exit the Calculator Accessory. 

Select C A  to clear the calculator. 

play. 

DeskMate displays the previous screen. 

I 
Calculator Functions 
Following is a list of the Calculator Accessory‘s 
functions and a brief explanation of each: 

Changes the sign of a number. 

Clears all parts of the calculator, 
except memory. 
Adds the displayed number to the 
next one you enter. 
Divides the displayed number by the 
next one you enter. 
Lets you use a percentage in a calcu- 
lation. For example, entering 200 - 3% 
produces the result of 200 minus 
3 rcent (194). 

M+ ds a number to the amount in the 
calculator‘s memory. 

M- Subtracts a number from the amount 
in the calculator’s memory. 

MC Clears the calculator‘s memory. 
MR Displays the calculator’s memory. 
= Displays the accumulated result of a 

calculation. 

S 
C E  Clears the current entry. 
CA 

+ 

/ 

% 

The Phone List Accessory 
This accessory provides a quick way to find the 
names and telephone numbers you have entered in 
the Address Book application. If you have an auto- 
dial modem, you can also use this accessory to dial 
the phone number for you. 
Select Phone L i s t  from the Accessory Menu (P10). 

Phone List Menu 
The Phone List Menu (F2) options let you print your 
phone list and exit this accessory. 

1 Print I 
~ Exit Esc I 

Print 
Prints a copy of your phone list. 
1. Select Print from the Phone List Menu (P2). 

DeskMate prints the first page of your phone 
list. The printer automaticall pauses between 

rent page. 

If you select NO, DeskMate continues to print the 
rest of the phone list or displays the Phone List 
screen. If you select YES, DeskMate reprints the 
current page. 

pages, and you are prompte 2 to reprint the cur- 

2. Select YES or NO. 

Note. You can select C A N C E L  at any 
time to quit printing. 
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Exit 
Exits the Phone List Accessory. 

DeskMate displays the screen you were previously 
Select E x i t  from the Phone List  Menu (F2). 

using. 

Number Menu 
The Number Menu (F3) options let you display a 
number and automatically dial it if you have an auto- 
dial modem. In addition, you can display home or 
work numbers on the phone list. 

Call 
Automatically dials a highlighted number on the list 
if you have an auto-dial modem connected to your 
computer. Be sure you have defined your telecom- 
munications equipment using the Communications 
option on the Setup Accessory‘s Options Menu. 
1. Highlight the number you want to dial. 
2. Select C a l l  from the Number Menu (F3). 

A dialog box appears, and the number you high- 
lighted is automatically dialed. 

has been dialed, pick up your telephone receiver. 
3. When the dialog box indicates that the number 

The phone list appears on your screen. 

Work phonemome phone 
Indicates which phone number is currently displayed 
on the phone list. 

Select the unchecked option (Work phone/Home 
phone) from the Number Menu (F3). 

The specified numbers are displayed on the screen. 

The Corkboard Accessory 
Use this accessory as you would a note pad. Your 
notes are stored on disk so that you can refer to 
them when you need them. 

Note: You might want to put the Corkboard Ac- 
cessory on the desktop so that you can see your 
notes any time you display the desktop. (See the 
“Desktop” chapter for more information.) 

1. Select Corkboard from the Accessory Menu 
(F10). 

Note: If your Corkboard data is on another 
diskette, you see a dialog box the first time 
you select the Corkboard. A message in the 
dialog box asks you to switch diskettes and 
select the RETRY button. If you select CAN- 
CEL, another dialog box appears and you 
can create a Corkboard on the current disk- 
ette by selecting OK. 

The cursor appears in the upper, left comer of 
the corkboard screen so that you can begin 
typing. 

See the “Corkboard Techni ues” box for infor- 
2. ?Lpe your note on the corkboard. 

mation on how to type on 9, e corkboard. 
3. If you want to print the corkboard’s contents, 

select P R I N T .  
DeskMate prints the first page of your corkboard. 
The printer automatically pauses between pages 
and you are prompted to reprint the current page. 
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Corkboard Techniques 
If you make a mistake while typing, you can press the DELETE or BACKSPACE key to remove charac- 
ters. BACKSPACE removes the character to the left of the cursor, and DELETE removes the character to 
the right of the cursor. To delete a larger portion of the corkboard, highlight the section you want to 
delete by either using SHIFT and the arrow keys or dragging the mouse pointer. Then, press DELETE. 
You can move the cursor around the screen using a mouse or the keyboard. If you are using a mouse, 
simply point and click. If you are using the keyboard, you can use the arrow keys or the indicated keys in 
the following chart: 

Press: To: 
PGDN 
PGUP 

CTRL+HOME 
HOME 
END 
CTRL+END 
C L E A R  
PRINT 

Move the cursor to the bottom of the screen. Pressing again displays the next screen. 
Move the cursor to the top of the screen. Pressing again displays the 
previous screen. 
Move the cursor to the beginning of the corkboard. 
Move the cursor to the beginning of the current line. 
Move the cursor to the end of the current line. 
Move the cursor to the end of the corkboard. 
Delete the contents of the corkboard. 
Print the contents of the corkboard. 

1. Select YES or NO. 

If you select NO, DeskMate continues to print the 
rest of the corkboard or displays the Corkboard 
screen. If you select YES, DeskMate reprints the 
current page. 

2. Select CANCEL to exit the Corkboard Accessory. 
Your notes are stored in the Corkboard file, and 
DeskMate displays the previous screen. 

The Month Accessory 
This accessory displays the current monthly calendar 
so that you can quickly check a date. 
1. Select Month from the Accessory Menu (F10). 

The current monthly calendar appears on the 
screen. 

I I 

You can look at the current month, a previous 
month, the next month, the same month in the 
previous year, or the same month in the next year. 

Press: To  see: 
P Previous month 
N Next month 
CTRL+P Same month, previous year 
CTRL+N Same month, next year 

1. Select CANCEL to exit the Month Accessory. 
DeskMate displays the previous screen. 

The Alarm Accessory 
Remind yourself of special events or meetings 
with the Alarm Accessory. You can use it alone or 
with the Calendar application. 

Note: If you want to use the Alarm Acces&ry 
with the Calendar application, you turn on the 
Alarm option when you add an event to your 
Calendar application. The alarm then operates as 
described in this section. 

The current month is determined by the date that 
appears in the upper, left corner of the DeskMate 
screen. 
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1. Select A1 arm from the Accessory Menu (F10).  The To Do ListAccessory 
s u r ~ ( r i ~ & r  ni- I ilnr .,rlull ro,,wr r h t ~ ~ r  

I scl in UMS bx a d  tn Ihr calrndnr 
I PFDIRUD go or1 

Ovleh elm Hm: 10 0 M( 0 Pn 

2. Change any of the alarm options in the dialog 
box. The options are explained in detail after 
the steps. 

3. Select OK to complete the task. 

DeskMate displays the screen you were previously 

When the alarm sounds, the F9 button on the menu 
bar flashes and is displayed in reverse highlight. 
Open the F9 Menu and select A1 arm to display the 
alarm message you created when setting the alarm. 
AlaWCalendar Alarms. Choose this option to 
turn the alarm function on or off. When the alarm 
is on, the available memory is decreased. If you 
need additional memory while running DeskMate, 
turn off the alarm. 
Quick Alarm Time. Use this option if you want to 
enter an alarm time that is not associated with an 
event in the Calendar application. Enter the time, 
using the format hhmm, and choose either AM or PM. 

Message. Type a description of the event for which 
the alarm is set. When the alarm sounds, you can 
select A1 arm from the F9 Menu to display the mes- 
sage. 

using. 

This accessory lets you display a daily list of the an- 
nual occasions, reminders, and scheduled events 
you have entered using DeskMate’s Calendar ap- 
plication. 
To display the To Do List Accessory from anywhere 
in DeskMate: 
1. Select To Do Li s t from the Accessory Menu 

(F10).  
The Thi ngs To Do box appears, listing all the 
daily events entered in the Calendar application. 

’ lhings lo Do 

Flag Day 
3:mp Finance Cannittee fk 

I iimi 
I ........ 1 

The To Do L i  s t  Accessory can display up to 12 
activities. These activities are displayed in the 
following order: 

Calendar-defined holidays 
Annual occasions 
Reminders 
Scheduled events 

For more information about these activities, see the 
“Calendar ” chapter. 

Your scheduled events are listed by start time. 
When the time for an event passes, the event is 
removed from the Things To Do box. Any addition- 
al scheduled events that were not listed because 
the To Do List was full are automatically added 
as space is available. 

Note: Events that do not include a start 
time (NOTES on the daily calendar) are 
listed before the events with start times. 
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2. Select C A N C E L  to remove the box from the 

You can also display the To Do List Accessory on 
your desktop. Be sure to see the “Desktop” chapter 
for more information about displaying an accessory 
on the desktop. 

screen. 

The Clipboard Accessoiy 
This accessory lets you store information in an ap- 
plication so that you can insert it into another ap- 
plication quickly and easily. When you use the Edit 
Menu’s C u t  and C o p y  options, the information you 
cut or copy is moved to the Clipboard. You can then 
use the Clipboard Accessory to create a file to save 
the information. You can save any number of Clip- 
board entries from the different applications. Then, 
when you are in another application, you can use 
these stored Clipboard files to insert another 
application’s information into the application you 
are currently using. 
To get started with the Clipboard, you must first cut 
or copy the information you want to store. Then, fol- 
low the instructions below. 
1. Select C1 i pboard from the Accessory Menu 

(F10). A Clipboard screen similar to the follow- 
ing appears. 

2. Select SAVE, COPY, DELETE, CANCEL, or CLEAR. 
Note: If you have already stored Clipboard 
information, highlight the file you want to 
use and then select the appropriate button. 

Selecting S A V E  lets you save the Clipboard infor- 
mation to a file. 
Selecting COPY lets you copy the highlighted 
Clipboard file into the current application. 

Selecting D E L E T E  lets you delete the highlighted 
Clipboard file from the Clipboard. 
Selecting C A N C E L  exits the Clipboard Accessory 
and takes you back to the application you were 
using when you accessed the Clipboard. 
Selecting CLEAR clears the entire Clipboard. 

selected. 
If you selected the S A V E  button: 

A dialog box appears. 
a. 

3. Follow the instructions below for the button you 

At the N a m e :  prompt, type the name you 
want to give the Clipboard file, ushg 15 
characters or fewer. 
Select O K  to complete the task. 
The file appears on the Clipboard in 
alphabetic order. 
Select CANCEL to return to the current 
application. 

b. 

c. 

If you selected the COPY button: 
The highlighted file is copied so that you can in- 
sert the information into the current application 
(if applicable). 
a. 

b. 

c.  
The Clipboard file’s information is inserted at 
the cursor location. 

The highlighted file is removed from the Clip- 
board. 

Select CANCEL to return to the current ap- 
plication. 

Select CANCEL to return to the Current 
application. 
Move the cursor to where you want to in- 
sert the Clipboard information. 
Select P a s t e  from the Edit Menu (F3). 

If you selected the D E L E T E  button: 

If you selected the CANCEL button: 

If you selected the CLEAR button: 
The current application screen is redisplayed. 

A dialog box appears asking you if you are sure 
you want to delete all the Clipboard entries. 
a. Select YES to delete all the entries or NO to 

redisplay the Clipboard screen. 
b. Select CANCEL to return to the current 

application. 
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The Task Switch Accessory 
This accessory lets you quickly move between Desk- 
Mate applications or between DeskMate and another 
software program in memory. 

When you store information on diskette or access 
your disk drives in any way, be sure that you Rave 
the correct diskette(s) in the drive(s) for the 
software you are currently using. 

Considerations When Using Task Switch 

You cannot use Task Switch at the same time 
you are running “always resident” programs, 
such as Microsoft Windows, Sidekick@, and 
other similar packages. 
You cannot use Task Switch with other software 
that requires you to reset the computer in order 
to load. 

pointing device. 
You cannot task switch with BASIC, using a 

You cannot task switch with programs that “take 
over” the keyboard. You will know if your program 
does this by pressing the ALT= key sequence. If 
nothing happens, your program controls the key- 
board. 

To use the Task Switch Accessory to switch between 
programs or DeskMate applications: 
1. Open one of the programs or applications you 

2. Select Task Switch from the Accessory Menu 
want to switch between. 

(F10). 
You return to the desktop. 

want to switch between. 
3. Open the other program or application you 

Note:  If the application or program 
does not appear on the desktop, use the 
File Menu’s (F2) Run option to open it. 

After you enter the new program or application, you 
can switch between the two by selecting Task 
S w i t c h  from the Accessory Menu (F10) or by simply 
pressing ALT= . 
To end task switching between two programs or ap- 
plications: 
1. Exit one of the programs (or applications) by 

pressing ESC. 
The desktop appears. 

exit it by pressing ESC. 
Task switching is canceled, and you can exit 
DeskMate. 

Note:  If you try to exit DeskMate and 
there is still a task in memory, you will 
return to that program. Simply exit that 
Program by pressing ESC. Task switch- 
ing is canceled. 

2. Open the other program (or application), and 

To use the Task Switch Accessory to switch between 
DeskMate and MS-DOS: 
1. At the desktop (or from within any application), 

select Task Switch from the Accessory Menu 
(F10). 
The Run dialog box a pears. (If you selected 
Task Switch from wit&, an application, you 
must select Run from the File Menu (F2) when 
the desktop appears.) 

2. At the Program: prompt, type command. corn and 
press ENTER. 

The system prompt appears. You can now select 
Task Switch (or press ALT=) to switch between 
MS-DOS and DeskMate. 
To cancel task switching, type e x i t  at the system 
prompt and press ENTER. The desktop is displayed. 
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Address Book 
Overview 
What Is I t?  
DeskMate's Address Book application helps you keep address information or- 
ganized and accessible. In addition to the master list Address Book creates 
for you, you can store up to 25 specialized lists of addresses. 

What Can I Do with It? 
The Address Book application contains many practical features that will 
make it easy for you to keep up with your addresses. In addition to keeping 
track of your addresses, with this application you can: 

Edit addresses and address lists without messy erasures, pen, and ink 
Look up address information quickly and easily 
Organize address lists for Christmas cards, business clients, or any special in- 
terest group 
Print mailing lists, mailing labels, and form letters 
Automatically dial phone numbers stored in Address Book using an auto- 
dial modem 
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How Do I Use It? 
When you open the Address Book application, a screen similar to the 
one at the right appears. 
Use the address record that appears on the screen like an index card or 
blank sheet from an address book. Press TAB (or SHIFT+TAB) to move the 
cursor forward and backward through the fields and type the various parts 
of the address (courtesy title, first and last names, city, state, and so on). 
You can type addresses in any order because Address Book automatically 
sorts and stores them alphabetically. Just be sure to fill in the last name 
field or type a space in it. 
In the Dates t o  Remember/Notes box, you can keep track of birthday 
and anniversary dates, or you can highlight the words Birthday and 
Anniversary and type in something else to remind you of special dates. In 
addition, you can type any special reminder notes you’d like to keep with an 
address. 
M e r  you finish typing the address information, you can select Add from the 
Address Menu (€75) to add the information to your Address Book. Another 
blank record is displayed, and the Index list box displays the name for the 
address you entered. Also, notice that the T o t a l  entries:  indicator at the 
bottom of the screen shows how many addresses the book contains. 
When you finish adding addresses, select an available option other than an 
Edit Menu (F3) option. Address Book stores the last address and performs 
the action you chose. To view any address, simply select the appropriate 
name from the Index list box. 
To learn the basics about using Address Book, see the “Address Book” article 
in the Getting Started magazine. Then, when you’re familiar with Address 
Book, this chapter will provide you with a quick way to answer specific ques- 
tions. YOU can look up the step-by-step instructions for each menu option. If 
you want to know which options to use to perform a specific task, check the 
“Address Book Tasks” section at  the end of this chapter. 
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Menu Options 
Address Book has five menus that list the options 
you can use with the application. The key that you 
press to see each menu appears beside the menu 
name. (For example, press the F2 key to see the File 
Menu.) A shaded option on a menu means that the 
option is not available. Some options have ac- 
celerator keys listed next to them. Use these keys to 
perform tasks without pulling down a menu. For ex- 
ample, when you want to copy highlighted address 
information, you can press CTRL+INSERT to select 
Copy from the Edit Menu (F3). 
This section explains each Address Book menu on 
the menu bar and also contains step-by-step instruc- 
tions on how to use each option on the menus. 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can format mailing 
labels, print form letters and labels, or run another 
DeskMate application. 

Print document.. , 
Print form l e t t e r . ,  , 
Print address,, . 

I Exit 
Run.. . 
About. . . 

Format labels 
Allows you to choose a format for printing mailing 
labels. 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using before you format and print 
the mailing labels. 

Note: If you have a laser printer, Address Book 
takes into account the printer’sprintable area, 
which is smaller than the actual paper size. 

1. Select Format 1 abel s from the File Menu (F2). 

A dialog box appears, listing sorting options and 
several label formats from which you can 
choose. 

2. At the Sorted by prompt, choose Last name or 
Z i  p code to indicate the sort criterion. 

3. At the Format prompt, choose the format that 
matches your mailing labels. 

Note: In addition to formats for stand- 
ard Radio Shack mailing labels, an 
Other option is available. Use this op- 
tion if your labels do not match any of 
the given formats or if you are not 
using a sheet-fed printer or any other 
printer that does not have a continuous 
page feed. If you select this option, a 
dialog box appears so that you can type 
the following information about your 
labels: 

The number of labels across each 
page. 
The number of labels down each 
page. 
The page width (in inches). 
The page height (in inches). 
The label width (in inches). 
The top margin (the number of 
lines you want the printer to skip 
between the top of the page and 
the first line printed). The default 
setting is 0 lines. You can try this 
setting and then change it if the ad- 
dresses print too low. 

4. Select OK to complete the task. 
When you print the labels, they are formatted and 
sorted as specified. The format is saved on disk and 
used each time you print. If you change printer or 
label types, you should reformat the labels. 
See the various print options for specific printing in- 
structions. 

Print labels 
Prints mailing labels. 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using before you format and print 
mailing labels. (Be sure to see the Format 1 abel s op- 
tion.) 

21 



Deskh4are User’s Reference 

1. 

2. 

3. 

Select A1 1 from the View Menu (F6) to view all 
addresses or By 1 i s t from the View Menu (F6) 
to view the specific list of addresses for which 
you want to print mailing labels. 
If you are going to print mailing labels on 
paper, feed the printing labels into the printer. 
If you are not using a continuous feed printer, 
align the top of the page with the print head. 
If you are using a continuous feed printer, do not 
worry about the vertical alignment of the labels. 
The application lets you choose the line on which 

Select the P r i  n t 1 abe 1 s option from the File 
Menu (F2). 
A dialon box appears. 

to begin printing. 

4. At the P r i n t  t o :  prompt, choose the P r i n t e r  or 
F i  1 e button. 
The P r i  n t e r  button lets you print mailing labels 
on paper (mailing labels). 
The F i  1 e button lets you print mailing labels to a 
file. Printing to a file stores the file on disk, using 
the name you give plus the extension .prn. You 
can then use the MS-DOS Print command to print 
the file from another computer that is not run- 
ning DeskMate. Or, you might send the file to 
another computer, using the Telecom application. 

Note: The printer used to print the file 
from MS-DOS must be the same type as 
the one you are using with DeskMate 
(the one you assigned with the P r i  n t e r  
option on the Setup Accessory‘s Options 
Menu). If ou want to transmit the file 
using D e s k  ate’s Telecom application, 
choose A S C I  I as the printer type. 

5. Follow the appropriate instructions below for 
the button you chose. 

a. Select OK to begin printing. 
A dialog box appears, displaying the mes- 
s a g e A r e t h e 1 a b e l s  c o r r e c t l y  a l i g n e d ?  
Continue with the following steps. 

b. Choose NO so that you can test the align- 
ment of the labels. 

If you chose the P r i n t e r  button: 

The printer prints: 0 
1 
2 xxxxxxx 
3 xxxxxxx 
4 xxxxxxx 
5 
6 

and repeats the X’s for each label in the row. 
When this first test is finished, a dialog box 
appears. 
At the L i n e  number where f i  r s t  1 i ne 
shou ld  beg in :  prompt, type a number in 
the range 0-6, specifying which line the ad- 
dress has to begin on to be properly aligned. 

The printer again prints X’s to let you see 
the new alignment. A message appears 
asking if the alignment is correct. Select 
YES when the alignment is the way you 
want it. The printer then moves to the next 
row of labels. 
Repeat Steps a c  as needed to adjust the 
vertical alignment. 
If necessary, adjust the horizontal align- 
ment by hand. 
When you’re ready to print, select YES at  
the Are t h e  l a b e l s  c o r r e c t l y  a l i g n e d ?  
prompt. 
The labels begin to print, and a dialog box 
appears, containing information about the 
print operation. You can select CANCEL at 
any time to stop the operation. 

At the F i  lename: prompt, type the name 
you want to give the “printed” file, using 
eight or fewer characters. An extension of 
.prn will be added to the filename unless 
you specify otherwise. 

c. 

d. Select OK. 

e. 

f. 

g. 

If you chose the F i  1 e button: 
a. 

Note: Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

b. Select OK to complete the task. 
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Note:  When you return to the desktop, 
you will not see the . rn file (if you 
used that extension) yisted in any 
application’s list box. It does, however, 
reside on the disk. You can view it and 
other files in the directory from the 
desktop’s Files View. 

print document 
prints all the address record information for a 
specific address list or all addresses to another file. 
Printing to a file stores the file on disk as an ASCII 
file, using the name you give plus the extension 
.doc. You can then use the MS-DOS Print command 
to print the file from another computer that is not 
running DeskMate. Or, you might send the file to 
another computer, using the Telecom application. 
The printer used to print the file from MS-DOS must 
be the same type as the one you are using with Desk- 
Mate (the one you assigned with the Printer option 
on the Setup Accessory‘s Options Menu). If you want 
to transmit the file using DeskMate’s Telecom ap- 
plication, choose A X  I I as the printer type. 
1. Select A1 1 from the View Menu (F6) to view all 

addresses or By 1 i s t from the View Menu (F6) 
to view the specific list of addresses that you 
want to print to a file. 

2. Select Print document from the File Menu (F2). 
A dialog box appears. 

3. At the Fi  lename: prompt, type the name you 
want to give the “printed” file, using eight or 
fewer characters. 

Note:  Be sure to type a complete path- 
name of up to 64 characters if you want 
to save the file on a different drive or in 
a different directory. 

4. At the Field delimiter: prompt, type any 
delimiter required by the application that will 
use the new file. (A delimiter is a character, 
such as a comma, that the application uses to 
mark the boundaries between fields.) Leave the 
prompt blank if you want to use a space as the 
delimiter. 

5. Select OK to complete the task. 
When you return to the desktop, you will see the 
.doc file listed in the TEXT list box. 

Print form letter 
Prints a form letter to all the people in the current 
address list. (This option automatically runs the 
mailmrge.pdm program to print form letters.) 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using. Also, be sure to set up your 
page layout using the File Menu’s Page setup option 
in the Text application. 

Note:  If you are using a single-drive diskette- 
based system, the Text file containing the form 
letter must be on the same diskette as the per- 
sonal.adr file. 

1. Use the Text application to create the form let- 
ter. 

2. Use Text’s Add f i el d option on the Layout Menu 
to place the desired Address Book fields (Ti  t 1 e, 
First, Last, and so on) in the document. 

3. In the Address Book application, select A1 1 from 
the View Menu (F6) to view all addresses. 

4. Select Print form l e t t e r  from the File Menu 
(F2). 
A dialog box appears, listing all the available 
Text documents and subdirectories. 

5. At the Open Fi 1 e: prompt, type the name of the 
Text file you want to use or highlight the file 
you want to use in the Fi  1 es k t  box. 

6. Select OK. 
Another dialog box appears, listing all the ad- 
dress lists. 

7.  Highlight the list to which you want to send the 
form letter, or highlight A1 1 to send the letter to 
all addresses. 

Note: When sending a form letter to a 
specific address list, you can take a 
shortcut by using the View Menu’s (P6) 
By 1 i s t option instead of the A1 1 option 
in Step 3. In this case, the application 
prints the form letter based on the cur- 
rent list and does not displa a dialog 
box listing the available ad J ress lists. ’ 

8. Select OK. 
Another dialog box appears. 
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9. At the Print to :  prompt, choose the Screen, 
Printer, or File button. 
The Screen button lets you print form letters on 
the screen so that you can see how the letter 
will look on paper, showing page breaks, mar- 
gins, and so on. 
The Pri nter button lets you print form letters 
on paper. 
The Fi  1 e button lets you print form letters to a 
file. Printing the letter(s) to a file stores the file 
on disk, using the name you give plus the exten- 
sion .pm. You can then use the MS-DOS Print 
command to print the file from another com- 
puter that is not running DeskMate. Or, you 
might send the file to another computer, using 
the Telecom application. 

Note:  The printer used to print the file 
from MS-DOS must be the same type as the 
one you are using with DeskMate (the one 
you assigned with the Printer option on 
the Setup Accessory‘s Options Menu). If 
you want to transmit the file using 
DeskMate’s Telecom application, choose 
ASCI I as the printer type. 

10. Follow the appropriate instructions below for 
the button you chose: 

If you chose the Screen button: 
a. Select OK to complete the task. 

The form letter appears on the screen. You 
can scroll through it or use the Next page 
option on the Options Menu (F2) to View 
the next page. 

b. When you finish viewing the letter(s) on 
the screen, select Exi t from the Options 
Menu (F2) to return to the Address Book 
screen. 

Select OK to begin printing. 
The form letter(s) begins to print, and a 
dialog box appears, containing information 
about the print operation. You can select 
CANCEL at any time to stop the operation. 

If you chose the Printer button: 

Note:  If you chose the Pause between 
pages option when you formatted the 
Text document’s page layout, the 
printer stops to let you change sheets 
of paper when each page finishes print- 
ing. A dialog box appears, asking 
whether you want to reprint the cur- 
rent page. 

To print the next page, insert a new 
sheet of paper, and select NO.  If you 
want to reprint the same page, insert a 
new sheet of paper and select YES. 
Select C A N C E L  to stop the print opera- 
tion. 
When you finish printing, select NO at 
the Reprint current page? prompt. 

At the Fi  lename: prompt, type the name 
you want to give the “printed” file, using 
eight or fewer characters. An extension of 
.prn will be added unless you specify other- 
wise. 

Note:  Be sure to type a complete path 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

b. Select OK to print the form letter(s) to a file. 
Note:  When you return to the desktop, 
you will not see the .prn file (if you 
used that extension) listed in any 
application’s list box. I t  does, however 
reside on the disk. You can view it and 
other files in the directory from the 
desktop’s Files View. 

If you chose the Fi  1 e button: 
a. 

Print address 
Prints the currently displayed address on paper or to 
a file. 
1. Select Print address from the File Menu (Fa). 

A dialog box appears. 
2. At the Print to:  prompt, choose the Printer or 

F i  1 e button. 
The Pri nter button lets you print the current 
address on paper. 
The F i  1 e button lets you print the current ad- 
dress to a file. Printing the address to a file 
stores the file on disk, using the name you give 
plus the extension .prn. You can then use the 
MS-DOS Print command to print the file from 
another computer that is not running DeskMate. 
Or, you might send the file to another com- 
puter, using the Telecom application. 

Note:  The printer used to print the file 
from MS-DOS must be the same type as the 
one you are using with DeskMate (the one 
you assigned with the Pri nter option on 
the Setup Accessory‘s Options Menu). If 
you want to transmit the file using 
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DeskMate’s Telecom application, choose 
ASCI I as the printer type. 

3. Follow the appropriate instructions below for 
the button you chose: 

If you chose the Pri nter button: 
Select OK to begin printing. 
The current address begins to print, and a 
dialog box appears, containing information 
about the print operation. You can select 
C A N C E L  at any time to stop the operation. 

a. At the F i  lename: prompt, type the name 
you want to give the “printed file, using 
eight or fewer characters. An extension of 
.pm will be added to the filename unless 
you specify otherwise. 

If you chose the F i  1 e button: 

Note:  Be sure to type a complete path 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

Select OK to print the current address to a 
file. 

b. 

Note:  When you return to the desktop, 
you will not see the .prn file (if you 
used that extension) listed in any 
application’s list box. It does, however 
reside on the disk. You can view it and 
other files in the directory from the 
desktop’s Files View. 

Exit 
Exits the Address Book application and returns you 
to the desktop. 

If you are working on an address when you exit the 
application, Address Book displays a dialog box with 
a message asking if you want to save changes to the 
record before quitting. Select YES to save the chan- 
ges, N O  to exit the application and not save the chan- 
ges, or C A N C E L  to return to the current record in the 
Address Book. 
The desktop screen appears. 

Select Exit from the File Menu (F2). 

Run 
Runs another DeskMate application file, or runs 
another software package without returning to the 
desktop. 
1. Select Run from the File Menu (F2). 

2. At the Program: prompt, type the name of the 
A dialog box appears. 

application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current direc- 
tory, type a full pathname, including the drive 
and directory. 

3. At the Data f i 1 e : prompt, either type the name 
of the file you want to use with the chosen ap- 
plication (or program) or leave the prompt 
blank. 
If you leave the prompt blank, DeskMate runs 
the application or program you specify without 
opening a corresponding file. 

4. Select OK to complete the task. 
DeskMate might ask you to insert the diskette con- 
taining the application or software package you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the desktop.pdm file. After you insert the 
diskette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run this program. 
1. Select About from the File Menu (P2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 
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Edit Menu 
The Edit Menu (F3) options let you edit your Ad- 
dress Book information. For example, you can move 
information from one address record to another, 
delete address information, or undo your last editing 
task. 

cut 
Cuts (or removes) highlighted information in a field 
and places it on the Clipboard. 
1. Highlight the information you want to remove. 

For more specific instructions on higlilighting Ad-  
dress Book information, see “Highlight Informa- 
tion” in the “Other Address Book Information” 
section. 

2. Select C u t  from the Edit Menu (F3). 
Address Book removes the highliglited information 
from the current location and places it on the Clip- 
board. 
To place the Clipboard information into another ad- 
dress, another application, or at another location in 
the same address use the Edit Menu’s (F3) Paste op- 
tion. 

COPY 
Copies highlighted information in a field to the Clip- 
board. 
1. Highlight the information you want to copy. 

For more specific instructions on higliligliting Ad- 
dress Book information, see “Higliliglit Informa- 
tion” in the “Other Address Book Information” 
section. 

2. Select Copy from the Edit Menu (F3). 
Address Book copies the highlighted information to 
the Clipboard. 

To place the copied information into another ad- 
dress, another application, or at another location in 
the same address use the Edit Menu’s (F3) Paste op- 
tion. 

P a s t e  
Inserts cut or copied information (Clipboard informa- 
tion) at the cursor location. 

1. Move the cursor to the field in which you want 
to place the Clipboard information. 

2. Select Paste from the Edit Menu (P3). 
3. Address Book inserts the Clipboard information 

at the cursor location. 
Notes:  

When inserting information into a 
field that already contains informa- 
tion, you must unhighlight the field 
before selecting Paste. To do this, 
simply press +. You are then ready 
to position the cursor as desired 
and insert the information. 
Be sure to save the changed ad- 
dress by selecting any Address 
Book option other than an Edit 
Menu (F3) option. 

C l e a r  
Deletes highlighted address information. 
1. Highlight the information you want to change 

or delete. 
~~~ ~ 

For more spec@ instructions on Iiiglilighting Ad- 
dress Book information, see “Highlight lnforma- 
tion” in the “Other Address Book Information” 
section. 

2. Select C1 e a r  from the Edit Menu (F3). 
Note:  If you want to change the high- 
lighted information, you can type over 
the information without using the 
c1 e a r  option. 

The information you highlighted disappears from 
the screen and is no longer part of the address. 
When you save the changed address (by selecting 
any Address Book option other than an Edit Menu 
(F3) option), Address Book automatically makes the 
change everywhere that the address appears in the 
book. 
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Undo 
changes an address back to the way it was the last 
time it was stored on disk. 

Note: The Undo option is only available after you 
have used an Edit Menu (F3) option and before 
you have used another option from a different 
menu. 
Select Undo from the Edit Menu (F3). 

Address Book undoes the changes. Or, if the address 
was new, Address Book clears all the fields and 
takes you back to where you were before you made 
the change. 

List Menu 
The List Menu (F4) options let you create special- 
ized address lists, delete a list, or merge two lists. 

New 
Creates a specialized address list. You can have as 
many as 25 specialized lists. 
1. Select New from the List Menu (F4). 

2. At the L i  s t name: prompt, type a name for the 

3. Select OK to complete the task. 

A dialog box appears. 

new list, using 20 characters or fewer. 

Address Book creates the new list and opens it so 
that you can begin adding addresses to it. The status 
line at the top of the screen changes to reflect the 
name of the new current list. The Member O f  list box 
also displays the list name (up to 15 characters). 

Delete 
Deletes any address list from anywhere in the book. 

Note: Deleting a list does not delete the addres- 
ses in that list. The addresses still appear in the 
Index list box when you use the View Menu’s A1 1 
option. To delete addresses, you need to use 
either Delete  or Del e t e  from 1 i s t on the Address 
Menu (F5). 

1. Select D e l e t e  from the List Menu (F4). 
A dialog box appears, listing all available ad- 
dress lists, including the current list. 

2. Highlight the list you want to delete. 
3. Select OK to complete the task. 

Address Book deletes the list. If the currently dis- 
played address was a member of that list, you will 
notice that the list name no longer appears in the 
Member O f  list box. 

Note: If you delete the current list, the applica- 
tion automatically selects the View Menu’s (F6) 
A1 1 option so that you can view all addresses in 
the book. 

Merge 
Inserts all the addresses from another list into the 
current list. 
1. Select By 1 i s t from the View Menu (F6) to 

view the list into which you want to merge the 
addresses. 

A dialog box appears, listing the available address 
lists. 

3. At the Merge from prompt, highlight the name 
of the list you want to merge into the current 
list. 

2. Select Merge from the List Menu (F4). 

4. Select O K  to complete the task. 
Address Book adds the addresses in the other list to 
the current list automatically. The Index list box 
reflects the changes. Note that the list from which 
you merged addresses remains the same. , 
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Address M e n u  
The Address Menu (F5) options let you work with 
your address records. For example, you can add or 
copy an address, add an address to a different list, 
find a specific address, or automatically dial a phone 
number (if you have an auto-dial modem). 

Add 
Adds the current address information to the current 
list. 
1. Select Add from the Address Menu (F5). 

A blank address record appears. 
Note: When you first open Address 
Book or a specific list, the Add option is 
already selected and you do not need to 
do this step. 

2. Type the information needed to complete each 
field of the record, pressing TAB and 
SHIFT+ TAB to move forward and backward 
from field to field. You must type something in 
the Last field, but all other information is op- 
tional. The fields are discussed below. 

As you move among the fields, the name of the field 
you are in (the current field) appears in the status 
line at the bottom of the screen. 
When you finish typing information on the address 
record, use the Add option again to continue adding 
addresses. Or, select another Address Book option 
(other than an Edit Menu (F3) option). Addresses 
you add or update are immediately stored on disk 
when you display another blank record or use 
another option. Address records are automatically 
stored alphabetically by last name. 

Title. Type a courtesy title such as Mr., Mrs., or Dr., 
using up to ten characters. 
First. Type a first name using up to 18 Characters. 
You can press -, or to scroll the name sideways. 
Last. Type a last name using up to 20 characters. 
Address Book automatically sorts addresses al- 
phabetically according to whatever information you 
type in this field. 
If you do not want to use a last name, you can leave 
the F i  rs t field blank and type the first name, such 
as Dad or Helen, in the Last field. In this case, the ad- 
dress is grouped with those addresses for which you 
entered last names: 

Anderson, S y l v i a  
Dad 
F i  n k i  ey, Henry 
He1 en 

Another option is to type the first name in the F i rs t 
field and a space in the Last field. In this case, the 
address appears before those for which you typed 
last n ames: 

, Dad 
, Helen 
Anderson, Syl v i  a 
F i  n k l  ey, Henry 

If you type nothing in the Last field, the message A 
las t  name i s  required appears whenyoutryto 
select another option. Select O K  to remove the mes- 
sage so that you can type a name or a space. 
Address Fields. The address fields are not labeled 
on the record, but their names appear in the status 
line at the bottom of the screen as you move 
through them. Type a street address (up to 43 char- 
acters), city (up to 20 characters), state (up to eight 
characters), and zip code (up to ten characters). 
Company name. Type a company name ushg up 
to 29 characters. 
Work and Home. Type a work and/or home 
phone number in the format that suits you, such as 
555-555-1000 or (555)555-1000. I t  will be easier, 
when you are searching for address information, if 
you use the same format for all phone numbers. You 
can type up to 20 characters in each phone number 
field. 
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Dates to Remember.  These two fields (Date One 
and Date Two) let you type special dates in any of 
the following formats: mm-dd-yy, mm-dd-Dyy, 
mm/dd/jy, or mm/dd/'yy. It will be easier, when 
you are searching for address information, if you use 
the same format for all dates. The labels Birthday 
and Anniversary are provided as defaults, but you 
can highlight and type over these labels if you want 
to use the fields for another date. You can type up to 
12 characters in these fields. 
Notes.  Type any notes about the current address in- 
formation ushg up to 40 characters. 

COPY 
Copies the current address information to the same 
address list. This option is handy if you want to add 
an address whose information will vary only slightly 
from the information in an existing address. 
1. Display the address you want to copy. 
2. Select Copy from the Address Menu (F5). 

The address you now see is the copy, and it contains 
the same information as the original. Change the in- 
formation as needed. 

Delete 
Deletes an address from the entire Address Book. 

1. 

2. 

3. 

Note: Use the Address Menu's (F5) Delete from 
1 i s t  option if you want to delete an address from 
only one list. 
From within any list in the address book, dis- 
play the address you want to delete. 
Select Delete from the Address Menu (F5). 
A dialog box appears, asking whether you are 
sure you want to delete the address. 
Select OK to complete the task. 

The address no longer exists anywhere in the ad- 
dress book. It disappears from the screen and the 
Index list box. 

Add to list 
Adds the current address to another list. 
1. Select Add t o  1 i s t  from the Address Menu (F5). 

A dialog box appears, listing all available address 
lists. 

the displayed address. 
2. Highlight the list(s) to which you want to add 

Note:  To highlight consecutive lists, 
press SHIFT+ 4. To highlight non-con- 
secutive lists, highlight the first list, 
ress CTRL+ J to move down the list g ox, and then press 
CTRL+SPACEBAR on each list you 
want to highlight. 

3. Select O K  to complete the task. 
The dialog box disappears, and the list(s) that 
you chose appear in the Member O f  list box. 

Delete from list 
Deletes an address from a specific list or multiple 
lists. 
1. From within any list, display the address you 

want to delete. 
The Member Of list box shows which list@) the dis- 
played address belongs to. 

2. Select De 1 e te  from 1 i s t from the Address Menu 
(F5). 
A dialog box appears, listing all the address lists. 

delete the specified address. 
3. Highlight the list(s) from which you want to 

Note:  To highlight consecutive lists, 
press SHIFT+ J. To highlight non-con- 
secutive lists, highlight the first list, 
ress CTRL+ J to move down the list E ox, and then press 
CTRL+ SPACEBAR on each list you 
want to highlight. 

4. Select OK to complete the task. 
The dialog box disappears, and the previously dis- 
played address reappears (assuming you did not 
delete it from the current list). If you did delete it 
from the current list, the screen displays the first ad- 
dress in the current list. 

Find 
Finds occurrences of specific address information. 
1. Select A1 1 from the View Menu (F6) to view all 

addresses or By 1 i s t from the View Menu (F6) 
to view a specific list of addresses. 

A dialog box appears. 

that you want to find, using a maximum of 37 
characters. 
The characters you type are enclosed in brackets. 

2. Select F i n d  from the Address Menu (F5). 

3. At the Search for: prompt, type the characters 
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4. Select OK to begin the search procedure. 
Address Book searches the entire list for the 
specified information, ignoring upper-/lowercase dis- 
tinctions. For example, if you are searching for com- 
pany, Address Book finds occurrences of 
Company, COMPANY, company, and any other 
upper-/lowercase variations of the word. 
If the search is successful, the first address that 
contains the specified character is displayed. If 
Address Book cannot find the characters, you see 
the message There are no m a t c h i n g  records i n  
t h i  s 1 i s t. Select OK to remove the message from the 
screen. 
If there are no other occurrences, you see the mes- 
sageThis i s  the las t  matching record i n  this 
1 i s t. Select OK to remove the message from the 
screen. 
To find subsequent occurrences of the same informa- 
tion, use the Address Menu’s (F5) F i n d  next option. 

Find next 
Finds the next occurrence of information you 
wanted to locate, using the Address Menu’s (F5) 
F i n d  option. 

Select Find next from the Address Menu (F5). 

If there are no other occurrences, you see the mes- 
sage This i s  the las t  matching record i n  this 
1 i s t. Select OK to remove the message from the 
screen. 

Call 
Automatically dials a phone number if you have an 
auto-dial modem. 

1. 

2. 

3. 

4. 

Note: You must have an auto-dial modem con- 
nected to your computer to use this option. 
Display the address containing the phone num- 
ber you want to dial. 
Place the cursor on the work or home phone 
number you want to call, or highlight a phone 
number in the Notes box. 
Select C a l l  from the Address Menu (F5). 
A dialog box appears, displaying the phone num- 
ber you are calling. 
When the person you are calling answers the 
phone, pick up the telephone receiver and select 
CANCEL to disconnect the modem from the line. 

View Menu 
The View Menu (F6) options let you view the ad- 
dresses in your master list or a specialized list. 

~ 1 
By list ... 

All 
Lets you view all the addresses in Address Book. 

Address Book displays the first address in the book. 
You can now use the I ndex list box to display other 
addresses. 

Note:  When you exit Address Book, the applica- 
tion “remembers” what you were viewing last (all 
addresses or a particular list) and returns to that 
view when you next run the application. 

Select A1 1 from the View Menu (F6). 

By list 
Lets you view an address in any specific list. 
1. Select By 1 i s t from the View Menu (F6). 

2. Highlight the name of the list you want to view. 
3. Select O K  to complete the task. 

A dialog box appears. 

Address Book displays the first address in the 
specified list. You can now use the Index list box to 
display other addresses in the list. 

Note:  When you exit Address Book, the applica- 
tion “remembers” what you were viewing last (all 
addresses or a particular list) and returns to that 
view when you next run the application. 
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Address Book 
Tasks 
This section lets you look up Address Book applica- 
tion tasks. The tasks are listed alphabetically, and 
the name of the menu and the option(s) needed to 
perform the task are listed beneath the task. If you 
don’t know how to use an option, see the “Menu Op- 
tions” section for detailed information and step-by- 
step instructions. 
Add an Address 

Address F5 (Add) 
Add an Address to Another List 

Address F5 (Add t o  1 i s t )  
change an Address 

Edit F3 (C1 ear)  
Copy an Address 

Address F5 (Copy) 
Correct an Error 

Edit Menu F3 (C1 ear) 
Edit Menu F3 (Undo) 

Create a Specialized List 
List F4 (New) 

Delete a List 
List F4 (Delete) 

Delete an Address from a List 
AddressF5 (Delete from l i s t )  

Delete an Address from the Entire Book 
Address F5 (Delete) 

Delete Information from a Field 
Edit F3 (C1 ear) 

Dial a Phone Number 
Address F5 (Cal l )  

Display a ProgranVApplication Name and Version 
Number 

Duplicate Information to Another Address 
File F2 (About) 

Edit F3 (Copy) 
View F6 (A1 1 or By 1 i s t )  
Edit F3 (Paste) 

Edit F3 (Copy) 
File F2 (Run) 
Edit F3 (Paste) 

Edit F3 (Copy) 
Edit F3 (Paste) 

Duplicate Information to Another Application 

Duplicate Information Within the Same Address 

Erase Address Information 
Edit F3 (C1 ear) 

Exit Address Book 
File F2 (Ex i t )  

Find an Address 
View F6 (A1 1 or By 1 i s t) 
Address F5 ( F i  nd) 
Address F5 (F ind next )  

Format Mailing Labels 
File F2 (Format 1 abel  s) 

Merge a List Into the Current List 
ViewF6 (By l i s t )  
List F4 (Merge) 

Edit F3 (Cut) 
View F6 (A1 1 or By 1 i s t )  
Edit F3 (Paste) 

Edit F3 (Cut) 
File F2 (Run) 
Edit F3 (Paste) 

Edit F3 ( C u t )  
Edit F3 (Paste) 

Print a Form Letter 
View F6 (A1 1) 
View F6 (By 1 i s t )  
File F2 ( P r i n t  form l e t t e r )  

ViewF6 ( A l l  orBy l i s t )  
File F2 ( P r i n t  document) 

Print the Current Address Record 
File F2 ( P r i n t  address) 

Print Mailing Labels 
ViewF6 ( A l l  orBy l i s t )  
File F2 (Format l a b e l s )  
File P2 (Print 1 abel SI 

Print Phone Numbers 
Phone List Accessory 

Run Another Application 
File F2 (Run) 

Undo Editing 
Edit F3 (Undo) 

View Addresses by List 
View F6 (By 1 i s t )  

View All Addresses 
View F6 (A1 1) 

Move Information to Another Address 

Move Information to Another Application 

Move Information Within the Same Address 

Print Address Records to a File 
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Other 
Address Book 
Information 
Correct an Error 
If you make an error as you are typing information 
in a field, you can press either BACKSPACE or 
DELETE to make corrections. Pressing BACK- 
SPACE erases the character immediately preceding 
the cursor. Pressing DELETE erases the character 
the cursor is on. 
You can also use the Edit Menu’s C 1  e a r  and Undo op- 
tions to correct errors. The C l e a r  option erases high- 
lighted information in a field. The Undo option 
removes all changes made to the address since it 
was last stored on disk. Or, if the address is new, 
Undo erases all the information in all the fields. 

High 1 igh t Information 
When you move the cursor to any field that already 
contains information, Address Book automatically 
highlights all the information in the field. You can 
then type over the information or use an Edit Menu 
(F3) option. 
You can also reverse highlight any part of the infor- 
mation for typing over or editing. To do this, use the 
arrow keys to move to the first character you want 
to edit. Then, press SHIFT+- or SHIFT+- to 
reverse highlight as much as you want. Or, with the 
mouse, move the cursor to the first character you 
want to edit, and then drag the mouse to reverse 
highlight. 
To unhighlight information, press + or + (or click 
the mouse button). 

Print Phone Numbers 
Use the Phone List accessory to print telephone infor- 
mation for each person in your address book (the 
person’s name, work or home phone number, and 
any information in the Not e s field). See the “Acces- 
sories” chapter for more information. 

Note: You cannot print phone information by list. 

View an Address in the 
Current List 
Use the Index  list box on the left side of the screen 
to display any address in the current list. 

Select the name, either by using the arrow keys 
or by pointing and clicking with a mouse. 

To scroll in the list, you can use the arrow keys. You 
can also type the initial letter of the name you are 
seeking. 
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Calendar 
Overview 
What Is It? 
With DeskMate's Calendar application, an organized schedule can be right 
at your fingertips. Using Calendar, you can schedule activities, remember an- 
nual occasions (such as birthdays), and record daily reminders. 

What Can I Do with It? 
With Calendar's many features, it is easy to maintain 
up-to-date schedule information. In addition to 
simple schedule maintenance, you can: 

Create different calendars to meet your schedule demands 
Print your calendar information for quick and easy accessibility 
Look up calendar information quickly and easily 
Set alarms to remind you about appointments 
Schedule weekly, monthly, and yearly appointments or meetings 

How Do I Use I t?  
When you open the Calendar application, a screen similar to the one at the 
right appears. 
The first time you nu^ this application, DeskMate automatically creates the 
pemnal.cal file and a calendar named PERSONAL. The name of the calendar 
appears on the title bar. 
The Calendar screen displays a calendar for the correct month and day. Any 
major holidays that fall in the displayed month are marked with the + icon. 
There are four different ways to view Calendar information. You can display 
a daily calendar, which gives you more detailed information about any 
schedule information or reminders. The weekly or monthly calendar lets you 
see at a glance whether you have things scheduled during the week or 
month. You can also display a yearly calendar, which displays six months at 
a time on the screen and you can see which days you have scheduled events 
or activities. 
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To add an activity or event to a calendar, use the Event Menu’s (F6) Add op- 
tion. You can then enter information about the event, annual occasion, or 
reminder, and DeskMate adds the activity to the calendar. The event or ac- 
tivity appears on the calendar regardless of how the calendar is displayed. 
As you schedule appointments and reminders in your calendar(s) you might 
want to use DeskMate’s Alarm Accessory to set an alarm. Then, when your 
appoktment time arrives, DeskMate will sound a beep and you can display 
a message to remind you of your appointment. 
You can also enter annual events, such as birthdays and anniversaries, by 
using the Annual occasion option on the Event Menu (F6). These events are 
added to your calendar for not only the current year, but all subsequent 
yew. 
As your calendar fills up with schedule information, you can use other Calen- 
dar options to search through your calendar for a specific activity, move in- 
formation between calendars, print a copy of your calendar, create new 
calendars, and so on. 
To learn the basics about using Calendar, see the “Calendar“ article in the 
Getting Starred magazine. Then, when you’re familiar with Calendar, this 
chapter will provide you with a quick way to answer specific questions. You 
can look up the step-by-step instructions for each menu option. If you want 
to know which options to use to perform a specific task, check the “Calendar 
Tasks’’ section at the end of this chapter. 
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Menu Options 
Calendar has six menus that list the options you can 
use with the application. The key that you press to 
see each menu appears beside the menu name. (For 
example, press the F2 key to see the File Menu.) A 
shaded option on a menu means that the option is 
not available. Some options have accelerator keys 
listed next to them. Use these keys to perform tasks 
without pulling down a menu. For example, when 
you want to display a daily calendar, you can press 
CTRL + D to select D a i 1 y from the Display Menu 

This section explains each Calendar menu on the 
menu bar and also contains step-by-step instructions 
on how to use each option on the menus. 

(F4) * 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can format your 
page layout, print Calendar information, or run 
another DeskMate application. 

Page setup 
Lets you specify that you want the printer to pause 
between pages. This feature is helpful if you are not 
using continuous-feed paper. All the other Page 
setup fields are automatically set for you. 
1. Select Page setup from the File Menu (F2). 

2. If necessary, choose the Pause between pages 

3. Select OK to complete the task. 
When you print your Calendar information, Desk- 
Mate will pause between the pages. 

A dialog box appears. 

check box. 

Print 
Lets you print Calendar information to the screen, 
on paper, or to a file. 
Be sure to use the Pr i n t e r option on the Setup 
Accessory's Options Menu to tell DeskMate the type 
of printer you are using. Also, if you are not using 
continuous-feed paper, be sure to turn on the Pause 
between pages option using the File Menu's (F2) 
Page setup option. (All other Page setup options are 
preset.) 
1. Select Print from the File Menu (F2). 

2. At the S t a r t  date: prompt, channe the date, if 
A dialog box appears. 

3. 

4. 

5.  

necessary, and type'the earliest date (using the 
format rnrnddyyyy) you want to print. 
At the End date: prompt, change this date, if 
necessary, and type the last date (using the for- 
mat mrnddyyyy) you want to print. 
Select OK. 
Another dialog box appears so that you can 
specify the device you want to use to print this 
calendar. 
At the Print t o :  prompt, choose the Screen, 
Printer, or File button. 
The Screen button lets you print the currently dis- 
played daily, weekly, monthly, or yearly calendar 
on the screen. Printing on the screen lets you see 
how the calendar will look on paper. 
The Pri nter button lets you print the currently 
displayed daily, weekly, monthly, or yearly calen- 
dar on paper. 
The F i 1 e button lets you print the currently dis- 
played daily, weekly, monthly, or yearly calendar 
to another file. Printing to a file stores the file on 
disk, using the name you give plus the extension 
.prn. You can then use the MS-DOS Print com- 
mand to print the file from another computer 
that is not running DeskMate. Or, you might send 
the file to another computer, using the Telecom 
application. 

Note: The printer used to print the file 
from MS-DOS must be the same type as the 
one you are using with DeskMate (the one 
you assigned with the Pri nter option on 
the Setup Acccessorfs Options Menu). If 
you want to transmit the file using 
DeskMate's Telecom application, choose 
ASCI I as the printer type. 
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6. Follow the appropriate instructions below for 
the button you chose in Step 5. 

If you chose the Screen button: 
a. 

b. 

Select OK to complete the task. 
The calendar prints on the screen. You can 
scroll through it using the arrow keys or 
use the Next page option on the Options 
Menu (Fa) to View the next page. 
When you finish viewing the calendar on 
the screen, select E x i  t from the Options 
Menu (F2). 
The normal Calendar screen is redisplayed. 

If you chose the Pri nter button: 
Select OK to begin printing. 
The document begins to print, and a dialog 
box appears, containing information about 
the print operation. You can select CANCEL 
at any time to stop the operation. 

Note: If you chose the Pause between 
pages option when you formatted the 
page layout, the printer stops to let you 
change sheets of paper when each page 
finishes printing. A dialog box appears, 
asking whether you want to reprint the 
current page. 
To print the next page, insert a new 
sheet of paper, and select NO. If you 
want to reprint the same page, insert a 
new sheet of paper, and select YES. 
Select CANCEL to stop the print opera- 
tion. 
When you finish printing. Select NO at 
the Reprint current page? prompt. 

At the Fi  lename: prompt, type the name 
you want to give the “printed” file, using 
eight characters or fewer. A n  extension of 
.prn will be added to the filename unless 
you specify otherwise. 

If you chose the Fi 1 e button: 
a. 

Note:  Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

b. Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .prn file (if you used 
that extenstion) listed in any application’s 
list box. It does, however, reside on disk. 
You can view it from the desktop’s Files 
View. 

Note: The printed monthly calendar 
does not include the bar graphs that in- 
dicate the level of activity for a given 
day. 

Exit 
Exits the Calendar application and returns you to 
the desktop. 

The desktop screen appears. 

Run 
Runs another DeskMate application file or runs 
another software package without returning to the 
desktop . 

Select E x i  t from the File Menu (F2). 

1. 

2. 

3. 

4. 

Select Run from the File Menu (F2). 
A dialog box appears. 
At the Program: prompt, type the name of the 
application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current direc- 
tory, type a full pathname, including the drive 
and directory. 
At the Data f i 1 e: prompt, either type the name 
of the data file you want to use with your 
chosen application (or program) or leave the 
prompt blank. 
If you leave the prompt blank, DeskMate runs the 
application or program without opening a cor- 
responding data file. 
Select OK to complete the task. 

DeskMate might ask you to insert the diskette con- 
taining the application or software package you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the desktop.pdm file. After you insert the 
diskette and select OK, you return to the desktop. 
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About  
Displays the program name, version number, and 
the files DeskMate uses to run this program. 
1. Select About from the File Menu (F2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Edit Menu 
The Edit Menu (F3) options make it easy for you to 
edit your Calendar information. For example, you 
can move information around, duplicate it without 
retyping, or remove unwanted information. 

Cut  
Cuts (or removes) a highlighted event and places it 
on the Clipboard. 
1. Highlight the event you want to remove. 

For more specific instructions on highligliting 
events, see “Highlight Events” in the “Other Calen- 
dar information” section. 

COPY 
Copies a highlighted event to the Clipboard. 
1. Highlight the event you want to copy. 

For more specific instructions on highlighting 
events, see “Highlight Events” in the “Other Calen- 
dar information” section. 

2. Select Copy from the Edit Menu (F3). 
DeskMate copies the highlighted event to the Clip- 
board. 
To place the copied event into another calendar or 
application, use the Edit Menu’s (F3) Paste option. 

Pas te  
Inserts cut or copied calendar information (Clip- 
board information) at the cursor location. 
1. Move the cursor to where you want the infonna- 

2. Select Paste from the Edit Menu (F3). 
tion to appear. 

DeskMate inserts the Clipboard information at the 
cursor location. 

Clear  
Deletes a highlighted event from your calendar. 
1. Highlight the event you want to delete on the 

2. Select C 1  e a r  from the Edit Menu (F3). 
daily calendar. 

DeskMate deletes the event from your calendar. 

2. Select Cut from the Edit Menu (F3). 
DeskMate removes the highlighted event from the 
current location and places it on the Clipboard. 
To place the Clipboard information into another 
calendar or application, use the Edit Menu’s (F3) 
Paste option. 
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Display Menu 
The Display Menu (F4) options let you display a 
daily, weekly, monthly, or yearly view of your calen- 
dar and scheduled events. 

Ueekly CtrltW 
dtlonthly Ctrltn 

Daily 
Displays a list of events for a specific day. 
1. Highlight any date you want to display on a 

2. Select Dai 1 y from the Display Menu (F4). 
weekly or monthly calendar. 

DeskMate displays the daily calendar for the date 
you highlighted. This calendar shows the day of the 
week, the month, and the year, as well as a notation 
if the day is a holiday. Your scheduled events appear 
in chronological order on the screen, complete with 
their descriptions. 
Note that you cannot change or delete holiday nota- 
tions. When you move the cursor to a holiday, you 
see only a blinking underline instead of the normal 
highlight. 

Weekly 
Displays a weekly calendar. 
1. Highlight a date in the week you want to dis- 

play on a daily or monthly calendar. 
2. Select Weekly from the Display Menu (F4). 

DeskMate displays a calendar for the week you 
specified. 
The calendar is in "grid" form. The days of the week 
and their dates appear down the left side of the grid, 
and the times of the day appear across the top of the 
grid. 

Each day on the weekly calendar is a 24-hour 
period. You can scroll continuously through a 24- 
hour day by pointing to and clicking on the arrow 
buttons or pressing the keyboard's arrow keys. 
Holidays are marked with the diamond indicator 
and are displayed in a box at the bottom of the 
screen when the appropriate day is highlighted. 
Each section of the grid represents a time slot of 15 
minutes. Time slots that are already scheduled ap- 
pear shaded so that you can quickly see how busy 
your schedule is for the week. 
Events that overlap appear in a solid fill or darker 
color so that you can clearly see schedule conflicts. 

Monthly 
Displays a monthly calendar. 

DeskMate displays the monthly calendar for the cur- 
rently highlighted date. 
Diamond markers appear to indicate holidays and 
annual occasions. 
A bar graph indicates activity level for a 12-hour 
day. The 12 vertical graph lines correspond to the 
time slot information currently scheduled on the 
weekly calendar from 8:OO a.m. to 8:OO p.m. Each 
vertical line can be up to four segments in length 
with each segment representing 15 minutes. A verti- 
cal line is added to the bar graph each time you add 
an activity to the calendar. 

Yearly 
Displays a yearly calendar. 

Select Yearly from the Display Menu (F4). 
A calendar for the current year appears. 
Days with special occasions and/or holidays appear 
with dates that are a different color. You see only six 
months of the year at one time. To see the remain- 
ing months, use the arrow keys to scroll the screen, 
or point to the scroll arrow buttons and click the 
mouse button. 

1. Select Monthly from the Display Menu (P4). 
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Search Menu 
The Search Menu (F5) options let you quickly locate 
specific Calendar information. 

I Today’s date 

Find 
Searches DeskMate’s Calendar for a specific se- 
quence of text characters. 

Note: You can only search for description infor- 
mation with this option. The Fi nd option does 
not locate notations such as Annual Occasion, 
Reminder, and so on. 

1. Select F i n d  from the Search Menu (F5). 
A dialog box appears. 

2. At the Search for: prompt, type the characters 
you want to find, using a maximum of 25 char- 
acters. 
The characters you type are automatically 
enclosed in brackets. 

3. At the Start date: prompt, type a new date 
(using the mmddyyyy format) if you want to 
start the search at a different date. 

(using the mmddyyyy format) if you want to 
end the search at a different date. 

4. At the End date: prompt, type a new date 

5. Select OK to complete the task. 
Calendar begins searching for the specified text. If 
Calendar finds the information, the daily calendar 
that contains those characters appears on the screen, 
and the event time is highlighted. If Calendar cannot 
find the Characters you specified, you see the mes- 
SageNooccurrences of the  search string were 
found. Select OK to remove this message from the 
screen. 

To find subsequent occurrences of the same text, use 
the Search Menu’s (P5) Fi nd next option. 

Find next 
Finds the next occurrence of information you 
wanted to locate using the Search Menu’s (F5) F i  nd 
option. 

The next occurrence is highlighted. 
If there are no other occurrences, you see the No 
occurrences of  the search string were found mes- 
sage. Select OK to remove the message from the 
screen. 

Find date 
Finds a specific date on a calendar. 

Select F i n d  next from the Search Menu (F5). 

1. Select F i n d  date from the Search Menu (F5). 
A dialog box appears. 

find in the format mmddyyyy. 
Note: You must enter a valid date between 

2. At the Date: prompt, type the date you want to 

01-01- 1980 to 12-30-2040. 
3. Select OK to complete the task. 

DeskMate displays the calendar for the date YOU 
chose. 

Today’s date 
Quickly returns you to the current date after com- 
pleting work on future or past scheduling tasks. 

Select Today’s date from the Search Menu (F5). 
The calendar you are currently using is updated to 
reflect the current date (the date that appears on the 
title bar). 
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Event Menu 
The Event Menu (F6) options make it easy for you 
to schedule events, reminders, or annual occasions 
on your calendar. In addition, you can change or 
remove schedule information as necessary. 

hnual  occasion.. . i Reminder.. . I 
Add 
Schedules activities and events on your calendar. If 
you are adding an event using a daily, monthly or 
yearly calendar, skip Step 2 below. If you are using a 
weekly calendar, perform Step 2 so that you can 
highlight the time slot for your event. You can select 
the beginning and ending times for the event before 
you add the event. 
1. 
2. 

3. 

4. 

5. 
6. 

7. 

Highlight the event date on a calendar. 
If you are using a weekly calendar, you can high- 
light the time slot for the event. 
Select Add from the Event Menu (F6). 
A dialog box appears, and the displayed date is 
the highlighted date on the current calendar. (If 
you need to change the date, move the cursor to 
the Event date: field, and type a new date in the 
format mmddyyyy.) 
At the Start t i  me: prompt, type the time in the 
format hhmm. 
Choose the AM or PM button. 
At the End time: prompt, type the time in the 
format hhmm. 
Choose the AM or PM button. 

8. At the Description: prompt, type the descrip- 

9. Choose the A1 arm check box to set the alarm. 
tion using 120 characters or fewer. 

You can set an alarm to sound at the time of the 
event. When an “X” is in the A1 arm check box, an 
alarm goes off at the time you set the event. It is 
recommended that you set the time earlier than 
the actual event. 
If you have not turned on the alarm using the 
Alarm Accessory, DeskMate reminds you to do so. 
Select OK to remove the message from the screen. 

10. Select OK to complete the task. 
DeskMate adds the event to your calendar, and it 
can be viewed by displaying the daily, weekly, or 
monthly calendar for the indicated date. 

Note: Calendar rounds start times and end times 
to the quarter hour, (back for start times, forward 
for end times). 

Change 
Changes a reminder, event, or annual occasion on 
the current calendar. 
1. Highlight Reminder or A n n u a l  Occasion on a 

daily calendar, or the event on a daily or weekly 
calendar you want to change. 

A dialog box appears. 

of information you are changing: 

2. Select Change from the Event Menu (F6). 

3. Follow the appropriate instructions for the type 

If you are changing a reminder: 
a. 

b. 

Atthe Description: prompt, type the new 
description, using 60 characters or fewer. 
Select OK to complete the task. 
DeskMate changes the reminder, and it ap- 
pears on all daily calendars. 

If you are changing an event: 
a. 

b. 

C. 

At the Event date: prompt, type a new 
date, if necessary, using the format 
m mddyyyy . 
At the Start time: prompt, type a new 
time, if necessary, in the format hhrnm. 
Choose the AM or PM button. 
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d. At the End t i  me : prompt, type a new time, 
if necessary, in the format hhmm. 

e. Choose the AM or PM button. 
f. Atthe Description: prompt, type a new 

description, if necessary, using 120 charac- 
ters or fewer. 
You can set an alarm to sound at the time 
of the event. When an “X” is in the A1 arm 
check box, an alarm goes off at the time 
you set the event. It is recommended that 
you set the time earlier than the actual 
event. 
Choose the A1 arm check box to set the 
alarm. 
If you have not turned on the alarm using 
the Alarm Accessory, DeskMate reminds 
you to do so. Select OK to remove the mes- 
sage from the screen. 

h. Select OK to complete the task. 
DeskMate changes the event as you 
specified. 

At the Date o f  occasion: prompt, change 
the date, if necessary, using the format 
mmdd. 

description, if necessary, using 30 charac- 
ters or fewer. 
Select OK to complete the task. 
The changes appear in all yearly references 
to this annual occasion. 

g. 

If you are changing an annual occasion: 
a. 

b. AttheDescription: prompt,typeanew 

c. 

Remove 
Deletes a reminder, event, or annual occasion from a 
calendar. 
1. Highlight Reminder, A n n u a l  Occasion, or the 

event you want to delete on a daily calendar. 
2. Select Remove from the Event Menu (F6). 

A dialog box appears. 
3. Choose either the T h i s  event on ly  button or the 

A1 1 events prior t o  button. 

4. If you chose A1 1 events prior to,  type a new 
date, if necessary, in the format mmddyyyy. 

5. Select OK to complete the task. 
DeskMate deletes the reminder, event (or all events 
prior to the date you specified), or annual occasion 
from your calendar. 

Annual occasion 
Adds an occasion to your calendar that occurs year- 
ly, such as birthdays and holidays. 
1. Highlight the occasion date. 
2. Select Annual  occasion from the Event Menu 

(F6). 
A dialog box a pears, and the displayed date is 
the highlightefdate on the current calendar. (If 
you need to change the date, move the cursor to 
the Date o f  occasion: field, and type a new 
date in the format mmdd.) 

3. At the Description: prompt, type the descrip- 
tion, using 30 characters or fewer. 

4. Select OK to complete the task. 
The annual occasion you entered can be read on the 
daily or weekly calendar for that date. A diamond 
(e) appears on the monthly calendar on the date of 
the annual occasion. On some monitors, the date of 
the occasion appears in a different color on the year- 
ly calendar. 
DeskMate automatically inserts an annual occasion 
into every year so that you do not have to re-enter 
the date at the beginning of each new year. 

Reminder 
Adds a reminder on the daily calendar. 
1. Select Remi nder from the Event Menu (F6). 

2. At the Description: prompt, type a reminder, 

3. Select OK to complete the task. 

A dialog box appears. 

using 60 characters or fewer. 

The reminder is added to your calendar, and it-ap- 
pears every day on each date’s daily calendar until it 
is deleted. 
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Calendars Menu 
The Calendars Menu (F7) options let you create 
new calendars, open existing ones, or delete calen- 
dars you no longer need. 

New 
Creates a new calendar. You can create up to 20 
calendars. 

Note: You must be in an existing calendar before 
you use the New option to create a new calendar. 

1. Select New from the Calendars Menu (F7). 
A dialog box appears. 

2. At the Name: prompt, type a calendar name, 
using 15 characters or fewer. 

3. Select OK to complete the task. 
DeskMate displays the new calendar. 

Open 
Opens an existing calendar without returning to the 
desktop. 
1. Select Open from the Calendars Menu (F7). 

A dialog box appears, listing all the calendars 
you can open. 

2. Highlight the name of the calendar you want to 
open. 

3. Select OK to complete the task. 
Your new calendar opens to the same calendar type 
you were working with (daily, weekly, monthly, or 
Yearly). 

Delete 
Deletes an existing calendar. 
1. 

2. 

3. 

Select Delete from the Calendars Menu (F7). 
A dialog box appears, listing all the calendars 
you have created. 
Highlight the name of the calendar you want to 
delete. 
Select OK to complete the task. 

DeskMate deletes the calendar. 

Calendar Tasks 
This section lets you look up Calendar application 
tasks. The tasks are listed alphabetically, and the 
name of the menu and the option@) needed to per- 
form the task are listed beneath the task. If YOU 
don’t know how to use an option, see the “Menu Op- 
tions” section for detailed information and step-by- 
step instructions. 
Add a Reminder 

Event F6 (Reminder) 
Add an Annual Occasion 

Event F6 (Annual occasion) 
Add an Event 

Event F6 (Add) 
Change a Reminder 

Event F6 (Change) 
Change an Annual Occasion 

Event F6 (Change) 
Change an Event 

Event F6 (Change) 
Create a New Calendar 

Calendars F7 (New) 
Delete a Calendar 

Calendars F7 (Delete) 
Delete a Reminder 

Event F6 (Remove) 
Delete an Annual Occasion 

Event F6 (Remove) 
Delete an Event 

Edit F3 (C1 ear) 
Event F6 (Remove) 
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Display a Daily Calendar 
Display F4 (Da i 1 y) 

Display a Monthly Calendar 
Display F4 (Month1 y) 

Display a PrograWApplication Name and Version 
Number 

File F2 (About) 
Display a Weekly Calendar 

Display F4 (Weekly) 
Display a Yearly Calendar 

Display F4 (Yearly) 
Duplicate Information in Another Calendar 

Edit F3 (Copy) 
Calendars F7 (Open) 
DisplayF4 (Daily, Weekly, Monthly, or Yearly) 
Edit F3 (Paste) 

Edit F3 (Copy) 
Edit F3 (Paste) 

File F2 (Exi t )  

Search F5 (Find date) 

Search F5 (Find) 
Search F5 (Find next) 

SearchF5 (Today's date) 

File F2 (Page setup) 

Edit F3 (Cut) 
Calendars F7 (Open) 
DisplayF4 (Daily, Weekly, Monthly, orYearly) 
Edit F3 (Paste) 

Edit F3 (Cut) 
Edit F3 (Paste) 

Open an Existing Calendar from Within a Calendar 
Calendars F7 (Open) 

Print a Calendar 
File F2 (Print) 

Run Another Application 
File F2 (Run) 

Duplicate Information Within the Same Calendar 

Exit Calendar 

Find a Date 

Find Text 

Find Today's Date 

Format a Page Layout 

Move Information to Another Calendar 

Move Information Within the Same Calendar 

Other Calendar 
Information 
High 1 igh t Events 
You can work with the information on the daily or 
weekly calendar (for example, move, copy, and 
delete) by highlighting it and then choosing the ap- 
propriate option. The following instructions explain 
how to highlight events. 
There are different techniques for highlighting infor- 
mation depending on whether you are using a daily 
or weekly calendar. Follow the instructions below to 
highlight scheduled events on a daily or weekly 
calendar. 

Daily Calendar: 
If you are using the keyboard, use the up and 
down arrow keys to move the cursor to the 
event you want to highlight. 
If you are using a mouse, point to the event you 
want to highlight, and click. 

Only the left column is highlighted, but when you 
move or copy the information, for example, all the 
information for the event is moved or copied. 

Weekly Calendar: 
Keyboard 

To highlight an existing event, use the arrow 
keys to move the cursor to any time slot in the 
scheduled event. Then, press the space bar. 
To enter a time period for a new event, move 
the cursor to the first time slot, and then hold 
down SHIFT and press the left or right arrow 
key until the desired time period is highlighted. 

To highlight an existing event, point to any time 
slot in the scheduled event, and click. , 

If you are entering a time period for a new 
event, point to the first time slot and hold down 
the mouse button, Drag the mouse to the left or 
right until the desired time period is high- 
lighted. Then, release the button. 

Mouse 
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Note: If more than one event is listed in the 
same time slot, you must press the space bar or 
double click to specify the event you want to 
select. A dialog box appears with the descriptions 
of multiple events. Use the arrow keys or point 
and click to select an event. Select O K  to complete 
the selection. 

Move the Cursor 
The techniques explained in this section will help 
you move the cursor around the screen. 
Keyboard. If you are working in a daily calendar, 
pressing t or .1 moves the cursor one event up or 
down on the list. 
On a weekly calendar, pressing t or .1 moves the cur- 
sor to the previous or next day of the week. Pressing - or +- moves the cursor backward or forward 
through the time slots (15-minutes). 
On a monthly calendar, pressing f or .1 moves the 
cursor to the same day of the previous or next week. 
Pressing --+ or moves the cursor backward or for- 
ward one day. 
On a yearly calendar, pressing f or .1 moves the cur- 
sor three months previous or ahead. Pressing + or 

moves the cursor to the next or previous month. 
You can also use these keys to move to specific 
places: 

Key(s) : Moves the Cursor: 
ALT+N To the next day, week, month, 

or year 
ALT+P To the previous day, week, month, 

or year 
CTRL+ To the beginning of a daily, weekly, 

or yearly calendar 
HOME 
CTRL+END To the end of a daily, weekly, or 

yearly calendar 
Mouse.  Position the cursor anywhere on a calendar 
by pointing to the desired location and clicking. To 
display information not currently on the screen, 
point and click on the scroll arrow icons on the 
menu bar. The following chart provides more infor- 
mation on moving the cursor with a mouse: 

Point and To Move the Cursor: 
Click on: 
NEXT To the next day, week, month, 

or year 

PREV To the previous day, week, month, 
or year 

To scroll more than one line or character at a time, 
point to the appropriate arrow button, and hold 
down the button. The screen scrolls continuously 
until the button is released. 
You can also scroll through a weekly schedule grid. 
Move the cursor to the farthest point on the grid in 
the direction you want to move, and then use the ap- 
propriate arrow key to scroll the grid. 

Select a Date 
Depending on the way you have a calendar dis- 
played, daily, weekly, monthly, or yearly, you can 
move the cursor to help you select the date you need 
to see. 
When you are using the Display Menu’s (F4) D a i  1 y 
option: 
Keyboard 

M o u s e  

To move to the next day, press ALT+N. 

To move to the previous day, press ALT+P. 

To move to the next day, point to the NEXT but- 
ton and click the mouse button. 
To move to the previous day, point to the PREV 
button and click the mouse button. 

When you are using the Display Menu’s (F4) 
Weekly option: 
Keyboard 

To move to a different day in the displayed 
week, press the up or down arrow key. 
To move to the next week, press ALT+ N. 

To move to the previous week, press ALT+P. 
M o u s e  

To move to a different day in the displayed 
week, point to the desired day and click the 
mouse button. 
To move to the next week, point to the NEXT but- 
ton and click the mouse button. 
To move to the previous week, point to the PREV 
button and click the mouse button. 
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When you are using the Display Menu’s (P4) 
Monthly option: 
Keyboard 

To move to a different day in the displayed 
month, use the arrow keys. 
To move to the next month, press ALT + N . 
To move to the previous month, press ALT + P. 

To select the day the cursor is on, press ENTER. 

To move to a different day in the displayed 
month, point to the desired day and click the 
mouse button. 
To move to the next month, point to the NEXT 
button and click the mouse button. 
To move to the previous month, point to the 
PREV button and click the mouse button. 
To select the day the cursor is on, double click 
the mouse button. 

Mouse  

When you are using the Display Menu’s (P4) 
Yearly option: 
Keyboard 

To move to a different month in the displayed 
year, use the arrow keys. 
To move to the next year, press ALT + N. 
To move to the previous year, press ALT+ P. 

To select the month the cursor is on, press 
ENTER. 

Mouse  

To move to a different month in the displayed 
year, point to the desired month (or point to the 
appropriate arrow on the menu bar) and click 
the mouse button. 
To move the next year, point to the NEXT button 
and click the mouse button. 
To move to the previous year, point to the PREV 
button and click the mouse button. 
To select the month the c m r  is on, double 
click the mouse button. 

Set the Alarm 
You can set an alarm for an event using the Add or 
Change option on the Event Menu (P6) and checking 
the A1 arm check box in the dialog box. When an “X” 
is in the check box, the alarm sounds at the event 
time. For this reason, if you plan to use the Alarm 
Accessory for other “quick” alarm reminders, it is 
recommended that you set the starting time earlier 
than the actual event. 

Note:  You must turn on the Alarm Accessory by 
using the A1 arm option on the Accessory Menu 
(F10). 

Store Updates 
Calendar stores additions, deletions, and changes 
you make to a calendar automatically. You do not 
have to perform a special procedure to store your in- 
formation on disk. 

Note: You must exit Calendar to automatidy 
update the changes on disk. 
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Desktop 
Overview 
What Is It? 
DeskMate’s central screen is the desktop. With desktop’s menu options, you 
can manage your computer files and design your DeskMate desktop without 
memorizing complicated commands and without ever leaving DeskMate. 

What Can I Do with It? 
The desktop contains a myriad of features that let you: 

Prepare diskettes for storing information, copying information, and copying 
entire diskettes 
Change the view of your desktop so that you can easily see your file and 
directory organization 
Design the DeskMate desktop by adding or removing list boxes so that the 
programs or applications you use most frequently are at your fingertips 
Install other software programs on the desktop for quick and easy access 
Without leaving DeskMate 
See your computer files in order by names, type of file, date, or size 

How Do I Use I t?  
When you start DeskMate, the first screen you see is the desktop (similar to 
the one shown at the right). 
The desktop lets you do more than run applications and their data files. You 
can use the desktop menus to manage your files, directories, and disks. For 
example, you can use the File Menu (F2) options to copy, delete, and 
rename files; use the Directory Menu (F3) to change, create and delete 
directories; use the Disk Menu (F4) to format and copy your disks. 
Using the options on the Desktop Menu (F7), you can design your desktop 
by creating, removing, and renaming the application boxes and list boxes on 
the screen. 
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DeskMate lets you look at your files a few different ways using the View 
Menu (€35) - the Menus View which is the screen shown at  the beginning 
of this chapter, the Tree View which shows you a graphic tree structure of 
your disk‘s directories, and the Files View which shows you a list of the files 
in the current directory. When you use the Files View, you can quickly view 
all your file information such as name, extension, size, and so on. You also 
have the option of sorting these files by name, type, date, and size. 
To learn the basics about using the desktop, see the “Desktop” article in the 
Gerring Starred magazine. Then, when you’re familiar with the desktop, this 
chapter will provide you with a quick way to answer specific questions. You 
can look up the step-by-step instructions for each menu option. If you want 
to know which options to use to perform a specific task, check the “Desktop 
Tasks” section at the end of this chapter. 
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Menu Options 
n e  desktop has six menus that list the options you 
can use. The key that you press to see each menu ap- 
pears beside the menu name. (For example, press 
the PZ key to see the File Menu.) A shaded option 
on a menu means that the option is not available. 
some options have accelerator keys listed next to 
them. Use these keys to perform tasks without pull- 
ing down a menu. For example, when you want to 
exit DeskMate, you can press ESC to select E x i t  
from the File Menu (€2). 
This section explains each of the desktop menus on 
the menu bar and also contains step-by-step instruc- 
tions on how to use each option on the menus. 

File Menu 
The File Menu (€2) options let you work with Desk- 
Mate files. For example, you can copy, delete, or 
rename a file, and run another program or applica- 
tion. 

I ~ Exit 

About. . . 
Get Info 
Lets you see the size of a selected file and the date 
and time you last changed it. 
1. Highlight a specific file in a list box. 
2. Select Get I n f o  from the File Menu (FZ). 

3. Select OK to remove the box from the screen. 
A dialog box appears. 

Run 
Runs a DeskMate application file or another 
software package. 
1. Select Run from the File Menu (€2). 

A dialog box appears. 
2. At the Program: prompt, type the name of the 

program or application you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current direc- 
tory, type a full pathname, including the drive 
and directory. 

3. At the Data f i 1 e : prompt, either type the name 
of the data file you want to use with your 
chosen program (or application) or leave the 
prompt blank. 
If you leave the prompt blank, DeskMate runs the 
specified program (or application) without open- 
ing a corresponding data file. 

4. Select OK to complete the task. 

DeskMate might ask you to insert the diskette con- 
taining the application or program you specified. 
Insert the appropriate diskette, and select OK to run 
the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the file desktop.pdm. After you insert the 
diskette and select OK, you return to the desktop. 

COPY 
Copies a file to any directory on any disk. If you 
want, you can also give the copy a new name. 

1. If you want to copy a file that appears in a list 
box, highlight it. 
If you are using a diskette-based system, be s a  
the diskette containing the file you want to COPY 
is in a diskette drive. 

A dialog box appears, displaying the name Of the 
file you highlighted. 

3. If you did not highlight a file, type the name of 
the file you want to copy at the Copy from: 
prompt, including the drive and directory name 
as necessary. 

2. Select Copy from the File Menu (PZ). ’ 
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4. At the Copy to:  prompt, type the name you 
want to give the copy, including the drive and 
directory name as necessary. 

Notes: 
If you want the copied file to have 
the same name as the original file, 
you only need to type a drive and 
directory name. 
If you are copying to a new 
filename but in the same drive and 
directory, you only need to include 
the new filename. 
If you have only one drive but are 
copying between two diskettes, 
specify Drive A at the Copy from: 
prompt and Drive B at the Copy t o :  
prompt. DeskMate tells you when 
to switch diskettes. 

5. Select OK to complete the task. 
You can use the * or 1 wildcards to represent any 
number of characters. For instance, *.doc copies all 
files that have the extension .doc. You can restrict a 
wildcard by beginning with specific characters. For 
example, ab*.doc copies all files beginning with ab 
that have the extension .doc. 

Be sure to see “wildcard Characters” in the “Other 
Lksktop Information ’’ section. 

~ ~~ 

You can also select multiple files from a list box on 
the desktop before selecting the Copy option. To do 
so, hold down the SHIFT key while highlighting the 
files. Then, follow the copy procedure as previously 
given and select the ALL button. Instead of copying 
one file, DeskMate copies all the highlighted files. 

For more information about selecting multiple files, 
see “Highlight Multiple Files” in the “Other Desktop 
Information ”section. 

Delete 
Deletes duplicate or unwanted files from a disk to 
create additional storage space. 
1. Change to the directory containing the file you 

want to delete. (See the Directory Menu’s (F3) 
Change option.) 

box, highlight it. 
2. If the file you want to delete appears in a list 

3. Select Delete from the File Menu (€72). 
A dialog box appears, displaying the name of the 
file you highlighted. 

4. If you did not highlight a file, type the name of 
the file you want to delete at the F i  1 ename: 
prompt. 

5.  Select OK to complete the task. 
Instead of changing directories before deleting a file, 
you can type a full pathname at the F i  1 ename: 
prompt, including the drive and directory name, for 
the file you want to delete. 
You can use the * or 1 wildcards to represent any 
number of characters, For instance, *.doc deletes all 
files that have the extension .doc. You can restrict a 
wildcard by beginning with specific characters. For 
example, ab*.doc deletes all files beginning with ab 
that have the extension .doc. 
Be careful when using wildcard characters. Be sure 
that any filenames you want to keep are not in- 
cluded in the wildcards you type. 

Be sure to see “u.ildcard Characters” in the “Other 
Desktop Information” section. 

You can also select multiple files from a list box on 
the desktop before selecting the Del ete option. To 
do so, hold down the SHIFT key while highlighting 
the files. Then, follow the copy procedure as pre- 
viously given and select the ALL button. Instead of 
deleting one file, DeskMate deletes all the high- 
lighted files. 

~~~~-~ 

For more information about selecting multiple files, 
see “Higlzlight Multiple Files” in the “Other Desktop 
Information I’ section. 

Rename 
Changes the name of a file. You might want to 
change the name to avoid filename conflicts or to 
make the name more descriptive of its contents. 
1. Be sure you are in the directory where the file 

you want to rename resides. (See the Directory 
Menu’s (F3) Change option.) 

box, highlight it. 
2. If the file you want to rename appears in a list 
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3. Select Rename from the File Menu (F2). 

A dialog box appears, displaying the name of the 
file you highlighted. 

4. If you did not highlight a file, type the name of 
the file you want to rename at the From: prompt. 

5.  At the To: prompt, type the new filename. 

6. Select OK to complete the task. 
f ie  filename is changed on the desktop or disk. 

Update screen 
Re-reads the disk (diskette) files and updates the 
screen (for example, after you switch diskettes.) 

Select Update screen from the File Menu (F2). 
DeskMate redraws the screen, showing the contents 
of the current disk. 

Exit 
Exits DeskMate and returns you to the MS-DOS 
prompt. 
1. Exit any application or program you are using. 
2. At the desktop, select E x i t  from the File Menu 

(F2) - 
A dialog box appears asking you to confirm your 
exit. 

3. Select OK to complete the task. 
The system prompt is displayed. 

About 
Displays the program or application name, version 
number, and the files DeskMate uses to run this pro- 
gram. 

1. Select Abou t  from the File Menu (F2). 

2. Select C A N C E L  to remove the box from the 
A dialog box appears. 

screen. 

Directory Menu 
The Directory Menu (F3) options let you create or 
delete a directory and change to a different drive or 
directory. 

Change. I . 
Create., , 

Change 
Lets you change DeskMate’s current disk, directory, 
or both to access different files or use a different 
diskette. Using this option lets you store the files 
created by the various applications in separate direc- 
tories or on different disks. For example, you can 
store all the letters you create, using the Text ap- 
plication, in a Letters directory on a diskette in Drive 
B. 
1. Select Change from the Directory Menu (F3). 

A dialog box appears. 
2. Highlight a directory in the Directory box, or at 

the Directory: prompt, type the new pathname. 
For example, the pathname for a directory named 
Letters on Drive B is b : \ 1 e t  ters . 

3. Select OK to complete the task. 
DeskMate displays the new directory or drive, and 
its files, on the desktop 

Create 
Creates additional directories on any disk. YOU 
might want to create a different directory to hold 
the files created by each of the DeskMate applica- 
tions. 

1. Select Create from the Directory Menu (F3). 
A dialog box appears. 
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2. At the Path: prompt, type the name of the direc- 
tory you want to create. 
If the directory is on a disk other than the current 
disk or in a directory other than the current direc- 
tory, type the full path for the new directory, 
using up to 64 characters. For example, to create 
a directory named Letters on Drive B, at the 
Path: prompt, type b:\letters. 

3. Select OK to complete the task. 

Delete 
Deletes directories that you no longer need. 
1. Before you can delete a directory, you must 

delete all the files from the directory. (See the 
File Menu’s (F2) Delete option.) 

2. Select Delete from the Directory Menu (F3). 
A dialog box appears, 

3. At the P a t h :  prompt, type the name of the direc- 
tory you want to delete, including the drive 
name and any other directory names in the path. 
For example, to delete the sub-directory Letters 
from the Text directory on Drive B, type 
b: \text\l etters. 

4. Select OK to complete the task. 
If you specify a directory that does not exist, or if 
you make a typing error, DeskMate displays a mes- 
sage telling you that the indicated path could not be 
found. You can either retype the pathname or select 
CANCEL to close the dialog box without making a 
deletion. 

Disk Menu 
The Disk Menu (F4) options let you copy or format 
a disk and check the disk storage space. 

Get Info.  I I 
Format. , . 

Get I n f o  
Lets you view the amount of available free space on 
the current disk, along with the volume name. 

1. Select Get I n f o  from the Disk Menu (F4). 
A message box containing the information ap- 
pears. 

2. Select OK to remove the box from the screen. 

Format 
Formats a diskette so that you can store data on it. 
1. 

2. 

3. 
4. 

5. 

6. 

Select Format from the Disk Menu (F4). 
A dialog box appears. 
At the Drive : prompt, type the letter of the 
drive in which you will put the diskette to be for- 
matted. 
If necessary, choose the appropriate drive type. 
If you want to add a volume label to the disk- 
ette, choose Volume Label. 
If you want to make the diskette a system disk- 
ette, choose Instal 1 operating system. 
Select OK to complete the task. 

You are asked to insert a diskette and press ENTER. 
When formatting is complete, you are asked if you 
want to format another diskette. Press Y to continue 
formatting, and follow the prompts that appear. 
Press N to end the formatting session. You return to 
the desktop. 

Diskcopy 
Makes one or more copies of a diskette. 
1. 

2. 

3. 

4. 

Select Di skcopy from the Disk Menu (P4). 
A dialog box appears. 
At the From: prompt, type the letter for the drive 
that will contain the diskette you want to copy. 
At the To : prompt, type the letter for the drive 
that will contain the blank, formatted diskette 
you want to copy to. 
You can type b at the To : prompt, even if you 
have only one diskette drive. The program tells 
you when to switch diskettes. 
Select OK to begin the copy procedure. 

You are asked to insert the diskette@). When Disk- 
copy is finished, you are asked if you want to copy 
another diskette. If you do, press Y and follow the 
same process. If you don’t, press N. Diskcopy ends 
and the desktop appears. 
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View Menu 
The View Menu (F5) options let you change the 
desktop view. 

Sort By Menu 
The Sort by Menu (F6) options let you sort 
filenames in the Files View by name, fiie extension, 
date, and size. 

Displays the DeskMate desktop as it appears when 
you first start running DeskMate. 

The Menus View is also referred to as the desktop. 
Select Menus from the View Menu (F5). 

Tree 
Displays a tree structure of the directories in the cur- 
rent drive. 

DeskMate displays the tree structure of the direc- 
tones on the current drive. To see the files in the 
directories, highlight a directory and press ENTER. 
A list box appears, displaying all the files in the 
directory (the Files View). For more information 
about the Files View, see the F i  1 es option. 

Files 
Displays a list box containing the files in the current 
directory. 

Select F i  1 es from the View Menu (F5). 
A list box appears, displaying all the files in the 
directory. If there are more files than can fit in the 
box, press PG UP and PG DN to view other files. 
You can also select a specific file by pressing the first 
letter of the filename until you highlight the file. 
To run DeskMate applications from the Files View, 
select the application name from the list box, or 
select a data file that displays the application name 
in the Program column. 

Select Tree from the View Menu (F5). 

N a m e  
Sorts the files that appear in the Files View list box 
alphabetically by filename. 
1. Open the directory containing the files you 

want to view. 
A list box appears, containing all the files in the 
current directory. 

2. Select Name from the Sort by Menu (F6). 
The files in the Files View list box appear alphabeti- 
cally. 

me 
Sorts the files that appear in the Files View list box 
alphabetically by extension name. 
1. Open the directory containing the files you 

want to view. 
A list box appears, containing all the files in the 
current directory. 

2. Select Type from the Sort by Menu (F6). 
The files in the Files View list box appear alphabeti- 
cally by extension name. 

D a t e  
Sorts the files in the Files View list box in reverse 
chronological order by date. 
1. Open the directory containing the files you 

want to view. 
A list box appears, containing the files in the cur- 
rent directory. 

2. Select Date from the Sort by Menu (F6). 
The files in the Files View list box appear in reverse 
chronological order by date. 
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Sise 
Sorts the files in the Files View list box in numerical 
order by size. 
1. Open the directory containing the files you 

want to view. 
A €kt box appears, containing the files in the cur- 
rent directory. 

2. Select Size  from the Sort by Menu (F6). 
The files in the Files View list box appear in ascend- 
ing numerical order by size. 

Desktop Menu 
The Desktop Menu (F7) options let you design your 
desktop so that the programs and applications you 
use most are available for quick access. For example, 
you can create application boxes for applications 
that don’t normally appear on the desktop, remove 
an application box from the desktop, or install other 
programs that you use and want to access from the 
DeskMate desktop. 

Display.. . 

C-tc quick load.. , 
Redefine.. . 

U- disk 

Install 
Automatically installs other program packages you 
want to use with DeskMate. Tandy and other com- 
panies have programs especially written to use with 
the DeskMate environment. These programs have 
special files that make installing them easy. 
1. 

2. 

Place the new program diskette in a diskette 
drive. 
Select Instal 1 from the Desktop Menu (F7). 
A dialog box appears. 

3. Change the default box size if necessary. 
4. Select OK to complete the task. 

The desktop returns and a dotted box appears. 
5. Using the arrow keys, move the dotted box to 

where you want the application box to appear 
on the desktop. 

6. Press ENTER or double click the mouse button. 
The installation continues automatically. Simply fol- 
low the prompts to complete the procedure. If you 
need to insert additional diskettes, DeskMate will 
tell you. 
When the installation process is finished, you can 
run the new application from its application box. In 
addition, you can run the program using the File 
Menu’s (F2) Run option, or you can select the file 
from DeskMate’s Files View. 
See the manual that comes with your new program 
for more specific information. 

Display 
Displays an application box or accessory on the 
desktop. 

I. If necessary, remove one or more application 
boxes from the desktop to make room for the ap- 
plication list box you want to display. (See the 
Remove option.) 

2. Select Disp lay  from the Desktop Menu (F7). 
A dialog box appears, listing all the applications 
and accessories that will fit on the current 
desktop and are not already displayed. 

sory you want to display. 

application box and accessory has a default size, 
and you cannot decrease this size. 

5. Select OK to complete the task. 
The desktop returns and a dotted box appears. 

6. Using the arrow keys, move the dotted box to 
where you want the application box or acces- 
sory to appear on the desktop. 

7. Press ENTER or double click the mouse button. 
Note: If you are using a mouse, you must point 
to the Zefr corner of the dotted box, and then 
click the button to display it. 

The application or accessory appears on the desktop. 

3. Highlight the name of the application or acces- 

4. Change the default box size if necessary. Each 
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Move 
Moves an existing application box or accessory on 
the desktop. 
1. Highlight the application box or accessory you 

2. Select Move from the Desktop Menu (F7). 
A dotted box appears on the desktop. 

3. Move the dotted box to where you want the ap- 
plication box or accessory to appear on the 
desktop. 

want to move. 

4. Press ENTER or double click the mouse button. 
The application box or accessory reappears on the 
desktop in its new location. 

Remove 
Removes an application list box or accessory from 
the desktop. Removing an application box or acces- 
sory does not erase it from the DeskMate environ- 
ment - you can choose to redisplay it again later. 
(See the D i  splay option.) 
1. Highlight the application box or accessory you 

want to remove. 
2. Select Remove from the Desktop Menu (F7). 

Create 
Creates an application box and displays it on the 
desktop. 
1. Select Create from the Desktop Menu (F7). 

A dialog box appears. 
2. At the Menu t i  t 1 e : prompt, type the name you 

want displayed on the list box. 
3. At the Programs list box, highlight the program 

for which you want to create the new applica- 
tion box, or type another program name at the 
Program name : prompt. 

4. At the Data f i l e  extension: prompt, type the 
extension of the data files you will create when 
using the program. 

5. Atthe S t a r t - u p  directory: prompt, type the 
name of the directory you want DeskMate to 
select before running the chosen program. 

If you type the name of another directory at this 
prompt, the program will store its files in that 
directory. When you return to the desktop after 
running the chosen program, DeskMate returns 
to the original directory. 
If you do not want to change directories when 
running this program, leave the S t a r t  -up 
directory: prompt blank. 

6. Select OK to complete the task. 
A dialog box appears. 

7. Choose the desired application box size. 
8. Select OK. 

The desktop returns and a dotted box appears. 
9. Move the dotted box to where you want the ap- 

plication box to appear on the desktop. 
10. Press ENTER or double click the mouse button. 
The new application box appears on the desktop. 

Create quick load 
Creates a Quick Load box that can change its name 
and contents depending on the current drive or 
directory. To see which application is currently as- 
signed to the Quick Load box, select the Redef i ne op- 
tion on the Desktop Menu (F7) and scroll through 
the applications until you find the application as- 
signed to the Quick Load box. 
The Quick Load box can be useful whether you are 
using a hard drive or diskette-based system. For ex- 
ample: 

When using a hard drive system, you might 
want to create a special directory to store a 
large number of files that you create with OM 
specific DeskMate application. You can then as- 
sign that directory to the Quick Load box and 
display it on the desktop. 
When using a diskette-based system, you might 
create more files for a specific application than 
can be stored on a DeskMate diskette. You can 
create a special diskette for that application 
(and its files) only. You can then assign that ap- 
plication to the Quick Load box, and when ~ O U  
insert the diskette, the files appear in the Quick 
Load box. 
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When using another software program that is 
written to run under the DeskMate User Inter- 
face, the program will automatically appear in 
the Quick Load box when you insert the pro- 
gram diskette. 

Before you can assign an application or program to 
the Qukk Load box, there must be an existing box 
for that application or program. If it does not appear 
in the list when you select the Di spl  ay option, you 
must create a new box using the Create option. 
Then, follow these steps: 
1. Select Create qu ick  load from the Desktop 

Menu (F7). 
A dialog box appears, asking if you want to 
change the existing Quick Load definition. 

Another dialog box appears. 

gram box you want to convert to a Quick Load 
box. 

A dialog box appears so that you can select the 
box size. 

2. Select YES. 

3. Highlight the name of the application or pro- 

4. Select OK to complete the task. 

5. Choose the size for the box you want to create. 
6. Select OK to complete the task. 

The desktop returns and a dotted box appears. 
7. Move the dotted box to where you want the pro- 

graWapplication to appear on the desktop. 
8. Press ENTER or double click the mouse button. 

You can create only one Quick Load box per direc- 
tory or disk, and it can have only one selection from 
any directory or disk. 

Redefine 
Lets you redefine the options for an application box. 
For example, you can change the box’s title, the pro- 
gram name, data file extension, and so on. 

1. Select Redefine from the Desktop Menu (P7). 
A dialog box appears, listing all of DeskMate’s ap- 
plications. 

2. Highlight the name of the application box you 
want to change. 

3. Select OK. 

Another dialog box appears. 
4. If you want a new box title, type the new title at 

the Menu t i t l e :  prompt. 
5. If you want the application box to contain a 

new program, choose it from the Programs list 
box, or type the new program name at the 
Program name: prompt. 

6. If you want the application box to contain dif- 
ferent files, type the new file extension at the 
Data f i l e  extension: prompt. 

7. If you want to indicate a new startup directory, 
type the new name at the Start-up directory: 
prompt. 

8. Select O K  to complete the task. 

Delete 
Erases a DeskMate application box or accessory so 
that it no longer exists and you can no longer dis- 
play it. 

Caution: If you only want to remove an applica- 
tion box or accessory without deleting it, use the 
Desktop Menu’s (F7) Remove option. 

A dialog box appears, listing all the application 
boxes and accessories. 

2. Highlight the name of the application box or ac- 
cessory you want to delete. 

3. Select O K  to complete the task. 

1. Select Delete from the Desktop Menu (F7). 

Use disk 
Controls the appearance of your desktop. 

Note: See “Other Desktop Information” to learn 
more about the Use disk option. 
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Desktop Tasks 
This section lets you look up desktop tasks. The 
tasks are listed alphabetically and the name of the 
menu and the option(s) needed to perform the task 
are listed beneath the task. If you don’t know how to 
use the option(s) needed to perform the task, see 
the “Menu Options” section for detailed information 
and step-by-step instructions. 
Change to a Different Drive or Directory 

Directory F3 (Change) 
Change the Desktop View 

Vim F5 (Menus, Tree, or F i  1 es) 
Check Disk Storage Space 

DiskF4 (Get Info) 
Check File 

File (FZ) (Get Info) 
Copy a Disk 

Disk F4 (D i  s kcopy) 
Copy a File 

File F2 (Copy) 
Create a Directory 

Directory F3 (Create) 
Create an Application Box 

Desktop F7 (Create) 
Create a Quick Load Box 

DesktopF7 (Create q u i c k  load) 
Delete a Directory 

Directory F3 (Delete) 
Delete a File 

File FZ (Delete) 
Delete an Application Box from DeskMate 

Desktop F7 (Delete) 
Display an Application Box or Accessory on the 
Desktop 

Display a PrograWApplication Name and Version 
Number 

File F2 (About) 
Exit DeskMate 

File F2 (Exit) 
Format a Diskette 

Disk F4 (Format) 
Install a DeskMate-Compatible Program Package 

DesktopF7 (Instal 1 )  
Move an Application Box 

Desktop F7 (Move) 
Redefine an Application Box 

Desktop F7 (Redef i ne) 

Desktop F7 (D i s p 1 ay) 

Remove an Application Box or Accessory from the 
Desktop 

Rename a File 

Run an Application or Program 

Sort Filenames in the Files View 

Update the Screen 

Desktop F7 (Remove) 

File F2 (Rename) 

File F2 (Run) 

Sort by F6 (Name, Type, Date, or Size) 

File F2 (Update screen) 

Other DesktoD 
1 

Information 
Correct a n  Error 
If you make an error as you type information in a 
field, you can press either BACKSPACE or DELETE 
to make corrections. Pressing BACKSPACE erases 
the character immediately preceding the cursor. 
Pressing DELETE erases the character the cursor is 
on. 

High Zig h t M u  1 tip le Files 
You can select or highlight consecutive files from a 
list box on the desktop by holding down the SHIFT 
key while pressing the up or down arrow key. 
To highlight non-consecutive files from a list box, ~~ 

highlight the first file that you want to delete in the 
list box. Then, hold down CTRL and press the ap- 
propriate arrow key until you highlight the next 
desired file. Keep holding down CTRL and press the 
space bar to highlight the desired file@). 

Store the Desktop 
Configuration o i  Diskette 
The Use d i  s k option on the Desktop Menu (F7) con- 
trols the appearance of your desktop. DeskMate auto- 
matically uses the desktop.cfg file from the EEPROM 
unless another desktop.cfg file is created on diskette. 
DeskMate automatically creates a file on the current 
diskette if you run out of EEPROM space, add To Do 
to your desktop, or use a start-up directory. When the 
new desktop.cfg is saved on a diskette, DeskMate 
automatically checks the Use disk option, and YOU 
are asked to insert the diskette each time you start 
DeskMate. If you don’t want to use the desktop.cfg 
file on diskette uncheck the Use disk option. 
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Wildcard Characters 
When you are copying or deleting files, you can in- 
clude wildcard characters (* and ?) for files with 
similar names. A wildcard lets you copy or delete 
these files all at once so that you won’t have to copy 
or delete each file individually. 
The ? wildcard tells DeskMate that you do not care 
what the character at the ? position is. For example, 
typing hol ? .doc finds both hole.doc and holt.doc. 
The * wildcard tells DeskIvIate that any character at 
the * position and all subsequent characters can be 
considered acceptable. For example, typing 1 e t  - 
ter.* finds letter.doc, le t ter . f i1 ,  and 1etter.prn. 
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Draw 
Overview 
What Is I t?  
Ever have trouble drawing a straight line? Using DeskMate’s Draw applica- 
tion, you can create pictures and designs by simply selecting a shape, chang- 
ing a color, or altering a design. You can add text and change the size of 
your drawings too. 

What Can I Do with I t?  
The Draw application contains many special tools and features that make 
drawing maps, greeting cards, or graphs simple. With your creativity and 
the Draw application, you can: 

Use Draw’s tools to draw and design without the hassles of pencils, pens, 
rulers, and ink 
Create brochures, customized forms, memo pads, letter heads, ads, charts, 
and so on 
Add Draw‘s predrawn clip art to your pictures and resize them to meet your 
needs 
Add illustrations to your Text documents to create reports, papers, or 
brochures 

How Do I Use I t?  
When you select the Draw application, a screen similar to the one at the 
right appears. 
Use the Draw screen like a blank canvas. Simply select the tool you want to 
draw with from the Tools Menu (F7) and go. To draw using the keyboard, 
position the cursor where you want it, and then press the space bar again to 
turn on the tool. Use the arrow keys to begin drawing the design, and then 
press the space bar to complete the piece. To draw with a mouse, point to 
the place where you want to begin the drawing and then drag the marker to 
create the design. Then, release the button to finish the design. 
You can use the Options Menu (F6) to customize the drawing tools you are 
using. With these options, you can adjust the width and style of lines or the 
typestyle of the text you use. In addition, you can select fill colors or pat- 
terns for enclosed shapes. 
Each time you draw something with a tool, you create an element.  As you 
add elements to your design or drawing, you can group them together to 
form larger elements or objects. 
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The Select tool is one of the most useful tools, because it lets you select ele- 
ments, objects, and pictures for moving, editing, and adjusting. By using the 
Edit Menu (P3) and Actions Menu (F4) options, you can flip a picture 
horizontally or vertically, rotate it 90 degrees, move it to another location, 
make a copy for use elsewhere, or delete it. 
To learn the basics about using Draw, see the “Draw” article in the Gettiiig 
Started magazine. Then, when you’re familiar with Draw, this chapter will 
provide you with a quick way to answer specific questions. You can look up 
the step-by-step instructions for each menu option. If you want to know 
which options to use to perform a specific task, check the “Draw Tasks” 
section at the end of this chapter. 
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3. Type a filename of eight or fewer characters. 
Draw automatically adds the extension .fig, un- 
less you specify otherwise. 

4. Select SAVE to complete the task. 
Draw displays a new, untitled picture. 

Open 
Opens another Draw file without returning to the 
desktop. 
1. Select Open from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
Step 5. 

If the picture is untitled, Save as : appears. Con- 
tinue with Step 3. 
If the picture is titled, continue with Step 5. 

3. At the Save as : prompt, type a filename of eight 
characters or fewer. 
Draw automatically adds the extension .fig, un- 
less you specify otherwise. 

2. Select YES, NO, or C A N C E L .  

4. Select SAVE to complete the task. 
A dialog box appears, listing all the files you can 
open in the current directory. In addition, the box 
lists all available subdirectories and drives. (The 
symbol [..I indicates the parent directory.) 

5.  Highlight the file you want to open. If the file 
you want to open is in another drive or direc- 
tory, highlight the appropriate drive or direc- 
tory. 

If you highlighted a specific file, it is displayed on 
the screen. If you highlighted a drive or directory, 
its files and directories appear in the list box. 
Other available drives appear in the list as well. 

6. Select OK.  

Menu Options 
Draw has six menus that list the options you can use 
with the application. The key that you press to see 
each menu appears beside the menu name. (For ex- 
ample, press the F2 key to see the File Menu.) A 
shaded option on a menu means that the option is 
not available. Some options have accelerator keys 
listed next to them. Use these keys to perform tasks 
without pulling down a menu. For example, when 
you want to clear a selected element from the 
screen, you can press DELETE to select C 1  e a r  from 
the Edit Menu (P3). 
This section explains each Draw menu on the menu 
bar and also contains step-by-step instructions on 
how to use each option on the menus. 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can create new 
Draw files, open existing files, print Draw pictures, 
or run another application or program. 

Bbout.. . 
New 
Creates a new Draw file. 
1. 

2. 

Select New from the File Menu (F2). 
If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, a new document 
screen appears. 
Select YES, NO, or CANCEL. 
If the document is untitled, Save as : appears. 
Continue with Step 3. 
If the document is titled, a new document screen 
appears. 

Continue with Steps 7-9.- 
7. Repeat Steps 5 and 6 until the list box displays 

the name of the file you want to open. 
8. Highlight the Draw file you want to open. 
9. Select OK to complete the task. 
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When you open a file in a different drive or direc- 
tory, subsequent “open” operations will display a 
list offiles, drives, and directories from the direc- 
tory in which the openedjile resides. However, 
when you exit Draw, the desktop displays a list of 
filesfiom the direcroryyou were in when you ac- 
cessed Draw. 

Save 
Lets you store updates to an existing picture without 
returning to the desktop. Store changes to pictures 
periodically to help prevent loss of information. (If 
you have not yet named the file, use the Save as op- 
tion.) 

Draw stores the changes you have made, and the pic- 
ture remains on the screen. 

Select Save from the File Menu (F2). 

Save as 
You can name and store a new file without return- 
ing to the desktop. 
1. Select Save as from the File Menu (F2). A 

2. At the Save as: prompt, type the name you 
dialog box appears. 

want to give the document, using eight or fewer 
characters. Draw automatically adds the exten- 
sion .fig, unless you specify otherwise. 

3. Select SAVE to complete the task. 
The new file and its name are stored on disk, and 
the picture remains on the screen. The new filename 
appears at  the top of the screen. 

Page setup 
Lets you design the physical page layout for your 
printed picture. 
1. Select Page setup from the File Menu (F2). A 

dialog box appears. Some of the options might 
not be available, depending on the type of 
printer you are using. Additional information 
about each option appears after the steps. 

2. Change the desired options. 
3. Select OK to complete the task. 

Paper Size. Choose the size paper you are using. If 
you choose Other, be sure to indicate the correct 
width and height in the appropriate fields. 
Left margin. Type the number of spaces you want 
for the left margin. 
Line width. Type the total number of characters 
you want to print on one line. 
For example, if you are using 8Vz-inch paper and a 
ten-characters-per-inch font (such as Courier), the 
total line width is 85 characters. If you set a left mar- 
gin of l~5-inches (15 spaces) and you want a right 
margin of 1 inch (ten spaces), subtract the left and 
right margin amounts from the total line width (85- 
25=60). The resulting total of 60 spaces (or 6 in- 
ches) is the printed line width. Be sure that the sum 
of the entries for Left margin and Line width set- 
tings does not exceed the width of your paper. 

Note: When printing in landscape format, Desk- 
Mate only prints ten characters per inch. 

Lines per page. Type the total number of lines on 
each sheet of paper. For example, 8Ih by 11-inch 
paper contains 66 lines in “portrait” mode when 
figured at six lines per vertical inch. 
Double space. Draw does not let you change this 
setting. 
Pause between pages. If you are not using con 
tinuous form paper, choose this option so that you 
can insert a new sheet of paper after each page 
prints. 
Print sideways. Choose this box to print sideways 
on your paper. When printing in this format, Desk- 
Mate only prints ten characters per inch. 
CENTER. By selecting this button, you can center 
your document on the page both vertically and 
horizontally. Enter the Left margin, Line w i d t h ,  and 
L i  nes per page settings as accurately as you can. 
Then, select the CENTER button, and DeskMate will 
automatically adjust the Line w i d t h  and Lines per 
page settings so that the body of the document is 
centered on the paper (based on your current 
printer selection). 
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Print 
Use this option to print the currently displayed pic- 
ture on paper, to the screen, or to another file. 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using. Also, be sure to set up your 
page layout using the File Menu’s (FZ) Page setup 
option. 

Note: You can print a picture on paper only if 
you are using a printer capable of printing 
graphics characters. 

box appears. 

Printer, or File button. 
The Screen button lets you print the picture on 
the screen so that you can see how your picture 
will look on paper. 
The Printer button lets you print your picture on 
paper. 
The Fi 1 e button lets you print your picture to 
another file. Printing to a file stores the picture 
on disk, using the name you give plus the exten- 
sion, .pm. You can then use the MS-DOS Print 
command to print the file from another computer 
that is not mnning DeskMate. 

Note:  You can also send the file to another 
computer, using the Telecom application. 
The printer used to print the file from MS- 
DOS must be the same type as the one you 
are currently using with DeskMate (the one 
you assigned with the Pri nter option in 
the Setup Accessory‘s Options Menu.) If 
you want to transmit the file using 
DeskMate’s Telecom application, choose 
ASCII as the printer type. 

3. Follow the appropriate instructions below for 

1. Select Print from the File Menu (FZ). A dialog 

2. At the Print t o :  prompt, choose the Screen, 

the button you chose in Step 2. 

The picture appears on the screen. You can scroll 
through it or use the Next page option on the Op- 
tions Menu (FZ)to view the next page. 
When you finish viewing the picture on the 
screen, select Exit from the Options Menu (F2) 
to return to the Draw screen. 

If you chose the Screen button: 

If you chose the Pri nter button: 
Select O K  to begin printing. 
The picture begins to print, and a dialog 
box appears, containing information about 
the print operation. You can select 
CANCEL at any time to stop the operation. 

At the Fi  lename: prompt, type the name 
you want to give the “printed” file, using 
eight or fewer characters. 

If you chose the F i  1 e button: 
a. 

Note:  Be sure to type a complete path- 
name of up to 64 characters If you 
want to save the file on a different 
drive or in a different directory. 

Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the . prn file (if you used 
that extension) listed in any application’s 
list box. It does, however, reside on disk. 
You can view it and other files in the direc- 
tory from the desktop’s Files View. 

b. 

Exit 
Exits the Draw application and return you to the 
desktop. 
1. Select E x i t  from the File Menu (F2). If you 

made changes, Save changes? appears. Con- 
tinue with Step 2. 
If you have not made changes and the picture al- 
ready has a filename, you will return to the 
desktop. 

2. Select YES, NO, or CANCEL. 
If the document is untitled, Save as : appears. 
Continue with Step 3. 
If the document is titled, you will return to the 
desktop. 

63 



DeskMate User’s Reference 

3. At the Save as : prompt, type a filename of eight 
characters or fewer. 
Draw automatically adds the extension .fig unless 
you specify otherwise. 

4. Select SAVE to complete the task. 

Run 
Runs another DeskMate application file or another 
software package without returning to the desktop. 
1. Select Run from the File Menu (F2). 

If you made changes, Save changes? appears. 
Continue with Step 2. If you have not made chan- 
ges, continue with Step 5. 

2. Select YES, NO, or CANCEL. 
If the picture is untitled, Save as : appears. Con- 
tinue with Step 3. 

If the document is titled, continue with Step 5. 

eight characters or fewer. 
Draw automatically adds the extension .fig un- 
less you specify otherwise. 

4. Select SAVE to complete the task. 
A dialog box appears. 

5. At the Program: prompt, type the name of the 
application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include 
the extension when you type the name. Also, if 
the file is in a directory other than the current 
directory, type a full pathname, including the 
drive and directory. 

6. At the Data f i 1 e : prompt, either type the name 
of the data file you want to use with the chosen 
application (or program), or leave the prompt 
blank. 
If you leave the prompt blank, DeskMate runs the 
application or program you specify without open- 
ing a corresponding data file. 

7. Select OK to complete the task. 

3. At the Save as: prompt, type a filename of 

DeskMate might ask you to insert the diskette con- 
taining the application or software package you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 

tains the desktop.pdm file. After you insert the dis- 
kette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run this program. 
1. Select About from the File Menu (PZ). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Edit Menu 
The Edit Menu (F3) options let you edit your Draw 
documents. For example, you can move or copy in- 
formation, select everything on the canvas, or resize 
a picture to meet your needs. 

1 Cl ipar t  ... I 

See “Other Draw Information” in this section for in- 
structions on how to use the mouse to use the edit 
features in Draw. 

Ctip art 
Clip art is predrawn art that you can paste on your 
canvas and edit. 
1. Select C1 i p art  from the Edit Menu (F3). 

Note: If a dialog box appears and asks if 
you want to search the system for the 
default file, select OK. 

A dialog box with clip art appears. You can either 
insert one of these pictures onto your canvas by 
selecting Paste or select Load to display other clip 
art files. You can then open one of the displayed 
files. 
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2. Use the arrow keys to choose the picture you 

3. Select the Paste button. 
want to insert. 

The picture appears in the upper left corner of 
the canvas, surrounded by the select box. 

4. Move the art to where you want it on the can- 
vas. (For information about moving a selected 
object, see the Sel ect option on the Tools Menu 
(F7) .I 

cut 
Cuts (or removes) a picture, object, or element in 
your file and places it on the Clipboard. 
1. Select the picture, object, or element you want 

2. Select C u t  from the Edit Menu (P3). 
to cut or remove. 

Draw moves the selected picture and places it on the 
Clipboard. 
To place the Clipboard information into another ap- 
plication or another picture, use the Edit Menu’s 
(F3) Paste Option. 

Note: You can only move a picture from Draw 
into another Draw file, or the Text or Form Setup 
applications. 

COPY 
Copies a picture, object, or element so that you can 
duplicate it in another application or another picture. 

Note: You can make a copy of a picture from 
Draw and use it in the Text, Draw, or Form Setup 
applications. 

to copy. 
1. Select the picture, object, or element you want 

2. Select Copy from the Edit Menu (F3). 
Draw copies the selected information to the Clip- 
board. You can then use the Paste option to reinsert 
the information. 
To place the picture, object, or element into another 
application’s file, use the Paste option on the Edit 
Menu (F3) to insert the Clipboard information. 

Paste 
Inserts pictures, objects, and elements which you 
have placed on the Clipboard, at the cursor location. 

1. Move the cursor to where you want to insert the 

Note: Be sure to position the cursor so 
that the picture fits within the margins 
of the file into which you are inserting 
it. You might need to use the Page 
setup option on the File Menu (P2) to 
adjust the page margins to accom- 
modate the picture. 

Clipboard information. 

2. Select Paste from the Edit Menu (F3). 
Draw inserts the Clipboard information at the cur- 
sor location. Keep in mind that you might need to 
revise the way that the information appears on 
the screen (for example, inserting or deleting 
spaces or aligning text). 
If you are inserting the Clipboard information 
into another Draw picture, the picture appears in 
the upper left corner of the canvas. 

Clear 
Deletes an object or element from your picture. 
1. Use the Select option on the Tools Menu (€77) 

to outline the object or element you want to 
delete. 

2. Select C1 ear from the Edit Menu (F3). 
The selected object or element disappears from the 
canvas. 

Select all 
Selects everything on a canvas. 

Move 
You can use this option to move a picture, object, or 
element. 

Select Select a1 1 from the Edit Menu (€73). 

1. 

2. 

3. 
4. 

Use the Sel ect option on the Tools Menu (P7) 
to outline the picture, object, or element you 
want to move. 
Select Move from the Edit Menu (F3). 
Draw outlines the selected area. 
Use the arrow keys to move the outline. 
Press the space bar to place the selected area on 
the canvas. 
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Reshe  
Use this option to change the size of a selected area. 
1. Use the Select option on the Tools Menu (F7) 

to outline the picture, object, or element you 
want to resize. 

2. Select Resi ze from the Edit Menu (P3). 
3. Use the arrow keys to resize the object. 
4. Press the space bar when you are finished. 

The picture appears in its rescaled size. 

Add Corner 

Lets you select a comer (vertex) to a polygonal 
drawing. 
1. Select Select from the Tools Menu (F7) to 

choose the object to which you want to add a 
comer. 

2. Select Add Corner from the Edit Menu (F3). 
3. Move the cursor to the place on the drawing 

where the new corner is to be placed and 
press the spacebar. 

4. Use the arrow keys to adjust the line. 

5. Press the space bar again when you finish. 

Mowe Corner 
Lets you move a comer of a polygonal object to a 
new place. 
1. Select Select from the Tools Menu (F7) to 

choose the object from which you want to move 
a comer. 

2. Select Move Corner from the Edit Menu (F3). 
3. Move the cursor to the corner you want to 

4. Use the arrow keys to move the comer. 
5. Press the space bar again when you finish. 

move, and press the space bar. 

Delete Corner 
Lets you remove a comer from a polygonal object. 
1. Select Select from the Tools Menu (F7) to 

choose the object from which you want to 
delete a comer. 

2. Select Delete Corner from the Edit Menu (F3). 

3. Move the cursor to the comer you want to 

4. Press the space bar. 
delete. 

Actions Menu 
The Actions Menu (F4) options let you work with 
your different picture designs. For example, you can 
duplicate part of a picture on the same canvas, flip a 
picture (or part of a picture) horizontally or vertical- 
ly, rotate a picture, or group elements together to 
make objects. 

See the “Other Draw Information” section for in- 
structions on how to use tlie mouse to edit in Draw. 

Duplicate 
Duplicates pictures, objects, and elements on the 
same canvas. 
1. Select the Select option on the Tools Menu 

(F7) to choose the picture, object, or element 
you want to copy. 

2. Select Dupl  i cate from the Actions Menu (P4). 
The new picture, object, or element appears in 
the upper left corner of the canvas. 

where you want it on the canvas. 
3. Use the arrow keys to move the picture to 

Move to top  
Moves one element in front of another element. 
1. Select the Select option on the Tools Menu 

2. Select Move t o  top from the Actions Menu (€74). 
(F7) to choose the element you want to move. 

The selected element moves to the foreground. 
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Move to bottom 
Moves one element behind another element. 

to select the element you want to move. 

(F4). 

1. Use the Select option on the Tools Menu (F7) 

2. Select Move t o  bottom from the Actions Menu 

The selected element moves to the backgound. 

Flip horisontal 
F l i p  a picture, object, or element from left to right. 
1. Select Select on the Tools Menu (P7) to choose 

the picture, object, or element you want to flip. 
2. Select F1 i p  ho r i zon ta l  from the Actions Menu 

(F4). 
After you flip a picture, object, or element, it oc- 
cupies the same space as the original, unfipped pic- 
ture, object, or element. 

Flip vertical 
Flips a picture, object, or element from top to bot- 
tom. 
1. Use the Select option on the Tools Menu (F7) 

to select the picture, object, or element you 
want to flip. 

2. Select F1 i p verti cal  from the Actions Menu 

After you flip a picture, object, or element, it oc- 
cupies the same space as the original, unf ipped  pic- 
ture, object, or element. 

Rotate 
Rotates a picture, object, or element by any angle. 
By rotating the area once, you turn the selected area 
on its side and to the right. You can rotate the same 
area twice or three times to turn it upside down or 
on its side to the left. The rotated area occupies the 
same space as it did before you rotated it. 
1. Select the Select option on the Tools Menu 

(F4) * 

(P7) to choose the picture, object, or element 
you want to rotate. 

2. Select Rotate from the Actions Menu (P4). 

Make object 
Groups elements together into an object, which can 
be used as a single element. 

1. Use the Select option on the Tools Menu (P7) 
to choose all the elements you want to include 
in an object. 

2. Select Make object from the Actions Menu (F4). 
The selected elements are now an object. 

Note:  To reverse the process, use the Break 
ob j e c t option on the Actions Menu (F4). 

Break object 
Breaks an object into its basic elements. If you have 
used the Make object option on the Actions Menu 
(F4), and you decide that you need to change one of 
the object's elements, you will need to break it first. 
1. Use the Select option on the Tools Menu (P7) 

2. Select Break object from the Actions Menu 
to choose the object. 

(F4). 
The selected object is broken into its elements. 

Note: To reverse the process, use the Make 
object option on the Actions Menu (F4). 

Align 
Lets you vertically or horizontally align two or more 
selected objects. 
1. Select Select from the Tools Menu (F7) to 

2. Select A1 i gn  from the Actions Menu (P4). 

3. Choose the area you want to align. 
4. Select O K  to complete the task. 

choose the objects you want to align. 

A dialog box appears. 

Align text 
Lets you align text with the base line of a text ele- 
ment. 
1. Select Select from the Tools Menu (P7) to 

2. Select A1 i g n  text from the Actions Menu (P4). 

3. Choose the text you want to align. 
4. Select OK to complete the task. 

choose the text you want to align. 

A dialog box appears. 

The text in the selection box is automatically aligned 
with the base line of the first text element in the 
box. Graphics elements in the box are unaffected. 
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Zoom Menu Options Menu 
The Zoom Menu (F5) options let you change the 
view of the canvas. For example, you can increase 
the size to see or draw things in more detail, or you 
can decrease the size to see what the whole canvas 
looks like on the screen. 

Normal 
Lets you see the normal (original) view of the pic- 
ture. 

Select Normal from the Zoom Menu (F5). 

Two times 
Lets you see a magnified view (twice the normal 
size) of an area on your picture. 

Select Two times from the Zoom Menu (F5). 

Four times 
Lets you see a magnified view (four times the nor- 
mal size) of an area on your picture. 

Select Four times from the Zoom Menu (F5). 

HaZf 
Lets you see the entire picture at half the normal 
size. 

Select Hal f from the Zoom Menu (F5). 

Quarter 
Lets you see the entire picture at one-quarter of the 
normal size. 

Select Quarter from the Zoom Menu (F5). 

The Options Menu (P6) options let you customize 
your drawing tools. For example, you can change 
colors, adjust the weight and style of the lines, or 
choose whether you want to use the mouse or key- 
board in Draw. 

F 

Patterns. 
Colors.. . 
Line . .  I 
Brush., . 
Text.. . 

dUse  House 

Patterns 
Choose patterns for filling enclosed shapes. 
1. Select Pat te rns  from the Options Menu (F6). 

2. Choose the fill pattern you want to use. 
A dialog box appears. 

Note: The empty option lets you draw an outline 
with no fill pattern. 

3. Select OK to complete the task. 
Each time you use a tool that draws an enclosed 
shape, Draw fills the shape with the pattern you 
chose. 
If you choose a new fill pattern, subsequent enclosed 
shapes will be filled with that new pattern. 
To change the fill pattern of an enclosed shape or to 
insert a fill pattern in an empty shape, simply use 
the Select option on the Tools Menu (F7) to select 
the shape and then choose a new fill pattern. 
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colors 
Draw uses four colors at one time that you select 
from a palette of 16 colors. This option lets you 
change to the colors you want to use. 
1. Select Colors from the Options Menu (F6). 

2. Choose one of the four attributes that you want 
A dialog box appears. 

to change (line, text, pattern foreground, or 
p a t  tern background). 

3. Choose one of the colors. 
Note:  There are 16 colors for EGA, 4 
for the Tandy 1000, and 2 for Hercules, 
CGA, and B/W EGA. 

4. Select OK to complete the task. 
Draw assigns the colors to the attributes you chose. 

Line 
When you draw elements, you can make the outlines 
appear in one of five weights, and one of four styles, 
by using this option. 
1. Select Li ne from the Options Menu (F6). 

2. At the Weight: prompt, choose the line weight 

Note:  Use the invisible line weight if 
you want to fill an enclosed shape with 
a pattern, and you do not want the 
shape’s border to appear. 

3. At the Style: prompt, choose the type of line 

4. Select OK to complete the task. 
The program applies the line specifications you 
chose to the next line(s) you draw. 

Brush 
Choose the Brush shape that you want to use when 
you paint. 

A dialog box appears. 

you want to use. 

you want to use. 

1. Select Brush from the Options Menu (F6) if you 
want to change the brush size and shape. 

2. Select the Brush option from the Tools Menu 
(P7) if you are painting a line or the Fi  1 1 ed 
Brush option if you are painting an enclosed 
Shape. 

3. Draw an enclosed shape. 

4. Fill the new element by pressing the space bar if 
you are using a keyboard, or by double clicking 
if you are using a mouse. 

Note:  See the Patterns option on the 
Options Menu (F6) for more hforma- 
tion on filling an empty shape or chang- 
ing a fill pattern. 

Text 
Lets you choose attributes for the text you type on 
the canvas. See the Using Fonts in Draw box for 
more detail. 
1. Select Text from the Options Menu (P6). 

A dialog box appears. 
2. At the Font type box, choose printer or out-  

1 i ne. 
Choose p r i n t e r to use the fonts built into your 
printer. This will let you print more quickly and 
with higher quality. You cannot, however, change 
the point size, width, or attributes of the charac- 
ters. 
Choose o u t  1 i ne if you want the flexibility to 
make point size, width, or attribute modifications 
to your font characters. 

to use. 
3. At the Fonts list box, choose the font you want 

4. If necessary, change the poi  n t si ze setting. 
Note:  You can use any point size 
within the 0-500 range. 

5.  If necessary, change the line w i d t h setting. 
Note:  You can use any width within 
the 0-300 range. 

6. If necessary, choose the text attributes you want 

7.  Atthe Justification box, choose thejustifica- 

8. Select OK to complete the task. 

to use. 

tion you want to use. 

Draw applies the typestyle and text attributes you 
chose to the text you type. 
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Using Fonts in Draw 
ro make the best use of DeskMate’s font 
apabilities in Draw, the following information 
ihould be noted: 

If 6 u  are using a hard drive system, all fonts 
must be stored in a single directory. DeskMate’s 
Install program automatically copies all fonts to 
the same directory, but if you add addition 
fonts, be sure they are in that directory. 

If you are using a diskette-based system, the dis- 
kette containing the fonts must be in the drive 
so that Draw can access them. (If you are using 
data diskettes, you can copy your font files 
(*.ffl) to your data diskettes. You should also 
copy your printer driver (drnpdxxxx.res and 
drnpexm.res) to these diskettes.) 

If Draw cannot find a font, the application sub- 
stitutes large, block letters on the screen. These 
are your indication that the requested font was 
not accessible. 

Use keyboard 
Lets you quickly change from using the mouse to 
using the keyboard in the Draw application. 

Select Use keyboard from the Options Menu 
(F6) * 

Use m u s e  
Lets you quickly change from using the keyboard to 
using the mouse in the Draw application. 

Select Use mouse from the Options Menu (F6). 

Scrol l  bars 
Lets you use scroll bars to move up and down and 
right and left on the canvas. 

Select Scroll bars from the Options Menu 
(p6). The scroll bars appear on the screen, and 
YOU can use the mouse pointer to adjust the 
scroll bar. 

Tools Menu 
The Tools Menu (F7) options let you choose which 
tools you want to draw with. For example, you can 
use the ellipse tool to draw circles, the rectangle tool 
to draw squares or rectangles, or the polyline tool to 
draw continuous, connecting lines. 

Select CtrltS 
d i n e  CtrltL 

Rectangle CtrltR 
Ellipss CtrltE 
I G X t  Ctrl tT 
Brush CtrltB 
Fi l l ed  Brush 
llrc CtrltL 
hlyline 
Palygan CtrltP 

See “Other Draw Information” in this section for in- 
structions on how to use the mouse to edit in Draw. 

Select 
Lets you select pictures, objects, and elements. The 
Sel ect  option makes it easy for you to design a pic- 
ture. For example, you can flip, rotate, move copy, 
or delete the selected part of the picture. 

~ 

lfyou do not get the entire object you are hying to 
select within the box, the object is not selected 

1. Select Select from the Tools Menu (€77) to 
select pictures, objects, and elements. 

2. Use the arrow keys to position the cursor out- 
side the corner of the area you want to select. 

3. Using the arrow keys, pull the select border 
until it surrounds the picture you want to select. 

The picture now appears surrounded by a box with 
handles. 
If you are using a mouse and you want to move the 
picture, object, or element, point to the center of the 
selected area and drag it to the desired area on the 
canvas. 
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If you are using a mouse and you want to resize a 
picture, object, or element, point to one of the hand- 
les of the selected area and drag it to the desired 
size. If you want to resize a picture, object, or ele- 
ment using the keyboard, use the Resi ze option on 
the Edit Menu (F3). 

Line 
Lets you draw straight lines on the canvas. To set 
the line’s attributes, use the Li ne option on the Op- 
tions Menu (F6). 
1. Select Line from the Tools Menu (€77). 
2. Use the arrow keys to position the cursor where 

you want to start the line to indicate the line’s 
first endpoint on the canvas. 

3. Press the space bar to indicate the line’s second 
endpoint. 

4. Use the arrow keys to draw the line. 
5. Press the space bar again to finish the line. 

The lines you draw appear in the currently chosen 
line weight and style. 

Rectangle 
Lets you draw squares and rectangles using the cur- 
rent line weight, line style, and fill pattern. To 
choose the line weight/style and fill pattern, use the 
L i  ne option on the Options Menu (F6) and the 
Patterns option on the Options Menu (F6). 
1. Select Rectangle from the Tools Menu (F7). 
2. Use the arrow keys to position the cursor at a 

3. Press the space bar. 
4. Expand the box using the arrow keys. 
5. Press the space bar. 

comer of the rectangle. 

The box now appears on the canvas at the location 
you chose. 

Ellipse 
1. Select E l  1 ipse from the Tools Menu (F7). 
2. Use the arrow keys to position the cursor at the 

center point of the ellipse, and press the space 
bar. 

3. Use the arrow keys to stretch the ellipse to the 
desired size. 

4. Press the space bar. 

Text 
Lets you type text on the canvas. The text attributes 
are set using the Options Menu’s (F6) Text option. 
1. Select Text from the Tools Menu (F7). 
2. Use the arrow keys to position the cursor where 

3. Type the text you want to include in the picture, 
you want the text to begin. 

and press ENTER when you finish typing. 

The text you typed appears in the picture. 

B r u s h  
Lets you paint with different brush tvpes that you 
select from the Brush option on the Options Menu 

1. Select the Brush option from the Tools Menu 

2. Use the arrow keys to position the c m r  where 

3. Press the space bar. 
4. Use the arrow keys to paint on the screen with 

(F6) * 

(F7). 

you want to begin painting. 

the brush you chose. 

Filled B r u s h  
Fills an object you draw to its outer boundaries with 
a prescribed pattern. 
1. Select Pattern from the Options Menu (€76). 
2. Choose a pattern to fill the object you created. 
3. Select Fi 1 1  ed Brush from the Tools Menu (€77). 
4. Use the arrow keys to position the cursor inside 

5.  Press the space bar. 
the boundaries of the object. 

The object is filled with the pattern you chose. 

A r c  
Draw arcs and irregular curves using the arc tool. 
1. Select Arc from the Tools Menu (F7). 
2. Use the arrow keys to move the cursor to hdi- 

cate the first endpoint of the curve. 
3. Use the arrow keys to move the c m r  to in&- 

cate the second endpoint of the curve. 
4. Press the space bar. 

Draw connects the endpoints with a straight line. 
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5. Move the cursor to the line and press the space 

6. Use the arrow keys to stretch it to the desired 

7. Press the space bar again when the arc is posi- 

bar to select it. 

curve pattern. 

tioned correctly. 

Polyline 
Lets you draw an object of multiple joining lines. 
1. Select Poly1 i ne from the Tools Menu (F7). 
2. Use the arrow keys to position the cursor to indi- 

3. Press the space bar. 
4. Use the arrow keys to expand the line to its 

second endpoint. 
5. Press the space bar. 
6. Expand the line to its next endpoint. 
7. Continue to expand new lines until you form 

8. Press ENTER when you are finished adding lines 

cate the first endpoint of the line. 

the desired shape. 

to the polyline. 

Polygon 
Lets you draw a polygon that automatically fills 
using the currently selected pattern. 
1. Select Polygon from the Tools Menu (F7). 
2. 

3. 

4. 

5. 
6. 
7. 

8. 

Use the arrow keys to indicate the first endpoint 
for the first line. 
Press the space bar. 
Use the arrow keys to expand the line to its 
second endpoint. 
Press the space bar. 
Expand the line to its next endpoint. 
Continue to expand new lines until you form 
the desired enclosed shape. 
Press ENTER to fill the new element with the 
selected pattern. 
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Draw Tasks 
This section lets you look up Draw application tasks. 
The tasks are listed alphabetically, and the name of 
the menu and the option(s) needed to perform the 
task are listed beneath the task. If you don’t know 
how to use the option@) needed to perform the 
task, see the “Menu Options” section for detailed in- 
formation and step-by-step instructions. 
Add a Comer 

Edit F3 (Add Corner) 
Break an Object 

Actions F 4  (Break object) 
Change Colors 

Options F6 (Colors) 
Change the Size of an Object 

Tools F7 (Select) 
Edit F3 (Resi ze) 

Zoom F5 (Normal, Two times, Four times, Half,  
or Quarter) 

Choose a Fill Pattern 
Options F6 (Patterns) 

Choose the Line Weight and Style 
Options F 6  (Li ne) 

Choose the Typestyle and Text Attributes 
Options F6 (Text) 

Create a New Draw File from Within a Picture 
File F2 (New) 

Create a Picture with the Draw Tools 
ToolsP7 (Select, Line, Rectangle, Ellipse, 
Text, Brush, Filled Brush, Arc, Poly1 ine, and 
Po 1 ygon) 

Delete a Comer 
Edit F3 (Delete Corner) 

Delete Part of a Picture 
Tools F7 (Select) 
Edit F3 (C1 ear) 

Change the View of the Canvas 

Display the Prograrrs/Application Name and Version 
Number 

Duplicate a Picture Into Another Application 
File F2 (About) 

Tools F7 (Select) 
Edit F3 (Copy) 
File F 2  (Run) 
Edit F3 (Paste) 

Duplicate a Picture Into Another Picture File 
Tools F7 (Select) 
Edit F3 (Copy) 
File F2 (Open) 
Edit F3 (Paste) 

Tools F7 (Select) 
Actions F 4  (Dupl i cate) 

Exit Draw 
File F2 (Exit) 

Flip an Area Horizontally 
Tools F7 (Select) 
ActionsF4 (Flip horizontal) 

Flip an Area Vertically 
Tools F7 (Select) 
Actions F4 (F 1 i p vert i c al) 

Format a Page Layout 
File F2 (Page setup) 

Insert Clip Art 
Edit F3 (C1 i p  ar t )  

Make an Object 
Tools F7 (Select) 
Actions F 4  (Make object) 

Edit F3 (Move Corner) 

Tools F7 (Select) 
Edit F3 (Cut) 
File F2 (Run) 
Edit F3 (Paste) 

Tools F7 (Select) 
Edit F3 (Cut) 
File F2 (Open) 
Edit F3 (Paste) 

Move Part of a Picture 
Tools F7 (Select) 
Edit F3 (Move) 

Tools F7 (Select) 
Actions F 4  (Move t o  bottom) 

Tools F7 (Select) 
Actions F4 (Move t o  top) 

Duplicate Part of a Picture on the Same Canvas 

Move a Corner 

Move a Picture to Another Application 

Move a Picture to Another Picture 

Move an Element of the Picture to the Background 

Move an Element of the Picture to the Foreground 
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Open an Existing Draw File from Within a Picture 

Open an Exiting Draw File in Another Drive or 
Directory 

Print a Picture 

Resize a Picture 

File FZ (Open) 

File F2 (Open) 

File FZ (Print) 

Tools P7 (Sel ec t) 
Edit P3 (Resi ze) 

Tools F7 (Select) 
Actions P4 (Rotate) 

Run Another Application 
File P2 (Run) 

Select Everything on the Canvas 
EditF3 (Select a l l )  

Store Updates to a New Picture 
File FZ (Save as) 

Store Updates to an Existing Picture 
File F2 (Save) 

Use the Keyboard Instead of a Mouse 
Options F6 (Use keyboard) 

Use the Mouse Instead of the Keyboard 
Options F6 (Use mouse) 

Rotate a Picture 

Other Draw 
Information 
Correct an Error 

Move the Marker 
Moving the marker around the screen in Draw is 
usually a matter of pressing arrow keys or pointing 
and clicking with a mouse. These additional tips will 
help you move the marker farther and faster. 
Keyboard.  Pressing an arrow key moves the 
marker one position (eight pixels or eight scans) in 
the indicated direction. Pressing PG UP, PG DN, 
CTRL+PG UP, or CTRL+PG DN moves you to the 
top, bottom, left, or right edge of the canvas respec- 
tively. To move a smaller or larger number of pixels, 
type the number of pixels you want to move, and 
then press the arrow key. 
Press CTRL+HOME to move the marker to the 
upper left comer of the screen. Press CTRL+END to 
move the marker to the bottom right comer of the 
screen. 
You can scroll through the canvas by holding down 
the arrow key for the direction in which you want to 
move. Release the key when you reach the desired 
point on the canvas. 
Mouse. Position the marker anywhere on the 
screen by pointing to the desired location and click- 
ing. To display parts of the canvas not currently on 
the screen, point to one of the scroll arrows on the 
Scroll bars (select the Scroll b a r  option from the 
Options Menu (F6)), and click. This scrolls the 
screen two characters in the direction indicated by 
the arrow. Pointing to one of the arrows and holding 
down the mouse button scrolls the screen con- 
tinuously until you release the button. 

When you type text in a picture, you are in Insert 
mode. In this mode, press the BACKSPACE key to 
delete the character directly to the left of the 
marker. To completely erase all the text you have 
typed, use the Tools Menu’s (F7) Select option to 
select the text you want to erase, and then use the 
Edit Menu’s (P3) C1 ear option to delete the text. 
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Overview 
What Is I t?  
Those important records will always be easy to put your hands on with 
DeskMate’s Filer application. Using Filer, you can “write” record-keeping in- 
formation on records, which you can think of as electronic index cards. You 
can store related records in the same file, just as you might gather a group 
of index cards in an index card file box. 

What Can I Do with I t?  
The Filer application contains various features that will make your record- 
keeping tasks simple. With this application, you can: 

Keep track of medical records, club membership and attendance records, 
recipes, household inventories, tax-deductible contributions, and so on 
Sort the stored Filer information and print various reports 
Locate records quickly and easily 
Create your own record layouts using the Form Setup application 

How Do I Use It? 
When you open the Filer application, the Open F i  le  dialog box appears. You 
can start Filer by selecting an existing file from this list box. Filer comes 
with two files already created for you - invntory.fi1 and carmaint.fi1. When 
you open a file, you see a screen similar to the one at the right. 

When you want to create a newfile, you must either duplicate an exist- 
ingfile’s layout (using Copy 1 ayou t s on the File Menu (F2) or create 
a customized layout using the Form Setup application). 

The record shown at the right is from the invntory.fi1 file. When you open a 
file, Filer automatically displays the file’s first record. Each record is divided 
into several fields in which you can type various items of information. 
Think of the Filer screen as an index card or record. To begin adding infor- 
mation, simply select Add from the Records Menu (F4). A new, blank record 
appears. You can then type the information needed for each field. Press 
TAB and SHIFT+TAB to move the highlight forward and backward 
through the fields. Or, if you have a mouse, simply point and click on the 
field you want to move to. 
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To add another record, select Add from the Records Menu (F4) again. Desk- 
Mate stores the record currently on the screen and displays another blank 
form. 
When you finish adding records, select an available option other than an 
Edit Menu (F3) option. Filer stores the record and performs the action you 
Chose. 

Note: Filer sorts entries from the oldest to the newest. Therefore, each 
time you add or change a record, that record goes to the end of the file. 
You can, however, change the sort order. See the instructions for the 
Records Menu’s (F4) Sort option. (Invntory.fi1 is sorted by the first field.) 

You can move through the records in your file and display a specific one by 
using the F i r s t ,  L a s t ,  Next, and Prev buttons (or the corresponding options 
on the Records Menu (F4)). 
After adding records in your file, you can use the Print record option on 
the File Menu (F2) to print a copy of the current record (or all records in 
the current file) on paper. You can also print the records to the screen or to 
another file. 
Filer also lets you print a report containing specific information from your 
file. If you use invntory.fi1 or carmaint.fi1, report layouts have already been 
created, but you can change them using Form Setup. When you create a 
new record layout in Form Setup, you can also create a report layout for the 
file. 
To learn the basics about using Filer, see the “Filer” article in the Getting 
Started magazine. Then, when you’re familiar with Filer, this chapter will 
provide you with a quick way to answer specific questions. You can look up 
the step-by-step instructions for each menu option. If you want to know 
which options to use to perform a specific task, check the “Filer Tasks” sec- 
tion at the end of this chapter. 
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Menu Options 
Filer has three menus that list the options you can 
use with the application. The key that you press to 
see each menu appears beside the menu name. (For 
example, press the F2 key to see the File Menu.) A 
shaded option on a menu means that the option is 
not available. Some options have accelerator keys 
listed next to them. Use these keys to perform tasks 
without pulling down a menu. For example, when 
you want to add a record, press CTRL+A to select 
Add from the Records Menu (F4). 
This section explains each Filer menu on the menu 
bar and also contains step-by-step instructions on 
how to use each option. 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can open existing 
files, print Filer records and reports, or run another 
program or DeskMate application. 

Open.. . 
Copy l a y o u t s . ,  . 
Page setup. I I 
Forn setup 
Print record.. . 
Print repart., , 
E x i t  

Open 
Opens an existing file from within Filer or another 
drive or directory. 
1. Select Open from the File Menu (F2). 

A dialog box appears, listing all the files you can 
open in the current directory. In addition, the box 
lists all available subdirectories and drives. (The 
symbol [..I indicates the parent directory.) 

2. Highlight the file you want to open or the ap- 
propriate drive or directory. 

3. Select OK. 
If you highlighted a file, the first record in the E- 
quested file appears. 
If you highlighted a drive or directory, its fila 
and directories appear in the list box. Other avail- 
able drives appear in the list as well. Continue 
with Steps 4-6. 

4. Repeat Steps 2 and 3 until the list box displays 

5.  Highlight the file you want to open. 
6. Select OK to complete the task. 

the name of the file you want to open. 

The first record in the requested file appears. 
Note: When you open a file from a different 
drive or directory, subsequent “open” operations 
will display a list of files, drives, and directories 
from the directory in which the opened file 
resides. However, when you exit Filer, the 
desktop displays a list of files from the directory 
you were in when you accessed the Filer applica- 
tion. 

COPY zayours 
Creates a new file by copying the layout of the exist- 
ing file. Existing files can be listed on the desktop in 
a F I L E R  application box or in the dialog box that ap- 
pears when you use the File Menu’s (Fa) Open op- 
tion. 

Note: You cannot copy layouts to another disk- 
ette in the same drive. 

1. Open the file whose layout you want to copy. 
The first record of the file appears on the screen. 

2. Select Copy 1 ayouts  from the File Menu (F2). 
A dialog box appears. 

3. At the Copy t o :  prompt, type a filename for the 
new file of eight or fewer characters. If you do 
not include a filename extension, Filer automat- 
ically adds the extension .fil. 

Note: Be sure to type a complete path- 
name of up to 64 characters if you want 
to save the file on a different drive or in 
a different directory. 

4. Select O K  to complete the task. 
Filer creates the new file using the currently dis- 
played layout. You are still in the original file, how- 
ever. To begin entering information in the new file, 
open the file by selecting Open from the File Menu 
(F2). 
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Page setup 
Lets you design a page layout for your printed 
reports. 
1. Select Page setup from the File Menu (F2). 

A dialog box appears. Some of the options might 
not be available, depending on the type of printer 
you are using. Additional information about each 
option appears after the steps. 

2. Change the desired options. 
3. Select OK to complete the task. 

Paper Size. Choose the size paper you are using. If 
you choose Other, be sure to indicate the correct 
width and height in the appropriate fields. 
Lef t  margin. Type the number of spaces you want 
for the left margin. 
Line width. Type the total number of characters 
you want to print on one line. 
For example, if you are using 8l4-inch paper and a 
ten-characters-per-inch font (such as Courier), the 
total line width is 85 characters. If you set a left mar- 
& of lIh-inches (15 spaces) and you want a right 
margin of 1 inch (ten spaces), subtract the left and 
right margin amounts from the total line length (85- 
25=60). The resulting total of 60 spaces (6 inches) 
is the printed line width. Be sure that the sum of the 
entries for the Left margin and Line width  settings 
does not exceed the width of your paper. 
Lines per page. Type the total number of lines on 
each sheet of paper. For example, 8%- by 11-inch 
paper contains 66 lines in the portrait format when 
figured at six lines per vertical inch. 
Double space. Filer does not let you change this 
setting. 

Pause between pages. If you are not using con- 
tinuous form paper, choose this option so that you 
can insert a new sheet of paper after each page 
prints. 
Print sideways. Choose this box to print sideways 
on your paper. When printing in this format, Desk- 
Mate only prints ten characters per inch. 

CENTER. By selecting this button, you can center 
your document on the page both vertically and 
horizontally. Enter the Left margin, Line w i d t h ,  and 
L i  nes per page settings as accurately as you can. 
Then, select the CENTER button, and DeskMate will 
automatically adjust the L i  ne w i d t h  and L i  nes per 
page settings so that the body of the document is 
centered on the paper (based on your current 
printer selection). 

Form setup 
Lets you switch to the Form Setup application 
without exiting Filer. 
If you created a layout file using the Form Setup ap- 
plication, you can use the layout file to develop a 
file in Filer. If, as you add records in Filer, you 
decide to change the record or report layout, you 
can switch quickly to Form Setup, make the chan- 
ges, and return to Filer to continue adding records 
to the same file. 

Select Form setup from the File Menu (P2). 
The record layout appears on the screen. To change 
the layout, refer to the “Form Setup” chapter. When 
you finish changing the layout file, return to Filer by 
following the instructions in the ‘‘Form Setup” chap- 
ter. The first record in the file appears, reflecting the 
changes you made in the Form Setup application. 

Note: If you used Form Setup to shorten any 
fields in which you had already typed infonna- 
tion, the final characters are dropped to accom- 
modate the new, shorter field length. If you 
deleted any fields, the information previously 
typed in those fields is lost. 

Print record 
Prints the current record or all records in the current 
file. You can print Filer information to the screen, on 
paper, or to another file. 
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Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using. Also, be sure to set up your 
page layout using the File Menu’s (F2) Page setup 
option. 
1. 

2. 

3. 

4. 

Select Print record from the File Menu (F2). 
A dialog box appears. 
Choose either Print current record or P r i n t  
a l l  records. 

Note:  If you have used the Records 
Menu’s (F4) Find option to limit the 
number of records to print, the Pri n t  
a1 1 records option wlll print only the 
selected records. 

Select OK. 

Another dialog box appears. 
At the Print t o :  prompt, choose the Screen, 
Printer, or File b u t t o n .  
The Screen button lets you print the record(s) to 
the screen so that you can see how the record(s) 
will look on the page. 

Note:  The screen representation might dif- 
fer from the printed form on paper. For ex- 
ample, if you are using a daisy wheel 
printer or ASCII format, only the text of 
the record is printed on a hard copy. 

The Printer button lets you print the record(s) 
on paper. 
The Fi  1 e button lets you print the record(s) to 
another file. Printing to a file stores the file on 
disk, using the name you give plus the extension 
.pm. You can then use the MS-DOS print com- 
mand to print the file from another computer 
that is not running DeskMate. Or, you might send 
the file to another computer, using the Telecom 
application. 

Note:  The printer used to print the file 
from MS-DOS must be the same type as 
the one you are using with DeskMate 
(the one you assigned with the Pri n ter  
option on the Setup Accessory‘s Options 
Menu). If you want to transmit the file 
using DeskMate’s Telecom application, 
choose ASCI I as the printer type. 

5.  Follow the appropriate instructions below for 
the button you chose. 

[f you chose the Screen button: 
a. 

b. 

Select O K  to complete the task. 
The current record or the first record ap- 
pears on the screen. 
If you are printing all the records, you can 
scroll through a record or use the Next page 
option on the Options Menu (P2) to view 
the next record. 
When you finish viewing the record(s) on 
the screen, select Exi t from the Options 
Menu (F2). 
The screen returns to the normal screen dis- 
play. 

If you chose the Pri nter button: 
Select OK to complete the task. 
The record(s) begin to print, and a dialog 
box appears, containing information about 
the print operation. You can select 
C A N C E L  at any time to stop the operation. 

Note:  If you chose the Pause between 
pages option when you formatted the 
page layout, the printer stops to let you 
change sheets of paper when each page 
finishes printing. A dialog box appears, 
asking whether you want to reprint the 
current page. 
To print the next page, insert a new 
sheet of paper and select NO. If you 
want to reprint the same page, insert a 
new sheet of paper and select YES. 
Select C A N C E L  to stop the print opera- 
tion. 
When you finish printing, select NO at 
the Reprint current page? prompt. 

At the F i  1 ename: prompt, type the name 
you want to give the “printed” file, us@ 
eight or fewer characters. Filer automat- 
ically assigns the extension, .pm, unless 
specified otherwise. 

If you chose the Fi  1 e button: 
a. 

Note:  Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 
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b. Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .pm (if you used that 
extension) file listed in any application box. 
It does, however, reside on disk. You can 
view it and other files in the directory from 

’ the desktop’s Files View. 

Print report 
Prints a report about the current file’s records to the 
screen, on paper, or to a file. 

Note: You must have designated a report format, 
using the Form Setup application, before you can 
use this option. 

Unless you have used the Records Menu’s (F4) F i nd 
option to limit the number of records to include, 
Filer prints information about all the records in the 
file. 
The information on the report will appear in the 
order in which the records are sorted in your file. To 
put your records in a particular order, use the Sort 
option on the Records Menu (F4). 

1. 

2. 

Note: Be sure to use the Printer option on the 
Setup Accessory‘s Options Menu to tell DeskMate 
the type of printer you are using. Some report 
layouts cannot be printed if you have specified a 
certain type of printer. Also, be sure to set up 
your page layout using the File Menu’s (F2) Page 
setup option. 
Select Pr in t  report from the File Menu (F2). 
A dialog box appears. 
At the P r i n t  to :  prompt, choose the Screen, 
Printer, or File button. 
The Screen button lets you print the report on 
the screen to see what it will look like on paper. 
The Pri nter button lets you print the report on 
paper. 
The F i  1 e button lets you print the report to 
another file. Printing the report to a file stores the 
file on disk, using the name you give plus the ex- 
tension .prn. You can then use the MS-DOS Print 
command to print the file from another computer 
that is not running DeskMate. Or, you might send 
the file to another computer, using the Telecom 
application. 

Note: The printer used to print the file 
from MS-DOS must be the same type as 
the one you are using with DeskMate 
(the one you assigned with the Printer 
option on the Setup Accessory‘s Options 
Menu). If you want to transmit the file 
using DeskMate’s Telecom application, 
choose A S C I  I as the printer type. 

3. Follow the appropriate directions below for the 
button you chose in Step 2. 

If you chose the Screen button: 
a. Select OK to complete the task. 

The report appears on the screen. You can 
scroll through it or use the Next page op- 
tion on the Options Menu (F2) to View the 
next page. 

b. When you finish viewing the report on the 
screen, select Exi t from the Options Menu 
(F2) * 

If you chose the Printer button: 
Select OK to begin printing. 
The report begins to print, and a dialog box 
appears, containing information about the 
print operation. You can select C A N C E L  at 
any time to stop the operation. 

Note: If you chose the Pause between 
pages option when you formatted the 
page layout, the printer stops to let you 
change sheets of paper when each page 
finishes printing. A dialog box appears, 
asking whether you want to reprint the 
current page. 
To print the next page, insert a new 
sheet of paper, and select NO. If you 
want to reprint the same page, insert a 
new sheet of paper and select YES. 
Select CANCEL to stop the print opera- 
tion. 
When you finish printing, select NO at 
the Reprint current page? prompt. 

At the F i  lename: prompt, type the name 
you want to give the “printed” file, using 
eight or fewer characters. 

If you chose the F i  1 e button: 
a. 

Note: Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or a different directory. Filer 
automatically assigns the extension 
.prn, unless otherwise specified. 
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b. Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .pm file (if you used 
that extension) listed in any application list 
box. It does, however, reside on disk. You 
can view it and other files in the directory 
from the desktop’s Files View. 

sxft 
Exits Filer and returns to the desktop. 

The desktop screen appears. 

Select Ex i t  from the File Menu (F2). 

Run 
Lets you run another DeskMate application file or 
another software package without returning to the 
desktop. 

1. Select Run from the File Menu (F2). 
A dialog box appears on the screen. 

2. At the Program: prompt, type the name of the 
application you want to run. If the program is 
not a DeskMate application (does not have the 
extension .pdm), include the extension when 
you type the name. Also, if the file is in a direc- 
tory other than the current directory, type a full 
pathname including the drive and directory. 

3. At the Data f i 1 e : prompt, either type the name 
of the file you want to use with the chosen ap- 
plication (or program) or leave the prompt 
blank. 
If you leave the prompt blank, DeskMate runs the 
application or program without opening a cor- 
responding data file. 

4. Select OK to complete the task. 
DeskMate might ask you to insert the diskette con- 
taining the application or software program you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the file desktop.pdm. After you insert the 
diskette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run the program. 

1. Select About from the File Menu (P2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Edit Menu 
The Edit Menu (F3) options make it easy for you to 
edit your Filer information. For example, you can 
move information around, duplicate it without rem- 
ing, or remove unwanted information. 

Copy Ctrltlns 
l’wt,e i i f l i l n s  

cut 
Cuts (or removes) highlighted Filer information, and 
places it on the Clipboard. 

Note: You cannot move information that is part 
of the record layout (such as field names), only in- 
formation you have typed in a field. 

1. Highlight the information you want to move. 

For more specijk instructions on highlighting Filer in- 
formation, see “Highlight Information for Editing” in 
the “Other Filer Information section 

2. Select C u t  from the Edit Menu (F3). 
DeskMate removes the highlighted information and 
places it on the Clipboard. 
To place the Clipboard information into another file, 
the current file, or another application, use the Edit 
Menu’s (F3) Paste option. 

Note: You cannot move Filer information to the 
Draw application. 

COPY 
Copies highlighted information to the C l i p M .  

Note: You cannot copy information that is part 
of the record layout (such as field names), only in- 
formation you have typed in a field. 
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1. Highlight the information you want to copy. 

For more specific instructions on highlighting Filer in- 
formation, see “Highlight Information for Editing” in 
the “Other Filer Information ” section. 

2. Select Copy from the Edit Menu (F3). 

DeskMate copies the highlighted information to 
the Clipboard. 
To place the copied information into another file, 
the current file, or another application, use the 
Edit Menu’s (F3) Paste option. 

Note: You cannot copy Filer information to 
the Draw application. 

Paste 
Inserts cut or copied Filer information (Clipboard 
information) at the cursor location. 
1. Move the cursor to where you want the infor- 

2. Select Paste from the Edit Menu (F3). 
mation to appear. 

DeskMate inserts the Clipboard information at the 
cursor location. 

Clear 
Deletes highlighted Filer information. 

Note: You cannot use the C1 ear option to delete 
information that is part of the form, only informa- 
tion you have typed in a field. See the “Form 
Setup” chapter for details on deleting part of the 
form. 

1. Highlight the information you want to delete. 

For more spec@c instructions on highlighting Filer in- 
formation, see “Highlight Information for Editing” in 
the “Other Filer Information” section. 

2. Select Clear from the Edit Menu (F3). 
The information you highlighted disappears from 
the screen and is no longer part of the record. 

Records Menu 
The Records Menu (F4) options let you work with 
your Filer records. For example, you can add, delete, 
or copy a record or display specific records that are 
already stored in the Filer application. 

Find. I I 
Sort.. . 

Add 
Adds a record to the current file. 

A blank record appears. 

field on the record. Press TAB and 
SHIFT+ TAB to move forward and backward 
from field to field. 

1. Select Add from the Records Menu (F4). 

2. Type the information needed to complete each 

When you finish entering information in one record, 
use the Add option again to continue adding records. 
Or, select another Filer option (other than an Edit 
Menu (F3) option). Records you add are immedi- 
ately stored on disk when you display another blank 
record or use another option. 

Delete 
Deletes a record. 
1. Display the record you want to delete. 
2. Select Delete from the Records Menu (F4). 

A dialog box appears, asking whether you want 
to delete the record. 

3. Select O K  to complete the task. 
Filer deletes the record from the screen and from the 
disk, and the next record in the file appears. 
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COPY 
Copies a record. This option is handy if you want to 
add a record whose information will vary only slight. 
ly from the information in an existing record. 
1. Display the record you want to copy. 
2. Select Copy from the Records Menu (F4). 

The original record stays on the screen, but is 
duplicated in the file. 

To display and change the information on the copied 
record, use the Next option on the Records Menu 
(F4) - 
First 
Displays the first record in the current file. 

Next  
Displays the next record in the current file. 

Select F i  r s  t from the Records Menu (F4). 

Select Next from the Records Menu (F4). 

Previous 
Displays the previous record in the current file. 

L a s t  
Displays the last record in the current file. 

Find 
Searches for specific records to display, change, or 
include in a report. 
You can limit the number of records by establishing 
standards that the records must meet in order to be 
included in the group. For example, suppose you 
have a recipe file in which you want to find all the 
Mexican entrees that have from 250 to 350 calories 
per serving. Assume the file has the same layout as 
the file invntory.fil and you are using: 

The Labe l  field for the food category 
F i  el d 1 for the national origin 
F i  e l  d 2 for the recipe name 
F i  el d 3 for the calorie count 
The Comments field for the recipe 

Select Previous from the Records Menu (F4). 

Select Las t  from the Records Menu (F4). 

To find those Mexican recipes, you need to tell Filer 
to find all the records where the information item in: 

The Label field is equal to Entrees 
F i  e l  d 1 is equal to Mexican 
F i e l d  3 is from 250 to 350 
Note:  Label, F i e l d  1, F i e l d  2, F i e l d  3, and 
Comments are generic field names used in the file 
invntory.fi1. If you created your recipe file using 
the Form Setup application, you might have as- 
signed specified field names such as Category, Na- 
tional Origin, Recipe Name, Calories, and Recipe. 

A dialog box containing several elements appears 
on the screen. You can use all these elements to 
set the search criteria. The first element, the 
F i  e l  ds list box, lists all the field labels in the file. 

2. In the F i  e l  ds list box, highlight the f i r s t  field 
you want to use to limit the search (Label in 
the above example). 
Notice that the field name you highlighted ap- 
pears after the F ind  records  where: prompt at 
the bottom of the box. Each time you add a 
search element, it appears here. 

3. Choose the Opera tors :  button that lets you 
define the relationship between the field and 
the value you will add (equal to in the above ex- 
ample). 

1. Select F i  nd from the Records Menu (F4). 

Note:  When you work with alphabetic 
characters, the Opera tors :  buttons 
mean “alphabetically equal to,” “al- 
phabetically less than or equal to,” “al- 
phabetically greater than or equal to,” 
and so on, using alphabetic order. 

4. In the Va 1 ue: field, type the value (up to 20 
characters) against which you want the informa- 
tion in the selected field to be judged (Entrees 
in the above example). 

Note:  If you choose the From.. . t o .  . . 
button, you need to type both the start- 
ing and ending values for the range. 
Type the smaller value. Then, press , 

TAB to move to the final field to type 
the larger value. 

For more information on fyping values in the F i  nd  
Records dialog box, see “Wildcard Characters”in the 
“Other Filer Information” section at the end of this 
chapter. 
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5. To establish each additional criterion, press 
SHIFT+TAB twice to return to the Fi  el ds list 
box so that you can repeat Steps 2-4. (You can 
have up to five criteria.) 

select OK to complete the task. 
6. After establishing the criteria for the records, 

Note:  Selecting C L E A R  erases all the 
criteria so that ou can begin again. 
Selecting a fieldrname and then the 
None button erases a single criterion. 
Selecting CANCEL terminates the Find op- 
tion, restoring all previous search 
criteria. 

Filer immediately limits the displayed records to 
those that meet the standards you set. The search 
criteria remain in effect until you change them or 
exit the file. 

sort 
Lets you display or print records in a particular 
order. You can establish the order by choosing the 
field(s) on which Filer is to base the sort and, if you 
choose more than one, by indicating their relative 
priority. For example, if you have a recipe file, you 
might want to display the recipes in order of 
category, national Origin, and recipe name. Setting 
up your sort order like this would display all dessert 
recipes before all entrees, all Italian entrees before 
all Mexican entrees, and a recipe for enchiladas 
before a recipe for fajitas. Within each sort level, 
Filer automatically sorts according to alphabetic or 
numeric order. 

Note:  If you do not have a sort order, Filer sorts 
entries from oldest to newest. Therefore, each 
time you add or change a record, that record goes 
to the end of the file. 

1. Select Sort from the Records Menu (F4). 
A dialog box appears on the screen to let you as- 
sign sorting priorities to the various fields in your 
record. The Fields list box contains a list of all 
field names in the file. 

Note:  Invntory.fil uses the generic field 
names Label, Field 1, Field 2, Field 3, 
and Comments. If ou created your 
recipe file using tKe Form Setup applica- 
tion, you might have assigned specific 
field names such as Category, National 
Origin, Recipe Name, Calories, and 
Recipe. 

2. Highlight the field to which you want to assign 
the highest priority. 

3. 

4. 

5. 

Select the Add t o  Sort button at the bottom of 
the dialog box, or press ALT+A. 
The cursor returns to the Fi  el ds list box. 
Repeat Steps 2 and 3 to assign the second, 
third, fourth, and fifth priorities to other fields 
as needed. 
When you finish assigning priorities, select OK to 
complete the task. 

Note:  Selecting C L E A R  erases all 
priorities so that you can begin again. 
Selecting C L E A R  and then leaving the 
priorities blank displays the records in 
the default order (the order in which 
they were added or modified). Selecting 
C A N C E L  terminates the Sort  option, res- 
toring any previous Sort priorities. 

Count 
Displays the number of records selected for display- 
ing or printing, as well as the total number of 
records in the file. 
1. Select Count from the Records Menu (F4). 

The total number of records selected to display or 
print and the total number of records in the file 
appear on the screen. 

screen. 
2. Select OK to remove the message from the 

See the F i  nd option for information on limiting the 
number of records to be displayed. 

Filer Tasks 
This section lets you look up Filer application tasks. 
The tasks are listed alphabetically, and the name of 
the menu and the option(s) needed to perform the 
task are listed below the task. If you don’t know how 
to use the option(s), see the “Menu Options” section 
for detailed information and step-by-step instruc- 
tions. 
Add a Record 

Alphabetize Records 

Copy a Layout 

Records F4 (Add) 

Records F4 (Sort) 

File F2 (Copy 1 ayou t s) 
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Copy a Record 
Records F4 (Copy) 
Records F4 (Next) 

Count Records in a File 
Records F4 (Co u n t) 

Delete a Record 
Records F4 (De 1 e t  e) 

Delete Information from a Field 
Edit F3 (C1 ear) 

Display a ProgranVApplication Name and Version 
Number 

Display a Record 

Duplicate Information in Another Application 

File F2 (About) 

RecordsF4 (First, Next, Previous, or Last) 

Edit F3 (Copy) 
File F2 (Run) 
Edit F3 (Paste) 

Edit F3 (Copy) 
File F2 (Open) 
Edit F3 (Paste) 

Edit F3 (Copy) 
RecordsF4 (First, Next, Previous, or Last) 
Edit F3 (Paste) 

Exit Filer 
File F2 (Exi t )  

Find a Group of Records 
Records F4 ( F i n d )  

Format a Page Layout for a Report 
File F2 (Page setup) 

Move Information to Another Application 
Edit F3 (Cut) 
File F2 (Run) 
Edit F3 (Paste) 

Edit F3 (Cut) 
File F2 (Open) 
Edit F3 (Paste) 

Edit F3 (Cut) 
RecordsF4 (First, Next, Previous, or Last) 
Edit F3 (Paste) 

File F2 (Open) 

File F2 (Open) 

Duplicate Information in Another File 

Duplicate Information Within the Same File 

Move Information to Another File 

Move Information Within the Same File 

Open an Existing File from Within Filer 

Open an Existing File in Another Drive or Directory 

Print a Report 

Print One or All Records 

Run Another Application 

Sort Records 

Switch to Form Setup from Filer 

File F2 (Print record) 

File F2 (Run) 

Records F4 (Sort) 

File F2 (Form setup) 

Other Filer 
Information 
Correct an Error 
If you make an error as you are typing information 
in a field, you can press either BACKSPACE or 
DELETE to make corrections. Pressing BACK- 
SPACE erases the character immediately to the left 
of the cursor. Pressing DELETE erases the character 
to the right of the cursor. 
You can also use the Edit Menu’s (F3) C 1  ear option 
to erase information in a field. 

Create a New File 
To create a new file, you can either copy layout in- 
formation from an existing file or use the Form 
Setup application to design your own layout. Then, 
you can open the new file and begin typing informa- 
tion in it. See the File Menu’s (F2) Copy layouts op- 
tion and the “Form Setup” chapter for detailed 
information on modifying and creating layouts. 

File F2 (Pr in t  report) 
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Create a New Record or 
Report Layout 
To create a new file layout instead of using an exist- 
ing layout, you can do one of the following: 

Copy an existing layout (using Filer’s Copy 
1 ayout option on the File Menu (F2)) and then 
modify it (using the Form Setup application) 
Use the Form Setup application to design a new 
file layout 

Details are in the “Form Setup” chapter. 

Design a Record or 
Report Layout 
To design a “custom” layout instead of copying an 
existing layout, you need to use the Form Setup ap- 
plication. To enter Form Setup from Filer without 
returning to the desktop, select Form setup from the 
File Menu (P2). See the “Form Setup” chapter for 
detailed information. 

Highlight Information for 
Editing 
When you move the cursor to any field in a record, 
Filer automatically highlights all the information in 
the field. You can then type over the information or 
use an Edit Menu (F3) option. 
YOU can also reverse highlight any part of the infor- 
mation for typing over or editing. To do this, use the 
arrow keys to move to the first character you want 
to change. Then, press SHIFT+ - or SHIFT+ - to 
reverse highlight as much as you want. Or, with the 
mouse, move the cursor to the first character you 
want to change and then drag the mouse to reverse 
highlight. 
To unhighlight a field, press -c or e. 

Layouts 
Filer includes two sample files, invntory.fil and car- 
maint.fi1 (listed in the FI  LER list box if you display 
the box on the desktop). You can copy one of these 
layouts to create other files, or you can use the Form 
Setup application to create files with custom 
layouts. After you create new files, their names also 
appear in the F I L E R  list box. For more information, 
see the File Menu’s (F2) Copy 1 ayouts and Open op- 
tions, as well as the “Form Setup” chapter. 

Store a Completed Record 
Records you add or change are immediately stored 
on disk when you display another blank record 
using the Records Menu’s (F4) Add option or use 
another Filer option (other than an Edit Menu (P3) 
option), 

Wildcard Characters 
When using the Records Menu’s (F4) Fi  nd option to 
search for a particular group of records, you can in- 
clude wildcard characters (* and ?) in your search 
value. A wildcard broadens the search because it 
symbolizes a space that can be filled in by any char- 
acter. 
The ? wildcard tells Filer that you do not care what 
the character at the ? position is. For example, 
typing O’Nell finds bothO’Nea1 andO’Nei1. 
The * wildcard tells Filer that any character at  the * 
position and all subsequent characters can be con- 
sidered a match. For example, typing 0 ’  N* finds all 
words that begin with O’N including 0 ’ Nead, 0 ‘ Neal, 
and 0 ’  Nei 1 .  
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Overview 
What Is I t?  
If you are using the Filer application to keep records such as inventories, 
automobile expenses, or medical records, you might want to create custom- 
made record layouts or designs. With Form Setup, you can control every 
aspect of your file layouts - for example, the size of the fields and their 
location on the screen. 

What Can I Do with I t?  
The Form Setup application contains many practical features that make it 
easy for you to design your Filer layouts. In addition to specifying what kind 
of information you’re going to type and where, with Form Setup you can: 

Print your record or report layouts so that you can “pencil in” information 
while you are away from your computer, and then store the information in 
the Filer application later 
Design report layouts to print information that is already stored in the Filer 
application 
Use the Draw application to add pictures or graphics to your record or 
report layouts 

How Do I Use It? 
When you open the Form Setup application, the following dialog box ap- 
pears: 

Uould you l i k e  t o  create a neu f i l e ?  

Select YES, type a filename for the new file, and select OK. Form Setup opens 
the new file and displays a blank work area. This is the record layout screen 
on which you will create the file’s record layout. When you open a file in 
Form Setup, the Record Menu’s (F4) Def i ne option is already selected so 
that you can immediately begin creating or modifying the layout. 
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Herc is a sample layout that you might want to use in Filer. 

For this Filer record, you would create the following layout: 

Cosmetic Text 
Character Set \ Format Character 

\ I  

\ Field Labels SiAgle-Une Fields 
Multi-Line Field with Outline 

Creathg a record layout can be as simple as using one option. For example, 
you can use the Field Menu’s (F6) Add option if you only want fields and 
labels. It all depends on what you want to include on the layout. If you want 
to include graphics and cosmetic text, Form Setup has several other easy-to- 
use options from which to choose. 
Position the cursor where you want a field, and then select Add from the 
Field Menu (F6). Use the arrow keys to insert character slots, and press 
ENTER when finished. A dialog box appears and you can specify the infor- 
mation about the fields. Select OK when you finish entering the information 
and repeat the procedure for any fields you want to include on the record. 
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When changing a record layout (or report layout) in Form Setup, you high- 
light information (fields, blocks of text, or pieces of art) differently than you 
do in most other DeskMate applications. With the keyboard, position the cur- 
sor anywhere on the item and press the space bar. Or, with a mouse, point 
to the item and click the mouse button. Note that you cannot highlight in- 
dividual characters. 
After you create the record layout, you can immediately go into the Filer ap- 
plication (using the File Menu’s (F2) F i  1 er option) and begin typing infor- 
mation in your records. Or, you can create an Optional report layout that lets 
you print a file report. The main advantages of a report are: 

Gives you a paper copy of your record information. 
It contains only the information from the fields you specify. 
It can include a summary that can perform a simple calculation 
based on the selected information. 

To switch from the record layout screen to the report layout screen, select 
Def i ne from the Report Menu (F5). To switch back to the record layout, 
select Def i ne from the Record Menu (F4) again. 
Suppose you had created the Charitable Contributions file shown earlier, 
and you wanted to print a report that looked like the report shown below. 
To format your information, you would create the following report layout: 

Selected Fields from Records Date Code 
Cosmetic Text \ (Title and Hepdinh) 

Page ‘Ode Fild Labels 
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Notice that, in creating the report layout, you place information in the dif- 
ferent screen sections according to where you want the information to ap- 
pear on the report. 

For helpful hits on creating a report layout, see the Define option in 
“Report Menu.” 

Header- top of each page 
Body- body of the report; includes the fields you specify 
Summary(optiona1) - end of the report 
Footer - bottom of each page 

Note: You can use Form Setup to change the record or report layout of 
an open file at any time. Be careful, however, about changing the layouts 
of files whose records already contain information. You automatically lose 
the information in any field that you delete, and you might truncate items 
in fields you resize. 

To learn the basics about using Form Setup, see the “Form Setup” article in 
the Getting Started magazine. Then, when you’re familiar with Form Setup, 
this chapter will provide you with a quick way to answer specific questions. 
You can look up the step-by-step instructions for each menu option. If you 
want to know which options to use to perform a specific task, check the 
“Form Setup Tasks” section at the end of this chapter. 
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Menu Options 
Form Setup has six menus that list the options you 
can use with the application. The key that you press 
to see each menu appears beside the menu name. 
(For example, press the F2 key to see the File 
Menu.) A shaded option on a menu means that the 
option is not available. Some options have ac- 
celerator keys listed next to them. Use these keys to 
perform tasks without pulling down a menu. For ex- 
ample, to delete highlighted information, press 
DELETE to select the C1 ear option on the Edit 
Menu (F3). 
This section explains each Form Setup menu on the 
menu bar and also contains step-by-step instructions 
on how to use each option. 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can create new 
files, open or print an existing file, or run another 
program or DeskMate application. 

Open.. . 
Copy layouts.. . 
Page setup.. . 
Filer 
hid.. . 
Run.. . 
Akaut... 

Esc 

NeW 
Creates a new file without returning to the desktop. 
1. 

2. 

Select New from the File Menu (F2). 
A dialog box appears so that you can name the 
new file. 
Type a name for the new file, using eight or 
fewer characters. If you do not include a 
filename extension, Form Setup automatically 
adds the extension .fil. 

Note: Be sure to type a complete pathname of up 
to 64 characters if you want to save the file in a 
different drive or in a different directory. 

3. Select O K  to complete the task. 
Form Setup opens the new file and you can define 
the setup. 

Open 
Opens an existing file from within Form Setup or 
another drive or directory. 
1. 

2. 

3. 

4. 

Select Open from the File Menu (F2). 
A dialog box appears, listing all the files you can 
open in the current directory. In addition, the box 
lists all available subdirectories and drives. (The 
symbol [..I indicates the parent directory.) 
Highlight the file you want to open or the ap- 
propriate drive or directory. 
Select OK. 
If you highlighted a file, the record layout you re- 
quested appears, and you can define the layout, if 
necessary. 
If you highlighted a drive or directory, its files 
and directories appear in the list box. Other avail- 
able drives appear in the list as well. Continue 
with Steps 4-6. 
Repeat Steps 2 and 3 until the box displays the 
name of the file you want to open. 

5. Highlight the file you want to open. 
6. Select OK to complete the task. 

The record layout for the file you requested appears, 
and you can define the layout. 

Note: When you open a file from a different 
drive or directory, subsequent “open” operations 
will display a list of files, drives, and directories 
from the directory in which the opened file 
resides. However, when you exit Form Setup, the 
desktop displays a list of files from the directory 
you were in when you accessed the Form Setup 
application. 

copy layouts 
Copies the current file’s layouts and saves them 
under a different name. 

Note: You cannot copy layouts to another disk- 
ette in the same drive. 
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1. Select Copy layouts from the File Menu (F2). 
A dialog box appears so that you can specify a 
name to give the copy of the file whose layouts 

2. At the Copy to: prompt, type a filename for the 
neyv file, using eight or fewer characters. If you 
do not include a filename extension, Form 
Setup automatically adds the extension .fil. 

Note: Be sure to type a complete path- 
name of up to 64 characters if you want 
to save the layouts on a different drive 
or a different directory. 

you are copying. 

3. Select OK to complete the task. 
The file you were using remains on the screen. 

Page setup 
Lets you design the page layout you want to use to 
print reports. 

Note: The page layout for records is predefined, 
using the “portrait” format. You cannot change 
this layout. 

1. Select Oefi ne from the Report Menu (F5). 

2. Select Page setup from the File Menu (F2). 
A dialog box appears. Some of the options might 
not be available, depending on the type of printer 
you are using. Additional information about each 
option appears after the steps. 

3. Change the desired options. 
4. Select OK to complete the task. 

Paper Size. Choose the size paper you are using. If 
you choose Other, be sure to indicate the correct 
width and height in the appropriate fields. 
Left margin. Qpe the number of spaces you want 
for the left margin. 
Line width. ’Qpe the total number of characters 
you want to print on one line. 

For example, if you are using 8a-inch paper and a 
ten-characters-per-inch font (such as Courier), the 
total line length is 85 characters. If you set a left 
margin of 1% inches (15 spaces) and you want a 
right margin of 1 inch (ten spaces), subtract the left 
and right margin amounts from the total line length 
(85-25=60). The resulting total of 60 spaces (or 6 
inches) is the printed line width. Be sure the sum of 
the entries for the Left margin and Line width set- 
tings does not exceed the width of your paper. 
Lines per page. Type the total number of lines on 
each sheet of paper. For example, 8l4,- by 11-inch 
paper contains 66 lines in the “portrait” mode when 
figured at six lines per vertical inch. 
Double space. Form Setup does not let you 
change this setting. 
Pause between pages. If you are not using con- 
tinuous form paper, choose this option so that you 
can insert a new sheet of paper after each page 
prints. 
Print sideways. Choose this box to print sideways 
on your paper. When printing in this format, Desk- 
Mate only prints ten characters per inch. 
CENTER. By selecting this button, you can center 
your document on the page both vertically and 
horizontally. Enter the Left margin,  Line width, and 
Li nes per page settings as accurately as you can. 
Then, select the CENTER button, and DeskMate will 
automatically adjust the Line w i d t h  and Lines per 
page settings so that the body of the document is 
centered on the paper (based on your current 
printer selection). 
After you select OK, your report layout returns to the 
screen. Note that a vertical line appears on the 
report to let you see the page width you defined. 
This helps you place the information on the layout 
so that it does not fall outside the margins. 
The page layout settings you chose are stored with 
the file and are used when you print the report from 
the Filer application. You do not need to use the 
Page setup option again in Filer. 
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Fi ler  
Switches from Form Setup to the Filer application so 
that you can add or update records in the file. 

Select F i  1 e r  from the File Menu (F2). 
The file’s first record appears. If your records al- 
ready contain information and you changed the 
record layout in Form Setup, the records now reflect 
those changes. For example, any fields deleted in 
Form Setup are deleted from the records. If you 
print a report, the report also reflects any changes 
made to its layout in Form Setup. For information 
on using Filer, see the “Filer” chapter in this manual. 

Note: If you want to leave Form Setup without 
entering Filer, use the File Menu’s (F2) Exi t or 
Run option. 

Print 
Lets you print a record or report layout to the 
screen, on paper, or to another file. Record layouts 
always print in the “portrait” format with predefined 
page margins. 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu (F2) to tell DeskMate the 
type of printer you are using. Also, be sure to set up 
your page layout (if necessary) using the File Menu’s 
(P2) Page setup option. Remember you must have a 
graphics printer if you want graphics and field out- 

1. Display the record or report layout you want to 
print, using the Def i ne option from the Record 
Menu (F4) or the Report Menu (F5). 

2. Select Print from the File Menu (F2). 
A dialog box appears. 

3. At the Print to: prompt, choose the Screen, 
Printer, or File button. 
The Screen button lets you print a record or 
report layout on the screen. Printing on the 
screen lets you see how your file will look on 
paper. 
The Pri nter button lets you print a record or 
report layout on paper. 

lines to print. 

The Fi 1 e button lets you print a record or report 
layout to another file. Printing to a file stores the 
file on disk, using the name you give plus the ex- 
tension .prn. You can then use the MS-DOS print 
command to print the file from another computer 
that is not running DeskMate. You might send the 
file to another computer, using the Telecom ap- 
plication. 

Note:  The printer used to print the file 
from MS-DOS must be the same type as the 
one you are using with DeskMate (the one 
you assigned with the Printer option on 
the Setup Accessory‘s Options Menu). If 
you want to transmit the file using 
DeskMate’s Telecom application, choose 
ASCI I as the print type. 

4. Follow the appropriate instructions below for 
the button you chose in Step 3. 

If you chose the Screen button: 
a. Select OK to complete the task. 

The record or report layout appears on the 
screen. 

b. When you finish viewing the layout on the 
screen, select Exi  t from the Options Menu 
072). 

Select O K  to begin printing. 
Your layout begins to print, and a dialog 
box appears, containing information about 
the print operation. You can select 
CANCEL at any time to stop the operation. 

If you chose the Printer button: 

Note:  If you chose the Pause between 
pages option when you formatted the 
page layout, the printer stops to let you 
change the paper when the layout page 
finishes printing. A dialog box appears, 
asking whether you want to reprint the 
current page. 
If you want to reprint the layout page, 
insert a new sheet of aper and select 

reprint the layout page. Select CANCEL 
to stop the operahon. 
When you finish printing, select NO at 
the Reprint current page? prompt. 

YES. Select NO if you B o not Want to 
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If you chose the F i  1 e button: 
a. At the F i  lename: prompt, type the name 

you want to give the “printed” file, using 
eight or fewer characters. 

Note: Be sure to type a complete path- 
MITE of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. Form 
Setup automatically assigns the exten- 
sion .prn, unless specified otherwise. 

b. Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .prn file (if you used 
that extension) listed in any application’s 
list box. It does, however, reside on disk. 
You can view it and other files in the direc- 
tory from the desktop’s Files View. 

, 

Exit 
Exits Form Setup and returns to the desktop. 

Select E x i t  from the File Menu (F2). 
The desktop screen appears. 

Run 
Opens another application file or runs another 
software package without returning to the desktop. 

Note: To run the Filer application without return- 
ing to the desktop, use the File Menu’s (F2) 
Fi ler  option. 

1. Select Run from the File Menu (F2). 
A dialog box appears on the screen. 

2. At the Program: prompt, type the name of the 
application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current direc- 
tory, type a full pathname, including the drive 
and directory. 

3. At the Data f i 1 e:  prompt, either type the name 
of the file you want to use with your chosen ap- 
plication (or program) or leave the prompt 
blank. 
If you leave the prompt blank, DeskMate runs the 
application or program you specify without open- 
ing a corresponding data file. 

4. Select OK to complete the task, 

DeskMate might ask you to insert the diskette con- 
taining the application or software package you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish running the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the file desktop.pdm. After you insert the 
diskette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run the program. 
1. Select About from the File Menu (F2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Edit Menu 
The Edit Menu (F3) options make it easy for you to 
edit your Form Setup information. For example, you 
can move information around, duplicate it without 
retyping or remove unwanted information. 
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cut 
Cuts (or removes) any item of information (a field, 
cosmetic text, a picture, or a page or data code) and 
places it on the Clipboard. 
1. Highlight the information you want to move. 

Note: You can highlight one item at a time. 

For more specific instructions on highlighting Form 
Setup information, see “Highlight Information” in 
the “Other Form Setup Information” section. 

2. Select C u t  from the Edit Menu (F3). 
DeskMate removes the highlighted information and 
places it on the Clipboard. 
To place the Clipboard information at another loca- 
tion on the same layout, use the Edit Menu’s (F3) 
Paste option. 

COPY 
Copies a piece of art or cosmetic text to the Clip- 
board. 

Note: Each field can appear only once in a 
layout, so you cannot use Copy to duplicate fields. 

1. Highlight the item you want to copy. 

Clear 
Deletes any item of information (a field, cosmetic 
text, a date or page code, or art) from a record or 
report layout. 
1. Highlight the information you want to delete. 

For more spec@c instructions on highlighting Form 
Setup information, see “Highlight Information” in 
the “Other Form Setup 1nformation”section. 

2. Select Clear from the Edit Menu (P3). 
The information you highlighted disappears from 
the screen and is no longer part of your record or 
report layout. 

Move picture 
Moves a picture to another location on the same 
layout. This option works the same as the Edit 
Menu’s Move option in the Draw application. 

A handle box appears around the art. 
1. Highlight the art to be moved. 

2. Select Move picture from the Edit Menu (P3). 
3. Move the art as you would in the Draw applica- 

tion. 

For more specific instructions on highlighting Form 
Setup information, see “Highlight Information” in 
the “Other Form Setup Information” section. 

2. Select Copy from the Edit Menu (F3). 
DeskMate copies the highlighted information to the 
Clipboard. 
To place the Clipboard information at another loca- 
tion on the same layout, use the Edit Menu’s (F3) 
Paste option. 

Paste 
Inserts cut or copied Form Setup information (Clip- 
board information) at the cursor location. 
1. Move the cursor to where you want the informa- 

2. Select Paste from the Edit Menu (F3). 
tion to appear. 

DeskMate inserts the Clipboard information at the 
cursor location. 

Siae picture 
Resizes a picture. This option works the same as the 
Res i ze option on the Draw application’s Edit Menu. 
1. Highlight the art you want to resize. 

A handle box appears around the art. 
2. Select Size picture from the Edit Menu (F3). 
3. Resize the box as you would in the Draw ap- 

plication. 
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Record Menu 
The Record Menu (€74) options let you define record 
layouts and sort records. 

Define 
Lets you create a layout for records in which you 
will later store information using the Filer applica- 
tion. A sample layout appears in “How Do I Use It?” 
in the “Overview” section. 

Select Define from the Record Menu (F4). 
It is a good idea to design the record layout on 
paper before mating it. Here are some things to 
keep in mind: 

You have 79 character spaces and 19 lines to 
work with on the screen. 
You can make your records look sharper by 
having all the fields (not the field names) start 
at the same column position, on different lines. 
You can have multiple-line text fields because 
Form Setup lets you add character slots by rows 
as well as by columns. Example: 

Comments: 

You cannot have multiple-line numeric fields. 
(See the Field Menu’s (F6) Add option.) 
Each field name can appear above the field, to 
the left of the field, or not at all (hidden). 
The Filer application’s F i  nd option on the 
Records Menu (F4) can search for a maximum 
of 20 characters. Therefore, if you think you 
will ever search for the information in a par- 
thlar field, you might want to size that field ac- 
cordingly. 

A field name that appears above a field can only 
be as long as the field itself, so you might want 
to size the field accordingly. 
If you plan to include format characters in a 

field, you must count them when calculat- 
ing the field length. (See “Format Charac- 
ters” in the “Other Form Setup Informa- 
tion” section at the end of this chapter for 
more information.) 

You must have a graphics printer if you want 
graphics and field outlines to print. 
Outlining increases the size of the field, reduc- 
ing the space available for other layout items. 

After designing the layout on paper, you might use 
several tasks to create it on the screen. The follow- 
ing list provides a guide to these tasks: 

Adding Graphics - It is a good idea to position 
graphics so that you can arrange your fields 
around them. See “Place Graphics on a Layout” 
in the “Other Form Setup Information” section 
for information on copying graphics from the 
Draw application to Form Setup. 
Adding Fields - The Field Menu’s (F6) Add op- 
tion lets you select each field’s location, size, 
name, label position, outlining, and data type. 
Adding Cosmetic Text - See “Add Cosmetic 
Text” in the“0ther Form Setup Information” sec- 
tion. 
Editing the Layout - See the Edit Menu (F3) 
options. 

After you create your record layout, you can select 
the File Menu’s (F2) F i  1 er  option to immediately 
enter Filer and begin typing information into your 
file’s records. Or, you can design a report layout to 
work in conjunction with the record layout. (See the 
Report Menu’s (F5) Def i ne option.) You can a h  
specify the order in which you want records dis- 
played. (See the Sort  option.) 
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sort 
Lets you establish the order in which you want 
records to appear, in the Filer application, when you 
add information in them. (Filer also lets you set up a 
sorting order. Setting up the order in Form Setup 
simply assures that the records will be sorted imme- 
diately when you start adding them using the Filer 
application.) 
You set the order by choosing the field(s) on which 
Filer is to base the sort and, if you choose more than 
one, by indicating their relative priority. For in- 
stance, if you have a recipe file, you might want to 
display the recipes in order of category, nation- 
al origin, and recipe name. Setting up your sort 
order like this would display all dessert recipes 
before all entrees, all Italian entrees before all 
Mexican entrees, and a recipe for enchiladas 
before a recipe for fajitas. Within each sort 
level, Filer automatically sorts according to al- 
phabetic or numeric order. 

Note: If you do not have a sort order, Filer 
sorts entries from oldest to newest. There- 
fore, each time you add or change a record, 
that record goes to the end of the file. 

1. Select Sort from the Record Menu (F4).  

A dialog box appears on the screen to let you as- 
sign sorting priorities to the various fields in your 
record layout. The F ie lds  list box contains a list 
of all the field names in your file. 

Note:  Invntory.fi1 uses the generic field 
names Label,  F i e l d  1, F i e l d  2 ,  F i e l d  3, 
and Comments . If you created your 
recipe file using Form Setup, you might 
have assigned specific field names such 
as Category, National Origin, Recipe 
Name, Calories, and Recipe. 

2. Highlight the field to which you wish to assign 
the highest priority. 

3. Select the Add t o  S o r t  button at the bottom of 
the dialog box, or press ALT+A. 
The field is added to the sort order, and the cur- 
sor returns to the F i e l d s  list box. 

third, fourth, and fifth priorities to the other 
fields as needed. 

5. When you finish assigning priorities, select OK to 
complete the task. 

4. Repeat Steps 2 and 3 to assign the second, 

Note:  Selecting CLEAR erases all priorities so that 
you can begin again. Selecting CLEAR and then 
leaving the priorities blank displays the records in 
the order in which they were added or modified. 
Selecting CANCEL terminates the Sort option, re- 
storing any previous priorities. 

Report Menu 
The Report Menu (F5) options let you work with 
your report layout. For example, you can define a 
layout, insert today’s date or page numbers, or 
resize a section of the layout. 

’ Resize section 
~ Clear a l l  I 

Define 
Lets you create a report layout after you create a 
record layout. Also displays a previously created 
report layout. 
The report layout lets you select the fields whose in- 
formation will appear on the file report. This layout 
is optional, but without it, you cannot print a file 
report. A sample report layout appears in “How Do I 
Use It?” in the “Overview” section. 

Note:  Because the report layout works with exist- 
ing fields, you must create the record layout 
before the report layout. 
Select Def i ne from the Report Menu (PS). 

The report layout screen appears. It  consists of 
header, body, summary, and footer sections. Each 
section appears above its title bar, and the title bar 
becomes unhighlighted when you move the cursor 
into that section. The vertical line on the right side 
of the screen indicates where the right margin 
be. 
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You place information in the sections, according to 
where you want it to appear in the printed report: 

HEADER - Any information that you want to ap- 
pear at the top of each page of the report, in- 
cluding: cosmetic text (such as titles and 
column headings to go above the fields), 
graphics (from Draw), a date code (to make the 
current date appear), and a page code (to 
generate page numbers). 
BODY - The fields whose information you want 
included in the body of the report. Also, cos- 
metic text and graphics. 
SUMMARY - Summary information to appear 
once, at the end of the report (optional) and 
also cosmetic text. 
FOOTER - Any information that you want to ap- 
pear at the bottom of each report page, includ- 
ing: cosmetic text, graphics, a date code, and a 
page code. 

Note: The date and age codes can ap- 
pear only once on a P ayout. 

It is a good idea to design the report on paper before 
creating it with Form Setup. Here are some things to 
keep in mind: 

Because you usually print reports, you need to 
decide how wide you want the report to be, and 
set your page margins accordingly. Use the File 
Menu’s (F2) Page setup option to do this. Form 
Setup lets you create report layouts of up to 132 
columns in width. Page setup also lets you 
decide the top and bottom margins, which deter- 
mine the number of records that will fit on one 
page of the report. 
A summary field can perform a simple calcula- 
tion based on a selected field. 
You can resize sections to make more room 
where needed, using the Res i ze sect i on option 
on the Report Menu (F5). 
You can use the Report Menu’s (F5) Show page 
option to see how the report might look. 
Because the size of the fields is already set (by 
the record format), you should position the 
fields in the body before you position the 
column headings in the header. In this way, you 
can ensure that the headings will align with the 
information below them. 

The following list provides a guide to the options 
and tasks you can use to create the report layout on 
the screen: 

The Field Menu’s (F6) Add option adds a field 
on the report layout. 
Add cosmetic text and graphics. See “Add Cos- 
metic Text” and “Place Graphics on a Layout” in 
the “Other Form Setup Information” section. 
Add page numbers and the date on a report 
layout using the Report Menu’s (F5) Page num- 
ber and Today’s date options. 
Add a summary field using the Report Menu’s 
(F5) Summary option. 
The Edit Menu (F3) options let you edit a 
report layout. 

When you finish creating the report layout, use the 
File Menu’s (F2) F i  1 er option and begin typing in- 
formation in your records. Otherwise, select E x i t  or 
Run from the File Menu (F2). 

Show page 
Shows you the effects of any fields you add or chan- 
ges you make to a report layout. In addition, you 
can see a template of the report that reflects the 
page margins and parameters you’ve set using the 
File Menu’s (F2) Page setup option. 
Anywhere that you have added a field to the layout, 
you see rectangles representing the actual infonna- 
tion that would print on the report if your records 
contained data. The body section displays as many 
lines of rectangles as it can, given your Page setup 
parameters. 
1. Select Show page from the Report Menu (F5). 

The template appears on the screen. 
2. When you finish reviewing the template, select 

OK to return to the previously displayed screen. 

Today’s date 
Places a date code on a report layout that will show 
the current date when the report is printed. You can 
place the date code in the header or footer section of 
the layout. When you print a report using this 
layout, the date will appear on each page of the 
report, at the location you specify. You can use a 
date only once on a report layout. 
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1. Move the cursor to the place in either the 
header or footer section where you want to 
place the date. 

2. Select Today’s date from the Report Menu (E’S). 

MMM DD, Y Y Y Y  appears, showing you where the date 
will appear when you print the report. 

Page number 
Places a page code in the header or footer section of 
a report layout. When you print a report using this 
layout, the page number will appear on each page of 
the report, at the location you specify. You can use 
the Page number option only once on a report layout. 
1. Move the cursor to the location in either the 

header or footer section where you want to 
place the page number. 

2. Select Page number from the Report Menu (F5).  

The ### code appears on the layout, showing 
where the page numbers will appear when you print 
the report. 

Summary 
Adds a summary field to a report layout. A summary 
field displays summary information about all the 
records in the report. For example, suppose your 
record layout contained a field called Units Bought 
by Customer. You could create a summary field to 
report the total number of units purchased (based 
on all the records that appear on the report), the 
average number of units purchased, or simply a 
count of the records that had any number entered in 
the Units Bought by Customer field. 

1. 

2. 

Note: You can have more than one summary 
field in a report. 
In the layout‘s summary section, move the cur- 
sor to where you want the summary field to ap- 
pear. 

Note:  The title bar of the section you 
are in is unhighlighted. 

Select Summary from the Report Menu (F5). 
A dialog box appears, containing several at- 
tributes that you can set to define the summary 
field. 

3. In the Fi elds list box, highlight the field on 
which you want to base the summary. 

Note: If the highlighted field is a text 
field, the t o t a l  and avg buttons that fol- 
low the Data type: prompt become 
shadowed. The t o t a l  and avg options 
are available only for numeric fields. 

4. At the Name: prompt, type a name you want to 
give the summary field, using 20 characters or 
fewer. 

5. At the Ou t l  i ned: prompt, choose either yes or 
no to indicate whether you want the field to ap- 
pear with or without a “box” outline. 

Note: Outlining a field makes it take 
up more space. Also, you must have a 
graphics printer to print outlines. 

6. At the Data type: prompt, choose t o t a l ,  avg, or 
count to specify the type of summary informa- 
tion you want (a total or average of information 
in a numeric field or a count of the number of 
records appearing in the report). 

7. At the Label : prompt, choose lef t ,  top,  or hid- 
den to indicate the location of the field name. 

8. Select O K  to complete the task. 
The screen shows the summary field in the location 
you chose. The summary field is five characters long 
if you chose to see a count. If you chose to make the 
field a total or an average, the summary field is the 
same length as the field whose information it is total- 
ing or averaging. 
You can resize a summary field or change its at- 
tributes, using the Size, Format, and Change Options 
on the Field Menu (P6). 

Resbe section 
Resizes any report layout section. Shrinking a See- 
tion gives you more room in other sections. 
1. Move the cursor anywhere in the section you 

want to resize. 
2. Select Resize section from the Report Menu 

(E’S). 
The cursor moves to the title bar of the section 
you are resizing. 
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3. Resize the section. 
If you are using the keyboard, press 5. to add 
lines (or t to delete lines), one at  a time. Then, 
press ENTER to finish the procedure. 
If you are using a mouse, point to the flashing cur- 
sor on the title bar of the section. Then, hold 
down the mouse button and drag the cursor 
down to add lines (or up to delete lines). Release 
the button to finish the procedure. 

Note:  Enlarging a section does not af- 
fect the size of the other sections as 
long as unused space appears below the 
footer section. When all the space is 
used, continuing to enlarge a section 
shrinks the section immediately 
beneath it. 

The section now occupies the size you specified on 
the layout. 

Clem all  
Clears the screen when you are setting up a report 
layout. Be sure that the report layout you want to 
cancel is on the screen before you begin this proce- 
dure. 
1. 

2. 

Select Clear a1 1 from the Report Menu (F5). 
A dialog box appears, containing the message 
Clear all  fields from report? 
Select OK to return the report layout screen to 
its original default state so that you can set up 
the report layout again. 

Field Menu 
The Field Menu (P6) options let you add or change 
a field on a layout, change the size of a field, and 
add format characters. 

Add 
Creates a new field on a record layout, or indicates 
that you want information from a certain field to ap- 
pear on the file’s report. 
T o  add a f ie ld to a record layout: 
1. 
2. 

3. 

4. 

5. 

6. 

Select Define from the Record Menu (P4). 
Position the cursor where you want the field 
(not the field name) to begin. Be sure to leave 
enough room for a field label and outlining, if 
desired. 
Select Add from the Field Menu (F6). (Or, press 
ENTER or double click the mouse button. 
These work as accelerators for the Add option.) 
The field‘s first character slot appears on the 
screen. 
Add character slots until the field is the desired 
size. If you are using the keyboard, use the 
arrow keys and then press ENTER. If you are 
using a mouse, point to the cursor, press down 
on the mouse button and drag it to the desired 
size, and then release the mouse button. 

Note:  Moving the cursor down and up 
adds and deletes whole rows of charac- 
ter slots. Moving the cursor right and 
left adds and deletes whole columns of 
character slots. Every tenth character is 
shaded to aid you in counting the char- 
acter slots. 

A dialog box appears, containing several options 
that let you specify information about the field. 
At the Name: prompt, type the name you want 
to give the field, using 20 characters or fewer. 
Choose a name that you might want to appear be- 
side or above the field to remind you of the kind 
of information to be typed into that field (last 
name, address, phone number, and so on). Also, 
if you want to include a colon (:) following a 
field, be sure to ty-pe it with the name. Form 
Setup does not add a colon automatically. 
At the O u t  1 i ned : prompt, choose either yes or 
no to indicate whether you want the fields to ap- 
pear with or without a “box” outline. 

Note:  Outlining fields can make your 
records easier to read and can call atten- 
tion to a specific field. However, you 
must have a graphics printer to print 
outlines. Also, outlining makes a field 
take up more space. Therefore, you can- 
not place outlined fields right next to 
each other. 
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7. At the Data type: prompt, choose either text or 
number to indicate the type of information the 
field will hold (text or numerical). 
Choosing text lets you enter any type of charac- 
ter in the field. Choosing number lets you type 
only numeric characters (0-9) and the symbols + 
and - (to indicate whether a number is positive or 
negative). Therefore, a good rule of thumb is to 
choose number only if you want a report summary 
to perform a calculation based on the numbers in 
the field. Also, a field cannot be numeric if it con- 
tains more than 39 character slots or more than 
one line of character slots. 

Note:  If you choose number, be sure to 
include a decimal point format charac- 
ter if you want to enter decimal num- 
bers in the field. Otherwise, Filer lets 
you enter only whole numbers. 

8. At the Label : prompt, choose lef t ,  top ,  or 

9. Select OK to complete the task. 
hidden to indicate the location of the field name. 

Repeat the procedure for any other fields you want 
to include on the record. 

Notes: 
As long as the cursor is on a field, that field 
is selected and the Add option is unavail- 
able. Move the cursor to the location for 
the next field before trying to use Add again. 
If you reach the maximum number of char- 
acter slots, the Add option becomes unavail- 
able and appears shadowed. 

After you create a field on a record layout, you can 
add that field to a report layout. 
To a d d  a f ie ld t o  a report  layout: 

1. Select Defi ne from the Report Menu (F5). 
A report layout screen appears. 

2. In the layout’s body section, move the cursor to 
where you want the field’s information to ap- 
pear. 

Note:  The title bar of the section you 
are in is unhighlighted. 

3. Select Add from the Field Menu (F6). 
A dialog box appears, listing all the fields whose 
information can appear on the report. 

4. Highlight the name of the field you want at  the 
chosen location. 

For more specific instructions on hghlighting Form 
Setup information, see “Highlight Information” in 
the “Other Form Setup Information” section. 

The field name appears in the edit field. 

The field is added at the chosen location. Repeat the 
procedure for any other fields you want to include in 
the report. 

Note: If there is not enough room for a field, you 
see a dialog box containing the message Field 
too b i g ,  w i  11  truncate. Select OK if you want to 
keep the field at its current location, with any 
extra characters truncated. Otherwise, select 
CANCEL. 

5. Select OK to complete the task. 

Change 
Lets you change the attributes assigned to a record 
field or a report layout’s summary field. 
To change  the record f ie ld:  

Note: You might need to change a field’s size or 
location to accommodate intended changes in 
field attributes. 

1. Select Defi ne from the Record Menu (F4). 
2. Highlight the field whose attributes you want to 

change. 

For more specific instructions on highlighting Form 
Setup information, see “Highlight Information” in 
the “Other Form Setup Information” sectlon. 

3. Select Change from the Field Menu (P6). 
A dialog box appears, containing several field op- 
tions that you can change. 

name, using 20 or fewer characters. 

no to indicate whether you want the field to ap- 
pear with or without a “box” outline. 

4. At the Name: prompt, you can type a new field 

5. At the O u t  1 1 ned : prompt, choose either yes or 

101 



DeskMate User’s Reference 

6. At the Data type: prompt, choose either text or 
number to indicate the type of information the 
field will hold (text or numerical). 

Note:  You cannot change text fields to 
numeric fields. If you must do this, you 
can use the Edit Menu’s (F3) C1 ear  op- 
-tion to delete the field so that you can 
recreate it. Be aware, however, that 
deleting a field removes that field from 
your records, automatically erasing any 
mformation in that field. 

7. At the Label : prompt, choose lef t ,  top, or 

8. Select OK to complete the task. 

1. Select Define from the Report Menu (F5). 
The report layout screen appears. 

2. In the layout‘s summary section, highlight the 
field whose attributes you want to change. 

hidden to indicate the location of the field name. 

To change a report layout’s summary field: 

8. If you chose t o t a l  or avg, use the Fields ht 
box to choose the numeric field you want to use 
for the summary. 

9. Select OK to complete the task. 

Si%e 
Changes the size of a field on a record layout or a 
summary field on a report layout. 

Notes: 
You cannot make a numeric field more than 
one line long or more than 39 character 

If you decrease the size of a field after ad- 
ding information to your file’s records 
through the Filer application, the informa- 
tion is shortened to accommodate the new, 
shorter field length. 

slots long. 

1. Highlight the field whose size you want to 
change. 

For more specific instructions on hig1zlighting Form 
Setup information, see “Highlight Information ’’ in 
the “Other Form Setup Information” section. 

3. Select Change from the Field Menu (F6). 
A dialog box appears, containing several sum- 
mary field options you can change. 

4. At the Name: prompt, you can type a new sum- 
mary field option, using 20 or fewer characters. 

5. At the O u t 1  i ned: prompt, choose yes or no to in- 
dicate whether you want the summary field to 
appear with or without a “box” outline. 

6. AttheData type: prompt, choose total ,  avg, or 
count to indicate the type of summary informa- 
tion you want to see on the report (a total of 
the numeric information in the chosen field, or 
a count of the number of records appearing on 
the report). 

Note:  If the field you are changing is a 
text field, the total and avg options ap- 
pear shadowed to indicate that they are 
not available. 

7. At the Label: prompt, choose left , top,  or h i d -  
den to indicate the location of the summary 
field name. 

~~ 

For more specific instructions on highlighting Form 
Setup information, see “Highlight Information” in 
the “Other Form Setup Information” section. 

2. Select Size  from the Field Menu (F6). 
The cursor appears to the right of the field’s final 
character slot. 

To do this with the keyboard, use the arrow keys 
and then press ENTER when the field is the 
desired length. With the mouse, drag the cursor 
and then release the mouse button. 

3. Make the field larger or smaller. 

If you are resizing a field on a record layout, the 
field’s size changes only on that layout. I t  does not 
change on the report layout. You can change the 
size on the report layout, however, by redefining the 
field on that layout. 
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Format 
Adds format characters to any field in a record 
layout or to a summary field in a report layout. 

Note: You must create the field before you can 
insert format characters into it. 

1. Highlight the field in which you want to place 
format characters. 

2. Select Format from the Field Menu (F6). 

For more specific instructions on highIigliting Form 
Setup information, see “Highlight lnfonnation” in 
the “Other Form Setup Information” section. 

3. 

The cursor appears in the field‘s first character 
position. 
Move the cursor to any slot where you want a 
format character to appear. Then, type the char- 
acter. 

Note: You can press BACKSPACE or 
DELETE to remove a format character. 

4. Repeat Step 3 for any other format characters in 

5. Press ENTER (or click the mouse button 
that field. 

anywhere outside the field) to complete the task. 
The format characters are now part of the field and 
will automatically appear in the file’s empty records 
when you enter information from Filer. 

Text Menu 
The Text Menu (€77) options let you add boldface or 
underline to cosmetic text or change it back to plain 
text. 

Underline 

Plain 
Returns boldfaced and/or underlined cosmetic text 
to plain text. 
1. Highlight the text that you want to return to 

plain type. 

For more speclfic instructions on highlighting Form 
&hip information, see “Highlqht Information” in 
the “Other Form Setup Information” section. 

2. Select P1 a i  n from the Text Menu (P7). 
The highlighted text now appears in plah type. 

Bold 
Makes cosmetic text on the screen appear and print 
boldfaced. You can boldface either plain or under- 
lined cosmetic text. 
1. Highlight the text you want to boldface. 

~~ 

For more specrfic instructions on highlighting Form 
Sehip information, see “Highlight Information” in 
the “Other Form Setup Information” section. 

2. Select Bo1 d from the Text Menu (F7). 
The text you highlighted now appears in a different 
color or intensity. 

Underline 
Makes cosmetic text on the screen appear and print 
underlined. You can underline either plain or 
boldfaced text. 
1. Highlight the text you want to underline. 

For more spec@ instructions on hghlighting Form 
Sehiy Information, see “Highlight Information” in 
the “Other Form Setup Information” section. 

2. Select Under1 i ne from the Text Menu (€77). 
The text you highlighted now appears underlined. 
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Form Setup 
Tasks 
This section lets you look up Form Setup application 
tasks. The tasks are listed alphabetically, and the 
name of the menu and the option@) needed to per- 
form the task are listed beneath the task. If you 
don’t know how to use the option($, see the “Menu 
Options” section for detailed information and step- 
by-step instructions. 
Add a Field to a Record Layout 

Record P4 (Define) 
Field P6 (Add) 

Report P5 (Def i ne) 
Field €76 (Add) 

Report P5 (Def i ne) 
Report P5 (Sumnary) 

Add Format Characters 
Field F6 (Format) 

Boldface Text 
Text P7 (Bo1 d) 

Cancel a Report Layout 
ReportP5 (Clear a l l )  

Cancel Boldface or Underline 
Text P7 (P1 a in)  

Change Field Attributes on a Record Layout 
Record P4 (Def i ne) 
Field F6 (Change) 

Report P5 (Def i ne) 
Field €76 (Change) 

Report P5 (Def i ne) 
ReportP5 (Resize s e c t i o n )  

Copy a File’s Layouts 
File P2 (Copy 1 ayouts) 

Create a New File from Within a File 
File €2 (New) 

Create a Record Layout 
Record €74 (Define) 

Create a Report Layout 
Report F5 (Def i ne) 

Add a Field to a Report Layout 

Add a Summary Field to a Report Layout 

Change Field Attributes on a Report Layout 

Change the Size of a Report Layout Section 

Delete Information from a Layout 

Display a ProgranVApplication Name and Version 
Number 

Duplicate Information Within the Same Layout 

Edit F3 (Clear) 

File F2 (About) 

Edit P3 (Copy) 
Edit F3 (Paste) 

Exit Form Setup 
File F2 (Ex i t )  

Format a Report Layout 
Report F5 (Def i ne) 
File F2 (Page setup) 

Insert a Date on a Report 
ReportF5 (Today’s date) 

Insert Page Numbers on a Report 
Report F5 (Page number) 

Move a Picture Within the Same Layout 
Edit F3 (Move p i c t u r e )  

Move Information Within the Same Layout 
Edit F3 (Cut) 
Edit F3 (Paste) 

File F2 (Open) 

File F2 (Open) 

Record P4 (Def i ne) 
Report F5 (Def i ne) 
File F2 ( P r i n t )  

Resize a Picture 
Edit F3 (S ize p i  c tu re)  

Run Another Application 
File F2 (Run) 

Sort Records 
Record F4 (Sort) 

Switch Between Layouts 
Record F4 (Def i ne) 
Report F5 (Def i ne) 

File F2 (Fi 1 e r )  

Report F5 (Show page) 

Text F7 (Under1 i ne) 

Open an Existing File from Within a File 

Open an Existing File in Another Drive or Directory 

Print a Layout 

Switch to Filer from Form Setup 

Test a Report Layout 

Underline Text 
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Other 
Form Setup 
Information 
Add Cosmetic Text 
Cosmetic text is any text that you place directly on 
a record or report layout - as opposed to field 
labels, report dates, and page numbers, which you 
generate ushg various Form Setup options. 
One way to produce cosmetic text is to simply type it 
in where you want it, and then press ENTER. 

Note: To move the cursor to where you want the 
text to begin, simply use the arrow keys. Or, if 
you have a mouse, move the mouse pointer and 
then click the mouse button. 

When you press ENTER, the text is automatically 
highlighted so that you can boldface and/or under- 
line it if desired, using the appropriate Text Menu 
(F7) option(s). 
If you would like to use a variety of typestyles and 
sizes, you can use the Draw application to create cos- 
metic text. Then, you can copy the text to your 
record or report layout. See “Place Graphics on a 
Layout” in this section for more information. 

Correct an Error 
If you make an error while typing information in a 
dialog box edit field, you can press either BACK- 
SPACE or DELETE to make corrections. Pressing 
BACKSPACE erases the character immediately to 
the left of the cursor. Pressing DELETE erases the 
character to the right of the cursor. 
On a layout, you can use the Edit Menu’s (F3) C 1 ear 
option to erase a highlighted field, cosmetic text, or 
graphics. 

Caution: Erasing a field on a record layout auto- 
matically deletes the field from your records and, 
therefore, deletes any information in that field 
from all records. 

Format Characters 
Form Setup gives you the option of adding format 
characters to any field in a record layout or to a sum- 
mary field in a report layout. 
Format characters are field characters that remain 
constant, such as: 

Hyphens in telephone numbers (555-3434) 
Slashes in dates (04/02/90) 
Decimal points and dollar signs in numbers 
($25.50) 

When added to a field in Form Setup, these charac- 
ters automatically appear in that field in your Filer 
records. There, they: 

Remind you of the format to use to enter infor- 
mation. 
Save you the trouble of entering them on each 
record. For example, to enter the sample date, 
you would type only 040290. 

You will probably want to include a decimal point 
format character in most numeric fields. If you do 
not include this format character, Filer will let you 
type only whole numbers in the given field. When 
you do include the decimal point, Filer automat- 
ically inserts .00 in the field if you don’t type the 
decimal. 

Note: Numbers are entered in the right most 
position. 

You can add format characters at any time after ad- 
ding a field. However, each format character takes 
up one space, so be sure to include the format char- 
acters when calculating the length of a field. 

High1 ight Information 
To highlight a layout item with the keyboard, p i -  
tion the cursor anywhere on the item and press the 
space bar. To highlight a layout item with a mouse, 
point to the item and click the mouse button. Form 
Setup lets you highlight only one item at a t h e  and 
you cannot highlight partial items (such as in- 
dividual characters in cosmetic text). 
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Place Graphics on a Layout 
0 

You can include pictures, borders, cosmetic text, and 
other graphics created with the Draw application on 
your Form Setup record and report layouts. It is a 
good idea to place such graphics first, using the fol- 
lowing general procedure. Then, when you are 
finished, you can arrange your fields around the 
graphics. 

1. 

2. 

3. 

4. 

Note: To print the graphics when you print your 
layouts, records, and reports, you must use a 
graphics printer, 
Using the Draw application, create the art you 
want to use on the layout. 
Copy the art to the Clipboard. 

e 

Note:  We recommend that you always 
copy the art (using the Copy option) 
rather than move it. This way, you al- 
ways have the original in your Draw 
file, available for editing or as a backup 
in case you accidentally delete the Clip- 
board copy. 

Start Form Setup, and create or open the file in 
which you want to use the art. 

Note: You can use the Run option on 
Draw‘s File Menu to start Form Setup 
without returning to the desktop. 

The record layout screen appears. If you are creat- 
ing a new field, the screen is blank. 
If you want to put the art on the record layout, 
continue with Step 5. If you want to put the art 
on a report layout, first select Def i ne from the 
Report Menu (€75) to display the report layout, 
and then continue with Step 5. 

5. Move the cursor to where you want the art to 

6. Select Paste from the Edit Menu (F3). 
appear. 

DeskMate inserts the Clipboard art at the cursor 
location. Once you select the art, which you do as 
you would in Draw, it appears with a handle box 
around it. 

picture and Size picture options to move or 
resize the art. These options work the same way 
as the Move and Res i ze options on Draw’s Edit 
Menu. 

7. If necessary, use the Edit Menu’s (F3) Move 

Notes:  
You can size or move your graphics in Form 
Setup, but if you wish to edit them in any other 
way, you need to do so from the Draw applica- 
tion. 
Form Setup does not “care” where your graphics 
come from as long as the art was originally 
created with Draw. For example, you can copy 
graphics from Text that were originally created 
in Draw. 
If you receive a Graphics form full  error when 
pasting graphics, return to Draw and try making 
your art less complex. 
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Overview 
What Is It? 
Are you ready for a break? Have some fun with DeskMate’s Hangman - a 
word game for all ages, young and old alike. 

What Can I Do with I t?  
Relax and have a little fun while DeskMate challenges your vocabulary. If 
you get called away and don’t have time to finish, DeskMate can save your 
game so that you can come back to it later. 

How Do I Use It? 
When you open Hangman, the following dialog box appears. 

Answer the prompts in this dialog box to define how you want to play the 
game: the number of players, words per game, and the number of wrong 
guesses (the number of chances you want before you are hanged). After you 
enter this information, another dialog box appears (shown at right), asking 
you to define player name(s) for the game. 
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If you want additional information about how to type the information in 
these boxes, see the Game Menu’s (P2) D e f  i ne option in the “Menu 
Options” section. 
After you type the name@), the Hangman screen appears (as shown at 
the right). 
The main area of the screen consists of the scoreboard, the status of the 
current game, the hangman area, the unknown word, and the letters you 
can use to guess the word. 
The rules of the game are simple. To win, you must guess all the letters 
for the unknown word. Or, if you’re playing against someone else, you 
must make fewer wrong guesses than your opponent. You can choose 
letters by either typing the desired letter from the keyboard or pointing 
to and clicking on the desired letter using the mouse. 
Hangman keeps track of the options you choose (such as how many words 
in a game, the number of players, the number of wrong guesses, and so on) 
and the game’s status. This information is displayed on the Hangman screen 
for your convenience. 
When you complete a word, DeskMate automatically selects a new word. 
To learn the basics about using Hangman, see the “Hangman” article in the 
Getting Started magazine. Then, when you are familiar with Hangman, this 
chapter will provide you with a quick way to answer specific questions. You 
can look up the step-by-step instructions for each menu option. If you want 
to know which options to use to perform a specific task, check the 
“Hangman Tasks” section at the end of this chapter. 
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Menu Options 
Hangman has two menus that list the options you 
can use with the game Hangman. The key that you 
press to see each menu appears beside the menu 
name. (For example, press the F2 key to see the 
Game Menu.) A shaded option on a menu means 
that the option is not available. Some options have 
accelerator keys listed next to them. Use these keys 
to perform tasks without pulling down a menu. For 
example, when you are ready to exit the game, you 
can press ESC to select E x i  t from the Game Menu 

This section explains each Hangman menu on the 
menu bar and also contains step-by-step instructions 
on how to use each option on the menus. 

(F2). 

Game Menu 
The Game Menu (Fa) options let you work with 
your Hangman game files. For example, you can 
start a new game, save the current game, or start 
over with the current player. 

I About ... I 
NeW 
Starts a new game of Hangman without returning to 
the desktop. 
1. Select New from the Game Menu (F2). 

A dialog box appears. The options you set during 
your previous game are still in effect. 

2. 

3. 

4. 

5. 

6. 

7.  

At the Number o f  P1 ayers prompt, choose the 
number of players for the new game of 
Hangman. 
At the Words per Game: prompt, choose the num- 
ber of words per game. 
To increase the number of words per game, move 
the cursor to the up arrow on the dialog box and 
press the space bar until the desired number ap- 
pears. You can have a maximum of ten words per 
game. 
To decrease the number of words per game, 
move the cursor to the down arrow on the dialog 
box and press the space bar until the desired num- 
ber appears. 
At  the Wrong Guesses : prompt, choose the num- 
ber of wrong guesses allowed before being 
hanged. 
To increase the number of wrong guesses al- 
lowed, move the cursor to the up arrow on the 
dialog box and press the space bar until the 
desired number appears. You can have a maxi- 
mum of 12 wrong guesses. 
To decrease the number of wrong guesses al- 
lowed, move the cursor to the down arrow on the 
dialog box and press the space bar until the 
desired number appears. 
Select OK to complete the task. 
Another dialog box appears so that you can list 
the player(s). The names of the player@) for the 
previous game are displayed in the dialog box. 
Type the name(s) of the player(s) for the game 
(if necessary). 
Select O K  to complete the task. 

DeskMate displays a new Hangman screen with the 
players and setup options you chose. 

Save 
Saves the current game so that you can return to it 
later. 

1. Select Save from the Game Menu (F2). ’ 

A dialog box appears, stating that the game was 
saved. 

2. Select OK to complete the task. 
Hangman saves this game until you save another 
game. 
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Restore 
Lets the current player start a saved hangman game. 

Select Restore from the Game Menu (F2). 
A new, unknown word appears, and the drawing 
(scaffold and man) is restored to the original state. 

sxit 
Exits Hangman and returns you to the desktop. 
1. Select E x i t  from the Game Menu (F2). 

A dialog box appears, asking if you want to save 
the current game. 

If you select YES, the next time you enter the 
Hangman application, DeskMate asks if you want 
to continue with the game you saved. 

2. Select YES or NO to return to rhe desktop. 

Run 
Lets you open another application file or run 
another software package without returning to the 
desktop. 
1. Select Run from the Game Menu (F2). 

A dialog box appears. 
2. At the Program: prompt, type the name of the 

application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm) include the 
extension when you type the name. Also, if the 
file is in a directory other than the current direc- 
tory, type a full pathname including the drive and 

3. At the D a t a  f i  1 e: prompt, either type the name 
of the file you want to use with the chosen ap- 
plication (or program) or leave the prompt 
blank. 
If you leave the prompt blank, DeskMate runs the 
application or program without opening a cor- 
responding data file. 

directory. 

4. Select OK to complete the task. 
DeskMate might ask you to insert the diskette con- 
taining the application or software program you 
specified. Insert the appropriate diskette, and select 
OK to run the program. 

When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the file desktop.pdm. After you insert the 
diskette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate use to run the program. 
1. Select About from the Game Menu (F4). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Players Menu 
The Players Menu (F3) options let you add, delete, 
or change the players for the Hangman game. 

Define 
Lets you change any player’s name. 
1. Select Defi ne from the Players Menu (F3). 

2. Change the names of any or all of the players 

3. Select OK when all the names are entered cor- 

A dialog box appears. 

for the current game. 

rectly. 

Add 
Adds a new player to your game. The maximum 
number of players is four. 

A dialog box appears. 

of the new player. 

1. Select Add from the Players Menu (F3). 

2. At the New pl  ayer name: prompt, type the name 

3. Select OK to complete the task. 
Hangman displays the new player’s name on the 
S C O R E B O A R D .  
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Delete 
Removes a player from the current game. 
1. Select Delete from the Players Menu (F3). 

A dialog box appears, listing each player. 
2. Choose the button next to the name you want to 

remove. 
3. Select OK to complete the task. 

Hangman deletes the name from the SCOREBOARD. 

Hangman Tasks 
This section lets you look up Hangman tasks. The 
tasks are listed alphabetically and the name of the 
menu and the option(s) needed to perform the task 
are listed beneath the task. If you don’t know how to 
use the option(s), see the “Menu Options” section 
for detailed information and step-by-step instruc- 
tiOnS. 
Add a Player 

Change the Players 

Display a Program/Application Name and Version 
Number 

Game F2 (About) 
Exit Hangman 

Game F2 ( E x i t )  
Play a New Game 

Game F2 (New) 
Remove a Player 

PlayersF3 (Delete) 
Run Another Application 

Game F2 (Run) 
Save the Current Game 

Game F2 (Save) 
Start Over with the Current Player 

Game F2 (Restore) 

Players F3 (Add) 

Players F3 (Oefi ne) 

Other Hangman 
Information 
Play a Saved Game 
To play a saved game, select HANGMAN. PDM from the 
PROGRAMS list box, and then select YES when the 
dialog box is displayed. DeskMate displays the game 
you saved the last time you played Hangman. 
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Telecom 
Overview 
What Is It? 
With DeskMate’s Telecom application, you can communicate with other host 
computers, outside news services, and bulletin boards. Communication with 
other computers is easy whether you’re using a direct connection (via cable) 
or communicating through a modem. 

What Can I Do with It? 
With the Telecom application’s many computer-communication features, 
you can: 

Communicate with an information service 
Share computer games or correspondence with your friends 
Print information you receive from another computer 
Automate Telecom’s communication commands by creating autolog files 

How Do I Use It? 
When you open the Telecom application, the command screen, like the one 
at the right, appears. 
You can use Telecom’s Commands Menu (F3) options and your knowledge 
of the host computer‘s communication requirements to create an autolog file 
on the command screen. With an autolog file and a communication connec- 
tion (direct cable or modem), you can automatically log on (connect) to 
another system, such as an information service. If you use an auto-dial 
modem, you can include the host computer’s telephone number in the 
autolog file, and the number is dialed automatically. 
Before you use Telecom, be sure to use DeskMate’s Setup Accessory (the 
Setup option on the Accessory Menu (F10)) to specify the communications 
equipment you are using. For more information about setting up your com- 
munication settings, see “The Setup Accessory” in the “Accessories’’ chapter. 
Then, when everything is set up, you can use the Commands Menu’s (F3) 
options to create an autolog file for your communication requirements. Use 
the Set option to define the communication parameters for the host com- 
puter. In addition, you can use the C a l l ,  Wai t, and Send options to specify 
the phone number and any special time allowances required for the logon 
procedures. The T r a n s f e r  and E x i t  options let you automatically transfer a 
file, terminate a connection, and exit Telecom. 
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After you create an autolog file, you can use the File Menu’s (F2) Save and 
Save as options to store the file so that you can use it again later. 
As you communicate with your friends and information services, you can 
use the Pri n t  option on the Buffer Menu (F4) to print out any information 
you are sending or receiving. Or, if you’d like, you can store this information 
in anoeer file or directory. 
To learn the basics about using Telecom, see the “Telecom” article in the Get- 
ting Starred magazine. Then, when you’re familiar with Telecom, this chap- 
ter will provide you with a quick way to answer specific questions. You can 
look up the step-by-step instructions for each menu option. If you want to 
know which options to use to perform a specific task, check the “Telecom 
Tasks” section at the end of this chapter. 
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Menu Options 
Telecom has four menus that list the options you 
can use with the application. The key that you press 
to see each menu appears beside the menu name. 
(For example, press the F2 key to see the File 
Menu.) A shaded option on a menu means that the 
option is not available. Some options have ac- 
celerator keys listed next to them. Use these keys to 
perform tasks without pulling down a menu. For ex- 
ample, when you want to execute a command, you 
can press CTRL+E to select the Execute command 
(option) from the Commands Menu (F3). 
This section explains each Telecom menu on the 
menu bar and also contains step-by-step instructions 
on how to use each option on the menus. 

File Menu 
The File Menu (Fa) options let you work with your 
DeskMate files. For example, you can create, open, 
save, or run Telecom autolog files, as well as run 
another program or DeskMate application. 

About I . . 

NeW 
Lets you create a new autolog file without returning 
to the desktop. 
1. Select New from the File Menu (F2). 

If you make changes to the current file, the mes- 
sage Save changes? appears. Continue with Step 
2. 
If you have not made changes to the current file, 
a new, blank command screen appears. 

2. Select YES, NO, or CANCEL. 
If the file is untitled, a dialog box ap- 
you can continue with Step 3. 
If the file is titled, a new, blank command 
appears. 

eight characters or fewer. 
Telecom automatically adds the extension .log m- 
less you specify otherwise. 

A new, blank command screen appears. 

3. At the Save as : prompt, type a filename usins 

4. Select SAVE to complete the task. 

Autolog 
Loads and runs an autolog file that is not currently 
displayed on the screen. To run the file that is cur- 
rently displayed, use the Commands Menu’s (P3) 
Execute option. 
Be sure your modem is properly connected and that 
the switches are set correctly. (For more infonna- 
tion, see your modem manual.) 
1. Select Autolog from the File Menu (F2). 

A dialog box appears, listing all the autolog files 
you can run. In addition, this box lists all the 
available drives and directories within the current 
directory. 

2. Highlight the name of the autolog file you want 
to run. If the autolog file you want to run is in 
another directory, highlight the appropriate 
drive or directory. 

If you highlighted a specific file name, the com- 
mands in the autolog file are performed and the 
terminal screen is displayed. You can monitor the 
dialing process in the small box on the screen. 
If you highlighted a drive or directory, its files 
and directories appear in the list box. Other avail- 
able drives appear in the list as well. Continue 
with Steps 4-6. 

name of the file you want to open. 

3. Select O K .  

4. Repeat Steps 1-3 until the list box displays the 

5. Highlight the autolog file you want to open. 
6. Select OK to complete the task. 

The commands in the autolog file are performed and 
the terminal screen is displayed. You can monitor 
the dialing process in the small box on the screen. 
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Open Save 
Opens an existing autolog file without returning to 
the desktop. 

Saves changes you have made in an existing autolog 
file without returning to the desktop. It is a good 

1. 

2. 

3. 

4. 

Select Open from the File Menu (F2). 
If you made changes to the current autolog file, 
Save changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
step 5. 
Select YES, NO, or CANCEL. 
If the autolog file on the screen is untitled, a 
dialog box appears. Continue with Step 3. 
If the autolog file already has a title, continue 
with Step 5. 
At the Save as: prompt, type a filename using 
eight characters or fewer. 
Telecom automatically adds the extension .log, 
unless you specify otherwise. 
Select SAVE to complete the task. 
A dialog box appears, listing all the autolog files 
you can open in the current directory. In addi- 
tion, the box lists all available subdirectories and 
drives. (The symbol [ ..] indicates the parent direc- 
tory.) 

5. Highlight the autolog file you want to open. If 
the file you want to open is in another drive or 
directoryy highlight the appropriate drive or 
directory. 

6. Select OK. 
If you highlighted a specific fie name, it is dis- 
played on the screen. 
If you highlighted a drive or directory, its files 
and directories appear in the list box. Other avail- 
able drives appear in the list as well. Continue 
with Steps 7-9. 

7. Repeat Steps 5 and 6 until the list box displays 
the name of the autolog file you want to open. 

8. Highlight the autolog file you want to open. 
9. Select OK to complete the task. 

The file you chose is displayed on the screen. 

idea to save changes to a file periodically to help 
prevent loss of information. (If you have not yet 
saved a file, use the Save as option on the File Menu 
(F21.1 

Telecom saves the changes you have made, and the 
file remains on the screen. 

Save as 
Saves a new autolog file that has never been named. 

Select Save from the File Menu (F2). 

1. Select Save as from the File Menu (P2). 

2. At the Save as : prompt, type the name you 
A dialog box appears. 

want to give the file, using eight characters or 
fewer. 
Telecom automatically adds the extension .log, 
unless you specify otherwise. 

3. Select SAVE to complete the task. 
The new file and its name are stored on disk, and 
the file remains on the screen. 

Print 
Prints a file to the screen, on paper, or to another 
file. 
Be sure to use the P r  i n t e r option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using. Telecom’s page setup op- 
tions are automatically set to print in a portrait for- 
mat. 
1. Select P r i n t  from the File Menu (F2). 

2. At the P r i n t  t o :  prompt, choose the Screen, 

A dialog box appears. 

P r i n t e r ,  or F i l e  button. 
The Screen button lets you print the file on the 
screen so that you can see how the information 
will look on paper. 
The P r i  n t e r  button lets you print the file on 
paper. 
The F i  1 e button lets you print the file to another 
file. Printing to a file lets you use the MS-DOS 
Print command to print this file from another 
MS-DOS computer that is not running DeskMate. 
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Note:  The printer used to print the file 
from MS-DOS must be the same type as 
the one you are using with DeskMate 
(the one you assigned with the Printer 
option on the Setup Accessory‘s Options 
Menu). If you want to transmit a file, 
choose ASCI I as the printer type. 

3. Follow the appropriate instructions below for 
the button you chose in Step 2. 

If you chose the Screen button: 
a. 

b. 

Select OK to complete the task. 
The file appears on the screen. You can use 
the arrow keys to scroll through it, or use 
the Next page option on the Options Menu 
(Fa) to look at the next page. 
When you finish viewing the file on the 
screen, select Exi t from the Options Menu 

The command screen is displayed. 
(F2). 

If you chose the Pri nter button: 
Select OK to begin printing. 
The file begins to print, and a dialog box ap- 
pears, containing information about the 
print operation. You can select CANCEL at 
any time to stop the operation. 

If you chose the Fi  1 e button: 
a. 

b. 

At the Fi lename: prompt, type the name 
you want to give the “printed” file, using 
eight characters or fewer. An extension of 
.pm will be added to the filename unless 
you specify otherwise. 

Note:  Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .prn file (if you used 
that extension) listed in any application’s 
list box. It does, however, reside on the 
disk. You can view it and other files in the 
directory, from the desktop’s Files View. 

Exit 
Exits Telecom and returns you to the desktop. 
1. Select E x i t  from the File Menu (F2). 

If you made changes to an autolog file, the mes- 
sage Save changes? appears. Continuewithstep 
2. 
If you have not made changes, you return to the 
desktop. 

If the autolog file is untitled, the prompt Save as : 
appears. Continue with Step 3. 
If the autolog file already has a filename, the 
desktop reappears on the screen. 

3. At the Save as : prompt, type a filename using 
eight characters or fewer. 
Telecom automatically adds the extension .log, 
unless you specify otherwise. 

4. Select SAVE to complete the task. 
The desktop reappears on the screen. 

2. Select YES, NO, or CANCEL. 

Run 
Runs another application file or another software 
package without returning to the desktop. 
1. Select Run  from the File Menu (F2). 

If you made changes to the autolog file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
Step 6. 

If the file is untitled, Save as : appears. Continue 
with Step 3. 
If the file has already been titled, continue with 
Step 6. 

3. At the Save as : prompt, type a filename of eight 
characters or fewer. 
Telecom automatically adds the extension .log, 
unless you specify otherwise. 

4. Select SAVE to complete the task. 
If the buffer contents has changed during this 
Telecom session, Save buffer changes? appears. 

Another dialog box appears. 

2. Select YES, NO, or CANCEL.  

5. Select YES, NO, or CANCEL.  
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6. At the Program: prompt, type the name of the 
application you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current one, e a full pathname, including the drive and 

7. AttheDatafile: prompt, eithertypethename 
of the data file you want to use with your 
chosen application (or program) or leave the 
prompt blank. 
If you leave the prompt blank, DeskMate runs the 
application or program you specify without open- 
ing a corresponding data file. 

8. Select OK to complete the task. 

directory. 

DeskMate might ask you to insert the diskette con- 
taining the application or software program you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the desktop.pdm file. After you insert the 
diskette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run the program. 
1. Select About from the File Menu (F2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Commands Menu 
The Commands Menu (F3) options let you create 
and edit the commands for an autolog file. For ex- 
ample, you can set communication parameters, send 
a response, transfer a file automatically, or insert 
and delete lines from an autolog file. 

t 
Set. I .  

call. * I  

k i t . .  . 
Send. . . 
Transf cr. . . 
Exit 

Tells Telecom the status of the communication line 
by establishing parameters such as baud rate, word 
length, parity, and so on. When you create an 
autolog file, the Set option is the first option you 
will use. 
1. Select Set from the Commands Menu (€73). 

A dialog box appears. 
2. At the Baud prompt, choose the appropriate rate. 

This option tells Telecom how fast to transmit in- 
formation to the other system. The higher the 
baud rate, the faster the transmission. If you use 
a modem, choose a baud rate that your modem 
and the other computer can use. If you use a 
direct cable connection, you can use any baud 
rate as long as the other computer also uses the 
same rate. You might not be able to communicate 
reliably at baud rates exceeding 1200 unless your 
computer and the host use flow control. 
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3. At the Word Length, Parity, and S t o p  Bi t s  
prompts, make the appropriate choices. 
These three options let you give Telecom techni- 
cal information that tells the program how to 
code and decode information passed between the 
two computers. The correct choices for these op- 
tions are usually dictated by the host. For ex- 
ample, most computers use one of the following 
sets of parameters: 

the appropriate choice. 
If you turn on flow control, transmission to the 
other system stops when the other system sends 
an Xoff code. Transmission resumes when it 
sends an Xon code. Telecom sends an Xoff to 
pause transmission from the other system when 
information is coming in too quickly. Telecom 
then sends an Xon to resume transmission when 
the buffer can handle more input. You can use 
flow control only if the host uses it as well. 

5. At the ASCI I f i 1 ter, Sel f echo, and Add 1 i ne 
feed prompts, make the appropriate choices. 

8-bit word size, no parity, and 1 stop bit 
7-bit word size, even parity, and 1 stop bit 

4. Atthe Flow control (Xon/Xoff) prompt, make 

Note:  You can use any or all of these three 
options. An “X  indicates the option is on. 

ASCI I f i  1 ter. Use this option to turn the ASCII 
filter on or off. Leaving the ASCII filter switch on 
removes all the characters above 80 
(hexadecimal) and control characters below 20 
(hexadecimal). 
Self echo. Use this option if you have problems 
displaying the characters you type during trans- 
h i o n .  For example, if the characters you type 
appear in duplicate, turn off the setting. If, on the 
other hand, your characters are not appearing at 
all, turn on the setting. 
Add 1 i ne feed. Use this option if the host system 
you are communicating with sends a carriage 
return character only. 

6. Select OK to complete the task. 

Call 
Tells Telecom to dial a telephone number of up to 
30 digits when running the autolog file. 

1. Select Ca l l  from the Commands Menu (P3). 

2. At the Phone number: prompt, type the 
A dialog box appears. 

telephone number you want the modem to dial, 
using no more than 30 digits. You can include 
dashes between area codes, exchanges, and 
numbers. 

3. Select OK to complete the task. 
Telecom inserts the Call  command in the 
Commands column and the number you typed into 
the Parameters column. 

Wait 
Tells Telecom to wait for a response from the host 
system or for a certain number of seconds to elapse, 
before disconnecting. 

Note:  Telecom automatically uses 30 seconds as 
its wait time. You can change this number to the 
number of seconds you realistically expect to wait. 

A dialog box appears. 

a. Wait for string: totypeastringofcharac- 
ters you expect to receive from the other 
system and the number of seconds you 
want Telecom to wait to receive the 
specified string. If Telecom does not receive 
the string in the number of seconds you 
specify, you can tell Telecom what to do 
next. 
Continue with Step 3. 

b. Wait for time period: toindicatethatyou 
want Telecom to wait a specified number of 
seconds before continuing the autolog file 
execution. 
Continue with Step 4. 

1. Select Wait from the Commands Menu (P3). 

2. Choose either: 

3. Type the string of characters you expect to 

4. Type the number of seconds you want to wait. 
receive from the host. 
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5. Ifyouchosewait for string:,  selectoneofthe 

Choose Stop Auto Log to tell Telecom to stop run- 
ning the autolog file and enter the terminal 
mode. The terminal screen appears. 
Choose Continue if you want to continue to run 
the autolog file. The next autolog file command is 
Star ted.  
Choose E x i t  to stop running the autolog file and 
exit Telecom. The communication line is discon- 
nected automatically. 

following options. 

6. Select OK to complete the task. 
Telecom inserts the Wai t command in the 
Commands column and the options you specified in 
the Parameters column. 

Send 
In an autolog file, tells Telecom that you want to 
send either a string of characters or a break se- 
quence to the host. 
1. 

2. 

3. 

4. 

Select Send from the Commands Menu (F3). 
A dialog box appears. 
Choose one of the following: 
Send string : to enter a maximum of 27 charac- 
ters you want to send to the other system. (For ex- 
ample, CTlU+ C is entered as ̂ C.) 
Send break sequence to send a break sequence to 
the other system. Many information services and 
other host systems require that you send a break 
sequence to gain the attention of the system's 
computer. 
If you chose Send string:, type the string you 
want to send (up to 27 characters). You can 
also turn the Add carriage return setting on or 
off to send a caniage return character at the 
end of the string. 

Select OK to complete the task. 
Telecom inserts the Send command in the 
Commands column and the options you specified in 
the Parameters column. 

Transfer 
Lets you set up an autolog file with predefined 
parameters for use in sending or receiving files. The 
parameters are stored and then automatically used 
when you run the autolog file. 

1. 

2. 

3. 

4. 

5. 

6. 

Select Transfer from the Commands Menu 
(F3). 
A dialog box appears. 
Highlight the name of the file whose transfer 
parameters you are defining, or type the name 
of the file at the Fi  1 ename : prompt. 
Choose Send to transfer a file from your com- 
puter to the host system or Receive to transfer a 
file from the host system to your computer. 
Choose one of the following: 
ASCI I to use the ASCII file transfer protocol. 
(Text application files are ASCII files if you 
change them using the To ASCI I option on Text's 
File Menu. But remember, boldface, underline, 
and page format codes cannot be transmitted in 
ASCII.) 

Note: The ASCII file transfer (in receiving 
mode) includes an information window 
that displays the incoming file. This win- 
dow lets you visually verify error messages. 

Xmodem to use this special file-transfer protocol. If 
you choose Xmodem, the other system must also 
use the Xmodem protocol. 
If you chose ASCI I, you can choose one of the 
following options: 
Add 1 i ne feed after carriage return to add a 
line feed each time Telecom sends (or receives) a 
carriage return character. DeskMate and most 
MS-DOS text files contain both a carriage return 
and a line feed at the end of each line. 
Strip line feed after carriage return totake 
out line feeds after carriage return characters. 
This results in a carriage return separating text 
file lines just as though they were typed on a key- 
board. 
Straight ASCII transfer to strip all non-ASCII 
codes from the file. It also tells Telecom to auto- 
matically end the transfer and close the trans- 
ferred file when the program sends or receives an 
end-of-file character. 
At the Command t o  s ta r t  transfer: prompt, 
type the command (up to 24 characters) needed 
to indicate to the host that your computer is 
ready to receive the ASCII file. (This option is 
only available when you are receiving an ASCII 
file.) 
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7. Choose Add carri age ret urn to add a carriage 
return for the command in Step 6 if required. 
(This option is only available when you are 
receiving an ASCII file.) 

8. At the Timeout: prompt, type the number of 
seconds that you want Telecom to wait without 
sending or receiving any characters before it 
closes the file and ends a transfer. 

9. Select OK to complete the task. 
These parameters are stored for the file you indi- 
cated. Any time the autolog file is run, it uses 
these parameters. 

Exit 
Placing the Exit  command at the end of the file, 
specifies that you want to immediately exit 
Telecom after running an autolog file. 

Select Exit from the Commands Menu (F3). 

The command screen displays the Exi t command at 
the end of the autolog file. 

Insert 
Inserts a blank line into an autolog file. 
1. Move the cursor to the line immediately below 

2. Select Insert from the Commands Menu (F3). 
A blank line appears, and all remaining lines move 
down to accommodate the insertion. You can now 
use another Commands Menu (F3) option to insert 
command information into the blank line. 

Delete 
Deletes a line from an autolog file. 

where you want to insert a blank line. 

1. Position the cursor in the line you want to 

2. Select Delete from the Commands Menu (F3). 
delete. 

The line disappears from the autolog file, and any 
lines below it move up. 

Execute 
Runs an open autolog file after you set up or change 
the parameters. 

Select Execute from the Commands Menu (F3). 
The terminal Screen appears, and DeskMate runs the 
autolog file parameters. 

Buffer Menu 
The Buffer Menu (F4) options let you use the ter- 
minal buffer to handle the exchange of hfonnation 
between computers. For example, you can turn the 
buffer on and off, save and print the contents of the 
buffer, or display the buffer contents on the screen. 

Bufler on 
Turns on the terminal buffer so that you can begh 
storing characters. Previous buffer contents are not 
affected. 

Select Buffer on from the Buffer Menu 014). 
Note: You can turn the buffer on or off 
from the terminal screen while you are 
communicating with the host system by 
pressing ALT+B. When the buffer is 
on, the words Buffer ON a pear on the 
bottom line of the termina P screen. 

Bufler ofl 
Turns off the terminal buffer so that it no longer 
stores characters being transmitted. 

Select Buffer off from the Buffer Menu (F4). 
Note: You can turn the buffer on or off 
from the terminal screen while you are 
communicating with the host system by 
pressing ALT+ B . When the buffer is 
on, the words B u f f er 0 N appear on the 
bottom line of the terminal screen. 

Load 
Loads a previously saved ASCII file into the b d e r  so 
that you can display it. The previous contents of the 
buffer are replaced by the ASCII file you load. 

1. Select Load from the Buffer Menu (€74). 
A dialog box appears, listing all the files in the 
current directory that you can load. In addition, 
this box lists all available subdirectories and 
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drives within the current directory. (The symbol 
[..I indicates the parent directory.) 

2. Highlight the name of the file you want to load 
or the drive or directory containing the file. Or, 
type the file you want to load at the Load F i  1 e: 
prompt. 

3. Select OK. 
If you chose a specific file, it is loaded into the 
buffer. 
If you chose a drive or directory, the appropriate 
directories and files are displayed. Other avail- 
able drives appear in the list box as well. Con- 
tinue with Step 4. 

4. Repeat Steps 2 and 3 until the list box displays 
the file you want to load. 

5. Highlight the name of the file you want. 
The filename you highlighted now appears at the 
Load Fi 1 e: prompt. 

The file is loaded into the buffer. 
6. Select OK to complete the task. 

Save a8 
Saves the contents of the buffer in a data file. 
1. Select Save as from the Buffer Menu (F4). 

2. At the Save as: prompt, type the name you 
A dialog box appears. 

want to give the file. 
Telecom automatically adds the .doc extension 
unless you specify otherwise. 

3. Select SAVE to complete the task. 

Display 
Displays the current contents of the buffer on the 
screen. 

Clear 
Deletes the current contents of the buffer. 

Select Di spl ay from the Buffer Menu (F4). 

1. Select C1 ear from the Buffer Menu (F4). 
If you have not saved the contents of the buffer 
since you added the last character, the message 
Save buffer changes? appears. To save the con- 
tents into a file before you clear the buffer, con- 
tinue with Step 2. To delete the contents of the 
buffer without saving them, choose NO. The con- 
tents of the buffer are deleted. 

2. Select YES, NO, or CANCEL.  
A dialog box appears. 

3. At the Save as: prompt, w e  the filename, 
using eight or fewer characters. 

The buffer information is stored in a file before 
being deleted from the buffer. 

Print 
Prints the buffer contents to the screen, on paper, or 
to another file. 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type of 
printer you are using. Telecom’s page setup options are 
automatically set to print in a portrait format. 
1. Select Print from the Buffer Menu (F4). 

2. At the Print t o :  prompt, choose the Screen, 
A dialog box appears. 

Printer, or File button. 
The Screen button lets you print the buffer con- 
tents on the screen so that you can see how the in- 
formation will look on paper. 
The Pri nter button lets you print the buffer con- 
tents on paper. 
The F i  1 e button lets you print the buffer contents 
to another file. Printing to a file lets you use the 
MS-DOS Print command to print this file from 
another MS-DOS computer that is not running 
DeskMate. 

Note: The printer used to print the file 
from MS-DOS must be the same type as the 
one you are using with DeskMate (the one 
you assigned with the Printer option on 
the Setup Accessory‘s Options Menu). To 
transmit a file, choose ASCI I as the printer 
type. 

3. Follow the appropriate instructions below for 
the button you chose in Step 2. 

If you chose the Screen button: 
a. Select OK to complete the task. 

The buffer contents appear on the screen. 
You can use the arrow keys to scroll 
through it or the Next page option on the 
Options Menu (F2) to look a t  the next page. 

b. When you finish viewing the file on the 
screen, select Exi t from the Options Menu 
(F2). 
The command screen is displayed. 
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If you chose the Printer button: 
Select OK to begin printing. 
The buffer contents begin to print, and a 
dialog box appears, containing information 
about the print operation. You can select 
CANCEL at any time to stop the operation. 

a. At the Fi lename: prompt, type the name 
you want to give the “printed” file, using 
eight characters or fewer. An extension of 
.pm will be added to the filename unless 
you specify otherwise. 

If you chose the Fi 1 e button: 

Note: Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

b. 
Note that when you return to the desktop, you 
will not see the .pm file (if you used that exten- 
sion) listed in any application’s list box. I t  does, 
however, reside on the disk. You can view it and 
other files in the directory from the desktop’s 
Files View. 

Select OK to complete the task. 

Op ti0 ns Menu 
The Options Menu (€75) options let you manually 
transfer a file, display the terminal screen, and dis- 
connect the telephone line. 

lexlfli rmi 

Transfer fsZe 
Lets you set up transfer files manually for use in 
sending or receiving files. 
1. 

2. 

3. 

Select Transfer f i l e  from the Options Menu 
(F5). 
Adialog box appears. 
Highlight the name of the file whose transfer 
parameters you are defining. 
Choose Send to transfer a file from your com- 
puter to the host system or Recei ve to transfer a 
file from the host system to your computer. 

4. 

5. 

6. 

7. 

8. 

9. 

Choose one of the following: 
ASCI I to use the ASCII file transfer protocol. 
(Text application files are ASCII files if you 
change them using the To ASCI I option on Text‘s 
File Menu. But remember, boldface, underline, 
and page format codes cannot be transmitted in 
ASCII.) 
Xmodem to use this special file transfer protocol. If 
you choose Xmodem, the other system must also 
use the Xmodem protocol. 
If you chose ASC I I, you can choose one of the 

Add 1 i ne feed after carriage return to add a 
line feed each time Telecom sends (or receives) a 
carriage return character. DeskMate and most 
MS-DOS text files contain both a carriage rem 
and a line feed at  the end of each line. 
S t r i p  line feed after carriage return totake 
out line feeds after carriage return characters. 
This results in a carriage return separating text 
file lines just as though they were typed on a key- 
board. 
S t r a i g h t  ASCII transfer tostripallnon-ASCII 
codes from the file. It also tells Telecom to auto- 
matically end the transfer and close the trans- 
ferred file when the program sends or receives an 
end-of-file character. 
At the Command t o  start  transfer: prompt, 
type the command (up to 24 characters) needed 
to indicate to the host that your computer is 
ready to receive the ASCII file. (This option is 
only available when you are receiving an ASCII 
file.) 
Choose Add carriage return to add a carriage 
return for the command in Step 6 if required. 
(This option is only available when you are 
receiving an ASCII file.) 
At the Ti meou t : prompt, type the number of 
seconds that you want Telecom to wait without 
sending or receiving any characters before it 
closes the file and ends a transfer. 
Select OK to complete the task. 

following options: 

Terminal 
Displays the terminal screen without running an 
autolog file. 

Select Terminal from the Options Menu (F53. 
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Disconnect 
Disconnects the telephone line after you finish com- 
municating with another system. When you choose 
this option, the line automatically disconnects. 

Select Disconnect  from the Options Menu (FS). 

Telecom Tasks 
Call Commands in Autolog Files 

Commands P3 (Ca l l )  
Create a New Autolog File from Within an 
Autolog File 

File F2 (New) 
Delete a Line From an Autolog File 

Commands P3 (Delete) 
Delete the Buffer Contents 

Buffer P4 (Clear) 
Disconnect the Telephone Line 

Options P5 (Disconnect) 
Display a Program/Application Name and 
Version Number 

File I72 (About) 
Display the Buffer Contents 

Buffer P3 (Di s p l  ay) 
Display the Terminal Screen 

Options P5 (Terminal) 
Execute an Autolog File 

File F2 (Auto1 og) 
Execute an Open Autolog File 

Commands P3 (Execute) 
Exit Telecom 

File P2 (Exi t )  
Exit Telecom After Executing an Autolog File 

Commands P3 (Exi t) 
Insert a Line in an Autolog File 

Commands P3 ( I nse r t )  
Load the Buffer 

Buffer F4 (Load) 
Open an Existing Autolog File 

File P2 (Open) 
Print an Autolog File 

File F2 (P r in t )  
Print the Buffer Contents 

Buffer P4 (Print) 
Run Another Application 

File F2 (Run) 
Send the Host a Response Within an Autolog File 

Commands P3 (Send) 

Set the Communication Parameters 

Store the Buffer Contents 

Store Updates to a New Autolog File 

Store Updates to an Existing Autolog File 

Transfer a File Automatically 

Transfer a File Manually 

Turn Off the Buffer 

Turn On the Buffer 

Wait for the Host Response Within an Autolog File 

Commands F3 (Set) 

Buffer F4 (Save as) 

File F2 (Save as) 

Files P2 (Save) 

Commands F3 (Transfer)  

OptionsP5 (Trans fer  f i l e )  

Buffer €74 (Bu f fe r  o f f )  

Buffer P4 (Bu f fe r  on) 

Commands P3 (Wai t) 

Other Telecom 
Information 
Bu.er  
A buffer is a temporary storage area in memory that 
enables the host and the terminal(s) to operate at 
different speeds. 

Command Screen 
As you use options on the Commands Menu (P3) to 
define your communication parameters or to set up 
your autolog file, the information appears on the 
screen. This screen displays the information in two 
columns under the headings Commands and 
Parameters.  Each time you add information to the 
autolog file, the information appears on the com- 
mand screen. For more information on using the 
command screen, see “Display the Command Screen 
During Communications.” 
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Correct an Error 
If you make an error as you are typing information 
in a file, you can press BACKSPACE or DELETE to 
make corrections. Pressing BACKSPACE erases the 
character to the left of the cursor. Pressing DELETE 
erases the character to the right of the cursor. If 
several characters or the whole field are highlighted, 
everything highlighted is deleted. 
You can also use the Buffer Menu's (F4) C1 ear op- 
tion to erase the contents of the buffer. 

Display the Command Screen - -  
During Communications 
When you are connected to another system and are 
communicating with it, you see the terminal screen. 
To use the Buffer (P4) and Options (F5) Menus, 
you must return to the command screen by pressing 
ALT+C. 
When you return to the command screen, you can 
issue commands to Deskh4ate without interrupting 
your communications session. 
You can return to the terminal screen by using the 
Options Menu's (P5) Termi n a l  option. 

Edit an Autolog File 
If you make an error in a line of your autolog file, 
you can change the contents of the line by following 
these instructions. You can also use the Insert and 
Delete options on the Commands Menu (F3) to add 
and delete lines. 

change. 
1. Move the cursor to the line that you want to 

2. PES ENTER. 
The dialog box for the command line that you high- 
lighted appears. Change the contents of the com- 
mand line, following the instructions for that 
particular command. For example, to change the con- 
tents of the Set command line, follow the instruc- 
tions for the Commands Menu's (F3) Set option. 

Stop Running 
Autolog File 

an 

When you are using the Auto 1 og option on the File 
Menu (F2), you can stop running the file at any 
time by pressing ESC. 
If you are already connected to the host when you 
cancel the login process, you remain connected. If 
you are not yet connected, press ALT+C to display 
the command screen. 
When the command screen appears, you can select 
the Autolog option again to repeat the lo& process. 

Terminal Screen 
While you are communicating with another corn- 
puter, the terminal screen appears, and DeskMate 
acts in a different way. There is no title bar or menu 
bar on the screen, and you cannot use the Acce~~ory 
Menu (F10). 
When you press a key, you send the corresponding 
ASCII code to the host. If your host requires a con- 
trol code, you can send that code by using the CTRL 
key in combination with another key. For example, 
pressing CTRL+ J sends the ASCII code 10 (a line 
feed) to the host, (Documentation you get from the 
host commonly refers to these codes with the symbol 
", that is, "J for the code produced by pressing 
CTRL+ J.) 
Use the Terminal option on the Options Menu (P5) 
to display the terminal screen. 
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Overview 
What I s  It? 
You can say good-bye to your typewriter and give documents a facelift with 
DeskMate’s Text. The Text application is a simple word-processing program 
that lets you prepare letters, memos, notes, or anything else that you might 
normally use a typewriter to produce. 

What Can I Do with I t?  
The Text application contains a myriad of features that will change the way 
you think about the task of writing. This application lets you do everything 
a typewriter will do, plus much, much more. For example: 

Design your page layout and include headers, footers, and automatically in- 
sert page numbers 
Emphasize your words on paper by using techniques such as centering, 
boldfacing, and underlining 

Create form letters using information from the Address Book application 
Insert pictures into your documents using the Draw application 

Check your spelling 

How Do I Use It? 
When you open the Text application, or one of its associated data files, a 
screen similar to the one at the right appears. 
Use the Text screen like a sheet of typewriter paper. Simply begin typing. 
Notice that when you reach the end of a line, Text wraps the word to the 
next line so that you don’t have to stop typing until you reach the end of a 
paragraph. To end a paragraph, press ENTER. To leave a blank line be- 
tween paragraphs, press ENTER again. 
When you begin typing, you are in Insert mode. This means that you can 
move the cursor over existing text and insert new text by simply typing. The 
existing characters move right to accommodate the new text. If you make a 
mistake while typing, you can press BACKSPACE to delete the previous 
character. The text closes up after the character is deleted. 
AU of your document might not appear on the screen at the same time. But, 
you can easily move (scroll) through the text using the arrow keys. If you 
are using a mouse, simply click on one of the arrows on the menu bar. 
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After you finish typing your document, you can design your document’s 
‘look” by adding headers, footers, and page numbers; setting specific rnar- 
gins; and so on. You can then print a professional-looking document. 
To learn the basics about using Text, see the “Text” article in the Getting 
Started magazine. Then, when you’re familiar with Text, this chapter will 
provide you with a quick way to answer specific questions. You can look up 
the step-by-step instructions for each menu option. If you want to know 
which options to use to perform a specific task, check the “Text Tasks” sec- 
tion at the end of this chapter. 
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Menu Options 
Text has six menus that list the options you can use 
with Text. The key that you press to see each menu 
appears beside the menu name. (For example, press 
the F2 key to see the File Menu.) A shaded option 
on a menu means that the option is not available. 
Some options have accelerator keys listed next to 
them. Use these keys to perform tasks without pull- 
ing down a menu. For example, when you want to 
copy text, you can press CTRL+INSERT to select 
Copy from the Edit Menu (F3). 
This section explains each Text menu on the menu 
bar and also contains step-by-step instructions on 
how to use each option on the menus. 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can create a new 
document while you are working in an existing docu- 
ment or format your page layout exactly as you 
want it to appear. 

Print farm Istter.. . 

1 I n  ASCki I 
Ahaul . . . 

New 
Creates a new document without returning to the 
desktop. 
1. Select New from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, a new document 
screen appears. 

2. Select YES, NO, or CANCEL.  

If the document is untitled, Save as : appears. 
Continue with Step 3. 
If the document is titled, a new document screen 
appears. 

3. At the Save as : prompt, type a filename of eight 
characters or fewer. 
Text automatically adds the extension .doc, m- 
less you specify otherwise. 

4. Select SAVE to complete the task. 
A new, untitled document screen appears. 

Open 
Opens an existing document from within the docu- 
ment you are currently working in or you can open 
an existing document in another drive or directory 
without returning to the desktop. 
1. Select Open from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
Step 5. 

2. Select YES, NO, or CANCEL.  

If the document is untitled, Save as: appears. 
Continue with Step 3. 
If the document is titled, continue with Step 5. 

3. At the Save as : prompt, type a filename of eight 
characters or fewer. 
Text automatically adds the extension .doc, un- 
less you specify otherwise. 

A dialog box appears, listing all the documents 
you can open in the current directory. In addi- 
tion, the box lists all available subdirectories and 
drives. (The symbol [..I indicates the parent direc- 
tory.) 

4. Select SAVE to complete the task. 

Note: You can also use the Text ap- 
lication to look at ASCII files (such as 

gatch files). Simply type the name of 
the file at the appropriate prompt, and 
press ENTER. 

5. Highlight the document, drive, or directory you 
want to open. 
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6. Select OK. 

If you chose a specific document, it is displayed 
on the screen. 
If you chose another drive or directory, the direc- 
tories and documents in the highlighted drive or 
directory you chose are displayed. Other avail- 
able drives also appear in the list box. Continue 
with Step 7. 

7. Repeat Steps 5 and 6 until the list box displays 
the name of the document you want to open. 

8. Highlight the document you want to open. 
9. Select OK to complete the task. 

The document appears on the screen. 
Note: When you open a document 
from a different drive or directory, sub- 
sequent “open” operations will display a 
list of documents, drives, and direc- 
tories from the directory in which the 
opened document resides. However, 
when you exit Text, the desktop dis- 
plays a list of documents from the direc- 
tory you were in when you accessed 
Text. 

Save 
Stores changes you have made in an existing docu- 
ment without returning to the desktop. It is a good 
idea to store changes to a document periodically to 
help prevent loss of information. (If you have not 
yet named your file, use the Save as option on the 
File Menu (FZ).) 

Text stores the changes you have made, and the 
document remains on the screen. 

Save as 
Use this option to rename your document or to 
name and store a new file without exiting the file. 

Select Save from the File Menu (F2). 

1. Select Save as from the File Menu (F2). 

2. At the Save as : prompt, type the name you 
A dialog box appears. 

want to give the document, using eight or fewer 
characters. 
Text automatically adds the extension .doc unless 

specify otherwise. 
3. Select SAVE to complete the task. 

The document is stored on disk but remains on the 
screen. 

Merge 
Inserts an entire document into the currently dis- 
played document. 

1. Move the cursor to the place where you want to 

2. Select Merge from the File Menu (Fa). 
insert another document. 

A dialog box appears, listhg all the documents in 
the current directory that you can merge. The 
box also lists all available subdirectories and 
drives. (The symbol [..I indicates the parent direc- 
tory.) 

3. Highlight the document you want to merge, or 
highlight the drive or directory containing the 
document you want to merge. 

If you chose a specific document, it is inserted at 
the cursor location. 
If you chose another drive or directory, the direc- 
tories and documents in the highlighted drive or 
directory you chose are displayed. Other avail- 
able drives also appear in the list box. Continue 
with Step 5. 

5. Repeat Steps 3 and 4 until the list box displays 
the name of the document you want to merge. 

6. Highlight the document you want to merge. 
7.  Select OK to complete the task. 

The document is inserted at the cursor location. 

4. Select OK 

Page setup 
Lets you design the physical page layout for your 
printed document. If you change the default settings 
for this option, your document is automatically con- 
verted to non-ASCII format. 

1. Select Page setup from the File Menu (Fa). 
A dialog box appears. Some of the options might 
not be available, depending on the type of printer 
you are using. Additional information about each 
option appears after the steps. 

2. Change the desired options. 
3. Select OK to complete the task. 

Paper Size. Choose the size paper you are using. If 
you choose 0 t her, be sure to indicate the correct 
width and height in the appropriate fields. 
Left margin. Type the number of spaces you want 
for the left margin. 
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Line width. Type the total number of characters 
you want to print on one line. 
For example, if you are using 8Ih-inch paper and a 
ten-characters-per-inch font (such as Courier), the 
total line length is 85 characters. If you set a left 
margin of la- inches (15 spaces) and you want a 
right margin of 1 inch (ten spaces), subtract the left 
and right margin amounts from the total line length 
(85-25=60). The resulting total of 60 spaces (or 6 
inches) is the printed line width. Be sure that the 
sum of the entries for the Left margin and the Line 
w i  d t h  settings does not exceed the width of your 
pap-. 
Lines per page. Type the total number of lines on 
each sheet of paper. For example, an 8%- by 11-inch 
paper contains 66 lines in “portrait” mode when 
figured at six lines per vertical inch. 
Double space. Choose this option to print the 
document double spaced instead of single spaced. (If 
you choose Double space, the program inserts a 
blank line between every line.) 
Pause between pages. If you are not using con- 
tinuous form pages, this option lets you insert a new 
sheet of paper after each page prints. 
Print sideways. Choose this box to print sideways 
on your paper. When printing in this format, Desk- 
Mate only prints ten characters per inch. 
CENTER. By selecting this button, you can center 
your document on the page both vertically and 
horizontally. Enter the Left margin, Line width, and 
Lines per page settings as accurately as you can. 
Then, select the CENTER button and DeskMate will 
automatically adjust the Line w i d t h  and Lines per 
page settings so that the body of the document is 
centered on the paper (based on your current 
printer selection). 

Print 
Prints the currently displayed document to the 
screen, on paper, or to another file. 
Be sure to use the Printer option on the Setup 
Accessory‘s Options Menu to tell DeskMate the type 
of printer you are using. Also, be sure to set up your 
page layout using the File Menu’s (F2) Page setup 
option. 

1. 

2. 

3. 

Note: To print a portion of your document, high- 
light the section you want to print, and then 
proceed with these instructions. 
Select Print from the File Menu (FZ). 
A dialog box appears. 
At the Print t o :  prompt, choose Screen, 
Printer, or File. 
The Screen button lets you print the document to 
the screen so that you can see how it will look on 
the page. 
The Printer button lets you print the document 
on paper. 
The F i  1 e button lets you print the document to 
another file. Printing to a file stores the file on 
disk, using the name you give plus the extension 
.prn. You can then use the MS-DOS Print com- 
mand to print the file from another computer 
that is not running DeskMate. Or, you might send 
the file to another computer, using the Telecom 
application. 

Note: The printer used to print the file 
from MS-DOS must be the same as the 
one you are using with DeskMate (the 
one you assigned with the Pri n t e r  op- 
tion on the Setup Accessory‘s Options 
Menu). If you want to transmit the file 
using DeskMate’s Telecom application, 
choose A S C I  I as the printer type. 

Follow the appropriate instructions below for 
the button you chose. 

If you chose the Screen button: 
a. Select OK to complete the task. 

The document appears on the screen. ’ 
To view more of the document, you can 
scroll through it using the arrow keys or 
select the Next page option on the Optiom 
Menu (F2) to View the next page. 
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b. When you finish viewing the document, 
select E x i  t from the Options Menu (F2). 
The normal screen display appears. 

If you chose the Printer button: 
a. 

b. 

C. 

d. 

Select OK. 
If you have assigned a page number to the 
page, the prompt S t a r t i n g  page number ap- 
pears. 
If the number shown is incorrect, type the 
correct number. 
Select OK to begin printing. 
The document begins to print, and a dialog 
box appears, containing information about 
the print operation. You can select CANCEL 
at any time to stop the operation. 

Note:  If you chose the Pause between 
pages option when you formatted the 
page layout, the printer stops to let you 
change the sheets of paper when each 
page finishes printing. A dialog box ap- 
pears, asking whether you want to 
reprint the current page. 
To print the next page, insert a new 
sheet of paper, and select NO. If you 
want to reprint the same page, insert a 
new sheet of paper and select YES. 
Select CANCEL to stop the print opera- 
tion. 
When you finish printing, select NO at 
the Reprint current page? prompt. 

If you chose the F i  1 e button: 
a. 

b. 

At the F i  lename: prompt, type the name 
you want to give the “printed” file, using 
eight or fewer characters. Text automat- 
ically assigns the extension .prn, unless 
specified otherwise. 

Note:  Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .prn file (if you used 
that extension) listed in any application’s 
list box. It does, however, reside on disk. 
You can view it and other files in the direc- 
tory from the desktop’s Files View. 

Print form letter 
Lets you print form letters. (This option automat- 
ically runs the Mailmrge.pdm program to print form 
letters.) 

1. 

2. 

3. 

Note: If you are using a diskette system, the 
document you want to print and the Address 
Book file must be on the same diskette before you 
attempt to print a form letter. 
Select Print Form Letter from the File Menu 
(F2). 

Note:  If your document is untitled, you 
will be prompted to enter a filename. 

The Print Form Letter dialog boxappears. 
Select the list you want to use from the Address 
Book. 
Select OK to complete the task. 

You can print the form letter on paper, to another 
file, or to the screen. See the File Menu’s (F2) Pri n t  
option for more information. 

Exit 
Exits the Text application and returns you to the 
desktop . 
1. Select E x i t  from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, you return to the 
desktop. 

2. Select YES, NO, or CANCEL. 

If the document is untitled, Save as : appears. 
Continue with Step 3. 
If the document is titled, you return to the 
desktop. 

3. At the Save as: prompt, type a filename, US@ 
eight characters or fewer. 
Text automatically adds the extension .doc, un- 
less you specify otherwise. 

4. Select SAVE to complete the task. 
The desktop screen is displayed. 
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Run 
Opens another DeskMate application file or runs 
another software package without returning to the 
desktop. 
1. Select Run from the File Menu (FZ). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
Step 5. 

2. Select YES, NO, or CANCEL. 
If the document is untitled, Save as : appears. 
Continue with Step 3. 
If the document is titled, continue with Step 5. 

3. At the Save as: prompt, type a filename of eight 
characters or fewer. 
Text automatically adds the extension .doc, un- 
less you specify otherwise. 

4. Select SAVE to complete the task. 
A dialog box appears. 

5. At the Program: prompt, type the name of the 
application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension .pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current one, 
type a full pathname, including the drive and 
directory. 

6. At the Data f i 1 e : prompt, either type the name 
of the data file you want to use with your 
chosen application (or program) or leave the 
prompt blank. 
If you leave the prompt blank, DeskMate runs the 
application or program you specify without open- 
ing a corresponding data file. 

7. Select OK to complete the task. 

DeskMate might ask you to insert the diskette con- 
taining the application or software package you 
specified. Insert the appropriate diskette, and select 
OK to run the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the desktop.pdm file. After you insert the 
diskette and select OK, you return to the desktop. 

To ASCII 
Converts a non-ASCII document to ASCII format. 
Text automatically converts your document into non- 
ASCII format if you use a special word-processing 
code (for example, boldface or underline). 

Select To ASC I I from the File Menu (P2). 
Text converts your document into ASCII format. See 
the “Other Text Information” section for more infor- 
mation about ASCII format. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run the program. 
1. Select A b o u t  from the Game Menu (P2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Edit Menu 
The Edit Menu (F3) options let you edit the docu- 
ments you create in Text. For example, you can 
move information within the same document or to 
another application or document. 

cut 
Removes text or pictures in a document and places it 
on the Clipboard. 

Note: You cannot move a picture from a docu- 
ment to any application other than Text, Draw, or 
Form Setup. 

1. Highlight the information you want to move. 
2. Select C u t  from the Edit Menu (P3). 

Text removes highlighted information and places it 
on the Clipboard. 
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To place the Clipboard information into another 
document, another application, or at another loca- 
tion in the same document, use the Edit Menu’s 
013) Paste option. 

COPY 
Copies’text and/or pictures in your document to the 
Clipboard. 

Note:  You can copy a picture into the Text, 
Draw, or Form Setup applications. 

1. Highlight the information you want to copy. 
2. Select Copy from the Edit Menu (F3). 
Text copies the highlighted information to the Clip- 
board. 
To place copied information into another document, 
another application, or at another location in the 
same document, use the Edit Menu’s (F3) Paste 
option. 

Paste 
Inserts cut or copied information (Clipboard informa- 
tion) at the cursor location. 

Note: If you are moving a picture, be sure to posi- 
tion the cursor so that the picture fits within the 
margins of the file or document into which you 
are inserting it. You might need to adjust the 
page margins to accommodate the picture. See 
the File Menu’s (F2) Page setup option for more 
information. 

Clipboard information. 
1. Move the cursor to where you want to insert the 

2. Select Paste from the Edit Menu (F3). 
Text inserts the Clipboard information at  the cursor 
location. Keep in mind that you might need to revise 
the way the information appears on the screen (for 
example, inserting or deleting spaces or aligning 
text). 

Clear 
Deletes highlighted information. 
1. Highlight the section of your document that you 

2. Select Clear from the Edit Menu (F3). 
want to delete. 

Note: If you accidentally delete a section of your 
document (using the Clear option), you can 
reinsert it by using the Un- Del ete option on the 
Edit Menu (F3). 

Select all 
Highlights an entire document. 

Select Select a1 1 from the Edit Menu (F3). 
The document appears highlighted, and you can per- 
form functions on the highlighted text such as copy- 
ing or moving. 

Un-Delete 
Reinserts accidentally deleted text. 
1. Move the cursor to the place in your document 

where you want to reinsert the deleted text. 
2. Select Un-Delete from the Edit Menu (F3). 

The previously deleted text is reinserted at the cur- 
sor location. 

Note: When you delete text, it moves to a special 
“memory” area. If your document is filled to its 
maximum capacity, or if you choose another op- 
tion such as Merge, Header, or Footer, the deleted 
text is written over and you cannot use the Un- 
Delete option to restore the text. 

Insert 
Lets you switch between insert or overtype mode. 

Select Insert from the Edit Menu (F3). 
If a check mark appears next to the Insert option, 
you are in Insert mode. If there is no check mark, 
you are in Overtype mode. See the “Other Informa- 
tion Text” section for more information on the Insert 
and Overtype modes. 

Proof 
Accesses the Spell Checker Accessory so that you can 
check your document for correct spelling. 

Note: If you highlight a word or group of words 
before you select the Proof option, the spelling 
check is performed on the selected word(s) only. 
Otherwise, the Proof option checks the entire 
document for spelling errors. 

The information you highlighted disappears from 
the screen and is no longer part of your document. 
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1. 

2. 

Select Proof from the Edit Menu (F3). 
If the document has no misspelled words, a mes- 
sage is displayed letting you know that no correc- 
tions are necessary. If a misspelled word is found, 
a dialog box appears showing the unknown word 
and some possible replacements. 
Choose a replacement, or if the correct word 
does not appear in the list, move the cursor to 
the context area and type the word correctly. 

3. Select Accept context to complete the task. 
4. If necessary, select one of the following options 

on the Options Menu (F2): 
Add t o  Dictionary to add the unknown word to 
the user's dictionary. 

Note:  If you want to edit the user's dic- 
tionary, you must use the Spell Checker 
Accessory on the (F10) Menu. 

Restore context to restore the original word to 
the edit field. 

Thesaurus 
Select this option if you have purchased the Desk- 
Mate Thesaurus Companion software (Cat. No. 25- 
1365). Refer to the instructions that came with the 
software to use the Thesaurus with DeskMate. 

Text Menu 
The Text Menu (F4) options let you customize your 

Center CtrltC 
Un-Center 
Indent.. . Clrltl 

Dict ianay. .  . 

documents by selecting different ways to present the 
text. For example, you can boldface or underline 
text to emphasize it in a document. 

Plain 
Returns boldfaced and/or underlined text to plain text. 

1. Highlight the text you want to return to plain type. 
2. Select P1 a i  n from the Text Menu (F4). 

The highlighted text now appears in plain type. 

Bold 
Makes text appear bold. 

Note:  If your document is in ASCII format, Text 
automatically converts the document to non- 
ASCII format when you select the Bo1 d option. 

1. Highlight the text you want to boldface. 
2. Select Bo1 d from the Text Menu (F4). 

The text you highlighted now appears in a different 
color or intensity. 

Underline 
Makes text appear underlined. 
1. Highlight the text you want to underline. 
2. Select Under1 i ne from the Text Menu (P4). 

The text you highlighted now appears underlined on 
the screen. 

Center 
Centers a line of text in your document. 

Note:  Only single-line paragraphs can be 
centered. The line must be preceded by a carriage 
return and end with a carriage return. 

center. 
1. Move the cursor to the line of text you want to 

2. Select Center from the Text Menu (F4). 
The selected line automatically moves to the center 
of your document. 

Un-Center 
Removes the Center attribute from your text. 
1. Move the cursor to the line of text you want to 

2. Select Un-Center from the Text Menu (F4). 
center. 
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Indent 
Lets you set the first line, left margin, and right mar- 
gin indentations for your document’s paragraphs. 
1. Select Indent from the Text Menu (F4). 

2. Atthe First line indent: prompt, type the 
A dialog box appears. 

number of characters you want to indent the 
first line of a paragraph from the document’s 

3. At the Left margin indent : prompt, type the 
number of characters you want to indent the 
body of the paragraph from the document’s left 
margin. 

4. At the Right margi n indent : prompt, type the 
number of characters you want to indent the 
body of the paragraph from the document’s 
right margin. 

Note: There must be a minimum of 22 charac- 
ters on a line, after the margins are set. 

left margin. 

5. Select OK to complete the task. 

Dictionary 
As more options are developed to be used with Desk- 
Mate, you might want to add on to the DeskMate 
you are currently using. The Dictionary option is 
available so that you can expand your DeskMate pro- 
gram as dictionary enhancements become available. 

Trcurslate 
As more options are developed to be used with Desk- 
Mate, you might want to add on to the DeskMate 
you are currently using. The Trans1 ate option is 
available so that you can expand your DeskMate pro- 
gram as translation enhancements become available. 

Search Menu 
The Search Menu (F5) options let you search for 
text that appears in a document and then, if you 
choose, lets you substitute different text. 

Find 
Locates occurrences of a word or phrase you specify 
in a document. 
1. Move the cursor to where you want to begin the 

search. 
2. Select F i n d  from the Search Menu (P5). 

A dialog box appears. 
3. At the Search for:  prompt, type the characters 

you want to find, using a maximum of 39 char- 
acters. 
The characters you type are automatically sur- 
rounded by brackets. 

4. Select OK to begin the search procedure. 
Text begins searching from the cursor location for 
the specified text, ignoring upper/lowercase distinc- 
tions. For example, if you are searching for COM- 
PANY, Text finds occurrences of COMPANY, 
Company, company, or any other upper-/lowercase 
variations of the word. 
If the search is successful, the part of the document 
containing the specified text appears, with the cur- 
sor positioned at the beginning of the text. If Text 
cannot find the characters, you see the message 
Search string was n o t  found.  Select OK to remove 
the message from the screen. 
To find subsequent occurrences of the word or 
phrase, use the Search Menu’s (F5) F i n d  next op- 
tion. 

Find next 
Finds subsequent occurrences of words or phrases in 
a document (after you have used the Fi nd option). 

Select F i n d  next from the Search Menu (P5). 
The cursor moves to the next occurrence. If there 
are no other occurrences, the Search string was not  
found message is displayed. Select OK to remove the 
message from the screen. 

Substitute 
Lets you replace a certain sequence of characters (a 
string) that occurs several times in your document. 

Note: If the Substitute option finds a stringcon- 
taining boldfaced or underlined characters, the 
text that replaces it will also be boldfaced or un- 
derlined. 
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2. 

3. 

4. 

Select Substitute from the Search Menu (F5). 
A dialog box appears. 
At the Search for: prompt, type the text you 
want to find, using no more than 39 characters. 
At the Rep1 ace w i  t h  : prompt, w e  the text you 
want to use as a replacement, using no more 
than 39 characters. 

Note:  If you leave this field blank, you 
see a message asking if you are sure 
you don’t want to enter replacement 
text. Select YES or NO, and press ENTER. 

Select OK to complete the command. 
The program begins searching for the text you 
specified. If it finds the text, the part of the docu- 
ment that contains that text appears highlighted, 
and a dialog box asks whether or not you want to 
make the substitution at this particular occur- 
rence. 

5. Select YES, NO, or CANCEL. 

If Text cannot find the string you want to replace, 
you see the message Found 0 occurrences, rep1 aced 
0. Select OK to remove the message from the screen. 
When Text finishes finding and replacing all occur- 
rences of the st r ing  you specified, the screen dis- 
plays the number of occurrences it found and 
replaced. Select OK to remove the message from the 
screen. 

Layout Menu 
The Layout Menu (F6) options let you add headers, 
footer, page numbers, and the current date to your 
documents. In addition, you can add Address Book 
fields in your document for creating form letters. 

Page nunker 
Taday’ s date. . , 
Add f i e l d . . .  

Return to document 
Exits the header or footer screen and returns you to 
the current document. 

Select Return t o  Document from the Layout 
Menu (F6). 

You return to the document you were currently 
working in. 

Header 
Lets you create a header for your document. A 
header prints the same information at the top of 
each page. 
1. 

2. 

3. 

Select Header from the Layout Menu (F6). 
A dialog box appears so that you can choose the 
pages on which you want the header to appear, 
Choose the No header, Header on a1 1 pages, or 
Header on a1 1 pages except f i r s t  page button. 
Choosing the No header button deletes an exist- 
ing header. 
Choosing the Header on a1 1 pages button lets you 
type information as you want it to appear in the 
document. 
Choosing the Header on a1 1 pages except f i r s t  
page button lets you type information as you 
want it to appear in the document. However, the 
header will not appear on the first page. 
Follow the instructions below for the option you 
chose in Step 2. 

If you chose the No header button: 

The current document reappears on the screen. 
Select OK to complete the task. 

Note:  If you selected No header from 
the Footer screen, selecting No header 
returns you to the Footer screen. 

If you chose the Header on a1 1 pages button: 
a. Select OK to complete the task. 
b. The blank Header screen appears. 
c. Type the header information as you want it 

to appear in the document. 
Note:  The word Header appears on the 
far right side of the status lme to show 
that the header screen is displayed. 

137 



DeskMate User’s Reference 

If you chose the Header on a1 1 pages except f i  rst  
page button: 

a. Select OK to complete the task. 
The blank Header screen appears. 

b. Type the header information as you want it 
to appear in the document. 

Note: The word Header appears at the 
far right side of the status line to show 
that the header is being edited. 

If you chose Header on a1 1 pages or Header on a1 1 
pages except f i r s t  page, use as many lines as you 
wish for your header as long as you leave at least 
five lines for the document. To include more space 
between the header and the rest of your document, 
press ENTER to create a blank line at the end of the 
header information. 
You can use a picture from the Draw application in 
your header as long as you leave at least five lines 
for the document. See the “Other Text Information” 
section for more information about using Draw pic- 
tures with the Text application. 

Footer 
Lets you create a footer in your document. A footer 
prints the same information at the bottom of each 
Page. 
1. Select Footer from the Layout Menu (F6). 

A dialog box appears so that you can choose the 
pages on which you want the footer to appear. 

2. Choose the No footer, Footer on a1 1 pages, or 
Footer on a1 1 pages except f i r s t  page button. 
Choosing the No footer button lets you delete an 
existing footer. 
Choosing the Footer on a1 1 pages button lets you 
type information as you want it to appear in the 
document. 
Choosing the Footer on a1 1 pages except f i r s t  
page button lets you type information as you 
want it to appear in the document. However, the 
footer will not appear on the first page. 

3. Follow the appropriate instructions for the but- 
ton you chose in Step 2. 

If you chose the No footer button: 
Select OK to complete the task. 

The current document is redisplayed and the ex- 
isting footer is deleted. 

Note:  If you selected No Footer from 
the Header screen, you return to the 
Header screen. 

If you chose the Footer on a1 1 pages button: 
a. Select OK to complete the task. 

The blank Footer screen appears. 
b. Type the footer as you want it to appear in 

the document. 
Note: The word Footer appears on the 
far right side of the status lme to show 
that the Footer screen is displayed. 

If you chose the Footer on a1 1 pages except f i r s t  
page button: 

a. Select OK to complete the task. 
The blank Footer screen appears. 

b. Type the footer as you want it to appear in 
the document. 

Note:  The word Footer appears at the 
far right side of the status line to show 
that the Footer screen is displayed. 

If you chose Footer on a1 1 pages or Footer on a1 1 
pages except f i r s t  page, use as many lines as YOU 
wish for your footer as long as you leave at least five 
lines for your document. To include more space be- 
tween the footer and the rest of your document, 
press ENTER to create a blank h e  at the beginning 
of the footer. 
You can use a picture from the Draw application in 
your footer as long as you leave at least five lines for 
your document. See the “Other Text Information” 
section for more information about using Draw pic- 
tures in Text. 

Page number 
Inserts page numbers throughout your document. 
You can also use this option in a header or footer. 
1. Move the cursor to the location on the page 

2. Select Page number from the Layout Menu (€76). 
where you want the page number to print. 

A marker (###> appears at the cursor location. 
When you are ready to print, you will be prompted 
to enter the starting page number for the document. 
The document is then numbered consecutively. 
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Today’s date 
Lets you choose a date format and then indicate 
where you want the date to appear in your docu- 
ment. You can also use this option in a header or 
footer. 
1. Move the cursor to the place in your document 

2. Select Today’s date from the Layout Menu 

where you want the date to appear. 

(F6). 
A dialog box appears. 

to appear. 
3. Choose the format in which you want the date 

4. Select OK to complete the task. 

The format you chose appears at the cursor location. 
When you print your document, the format is 
replaced with the system date (the date on the title 

. 
Add field 
Lets you add Address Book fields for form letters, 
using fields from the Address Book application. 
1. Move the cursor to the location where you want 

to insert a field from the Address Book. 
2. Select Add f ield from the Layout Menu (F6). 

A dialog box appears, listing all the fields avail- 
able in the Address Book application. 

3. Choose the field you want to insert at the cursor 
location. 
The field name, surrounded by asterisks, appears 
at the cursor location. 

4. Continue to add any additional fields you want 
to include in your form letter. 

Note: If you are putting two fields of in- 
formation side by side and you want a 
space to appear between them, be sure 
to press the space bar between the field 
entries. 
When you highlight text for boldfacing, 
underlining or editing, the entire block 
of characters is highlighted as a whole. 

Picture Menu 
The Picture Menu (F7) options let you work with 
the Draw pictures in your document(s). For ex- 
ample, you can show all pictures that have pre- 
viously been hidden in your document and resize a 
picture. 

Show 
Displays all pictures in a document that you pre- 
viously “hid.” When you use this option, Text 
replaces the line ** Picture Located Here ** with 
the actual picture. 

Select Show from the Picture Menu (F7). 
All pictures return to the screen. 

Hide 
Replaces all the pictures in your document with a 
text notation. 

Select H i  de from the Picture Menu (F7). 
All the pictures in the document are immediately 
replaced with ** Picture Located Here **. 
When you “hide” the pictures, the space needed by 
the pictures remains constant so that you can 
paginate your document correctly. 
You can highlight this line of text, and the program 
treats it as the entire picture. You can then use any 
of the Edit Menu (F3) options, such as Copy and C u t .  
To return all the pictures to the screen, use the Show 
option. 

139 



DeskMate User’s Reference 

Move 
Moves a picture to another place in the same document. 
1. Move the cursor to the place immediately 

2. Select Move from the Picture Menu (F7). 
3. Move the art to its new location in the document. 

preceding the picture. 

She 
Lets you change the size of a picture in your document. 
1. Move the cursor to the place immediately 

2. Select Size from the Picture Menu (F7). 
3. Resize the box as you would in the Draw ap- 

The picture in your document now appears in the 
desired size. 

preceding the picture. 

plication. 

Text Tasks 
This section lets you look up Text application tasks. 
The tasks are listed alphabetically, and the name of the 
menu and the option(s) needed to perform the task are 
listed beneath the task. If you don’t know how to use 
the option(s), see the “Menu Options” section for 
detailed information and step-by-step instructions. 
Add a Field from Address Book 

Layout P6 (Add f i el d) 
ASCII Fonnat 

File F2 (To ASCI I) 
Boldface Text 

Text F4 (Bo1 d) 
Cancel Boldface or Underline 

Text F4 (P1 a i  n) 
Center Text 

Text F4 (Center) 
Check for Mistakes with Spell Checker 

Edit F3 (Proof) 
Convert to ASCII 

File F2 (To ASCI I) 
Create a Footer 

Layout F6 (Footer) 
Layout F6 (Return t o  Document) 

Laput F6 (Header) 
Layout F6 (Return t o  Document) 

Create a Header 

Create a New Document from Within a Document 

File F2 (New) 

Layout F6 (Footer) 

Layout F6 (Header) 

Edit F3 (C1 ear) 

Delete a Footer 

Delete a Header 

Delete a Section of a Document 

Display a Program/Application Name and Version 
Number 

Duplicate Information in Another Application 
File F2 (About) 

Edit F3 (Copy) 
File F2 (Run)  
Edit F3 (Paste) 

Edit F3 (Copy) 
File F2 (Open) 
Edit F3 (Paste) 

Edit F3 (Copy) 
Edit F3 (Paste) 

Edit F3 (Cut) 
Edit F3 (Paste) 

File F2 ( E x i t )  

Search F5 (F ind )  
Search F5 (Find next) 

Format a Page Layout 
File F2 (Page setup) 

Hide All Pictures 
Picture P7 (Hi de) 

Highlight an Entire Document 
Edit F3 (Select a1 1 )  

Indent Text 
Text F4 (Indent) 

Insert Another Document into the Document on the 
Screen 

Insert a Picture into a Document 

Insert Page Numbers 

Insert Text 

Insert Today’s Date in Your Document 

Duplicate Information in Another Document 

Duplicate Information Within the Same Document 

Edit a Picture 

Exit 

Find Text 

File F2 (Merge) 

Edit F3 (Paste) 

Layout F6 (Page number) 

Edit F3 (Insert) 

Layout F6 (Today’s date) 
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Move a Picture Within the Same Document 
File FZ (Cut) 
Edit F3 (Paste) 
Picture F7 (Move) 

Edit F3 (Cut) 
File FZ (Run) 
Edit F3 (Paste) 

Edit F3 (Cut )  
File FZ (Open) 
Edit P 3  (Paste) 

Edit F3 (Cut) 
Edit F3 (Paste) 

Move Information to Another Application 

Move Information to Another Document 

Move Information Within the Same Document 

Open an Existing Document from Within a 
Document 

Open an Existing Document in Another Drive or 
Directory 

File P2 (Open) 
Overtype Text 

Edit F3 (Insert) 
Print a Document 

File FZ (Print) 
Print a Form Letter 

File F 2  (Print form letter)  
Reinsert Deleted Information 

Edit F3 (Un-Del ete) 
Rename the Document on the Screen 

File F2 (Save as) 
Resize a Picture 

Picture F7 (Resi ze) 
Run Another Application 

File FZ (Run) 
Show All Pictures 

Picture F7 (Show) 
Store Updates to an Existing Document 

File F 2  (Save) 
Store Updates to a New Document 

File P2 (Save as) 
Substitute Text 

SearchF5 (Substitute) 
Thesaurus 

Edit F3 (Thesaurus) 
Underline Text 

Text P4 (Under1 i ne) 

File F 2  (Open) 

Other Text  
Information 
ASCII Format 
When you create a new document, it is in ASCII for- 
mat (shown at the bottom of the screen). Your docu- 
ment must be in ASCII format if you want to either 
communicate with other computers using the 
Telecom application or transfer a file to another 
software package. 
ASCII format does not accept any of the word- 
processing codes (often called formatting codes) 
that Text inserts for such things as boldface, under- 
line, headers, and so on. If you add pictures or 
change the defined page setup settings in p u r  docu- 
ment, your ASCII formatted document automatically 
changes to non-ASCII. 
You can always return your document to ASCII for- 
mat by using the To ASCI I option on the File Menu 
(F2), but you will lose all of the special word- 
processing formatting codes. 

Correct an Error 
Press the BACKSPACE key (in insert mode) to 
delete the character to the left of the cursor and 
move the text together. If you are in Overtype mode, 
the BACKSPACE key removes the previous charac- 
ter, but the text does not move together. 

Note: Backspacing has no effect in either Insert 
or Overtype mode if the cursor is positioned after 
a picture, address book field, today’s date field, or 
page number field. 

You can delete small amounts of text by pressing the 
DELETE key. Position the cursor before the fht  
character you want to delete, and then press 
DELETE. The character to the right of the cursor dis- 
appears, and the remaining text shifts left. 
Remove larger sections of your document by &hg 
the Edit Menu’s (F3) C 1  ear option. If you accidental- 
ly delete a section of text, you can recover it by 
using the Edit Menu’s (F3) Un-Delete option. 
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Edit Pictures in 
Your Documents 
The only way to edit a picture that is in your docu- 
ment is by moving (or copying) that picture to the 
Draw application. Follow the instructions for Cut 
and Paste on the Edit Menu (F3) to move the pic- 
ture to Draw. 

Note: You don’t have to move your picture to the 
Draw application to resize it. See the S i  ze option 
on the Picture Menu (F7) for more information. 

After the picture is in the Draw application, you can 
make any changes needed and then move (or copy) 
the changed picture back to the Text application. 

End a Page 
To force a page to end before you have typed an en- 
tire page of text (based on the File Menu’s (F2) Page 
setup settings), type .N (be sure you type a capital 
N), and press ENTIER. The line following . N will be 
the first line of the next page when you print the 
document. 

Insert a Picture 
You can insert pictures that you create using the 
Draw application into your document. The proce- 
dure is as follows: 
1. 

2. 
3. 

4. 

5. 

Follow the instructions in the Draw chapter for 
duplicating or moving a picture to another ap- 
plication. 
Exit the Draw application. 
Open the Text document in which you want to 
place the picture. 
Note: The document in which you are placing 
the picture must be in non-ASCII format. 
Move the cursor to where you want to insert the 
picture. 
Select Paste from the Edit Menu (F3). 

The picture now appears in the document. If you 
placed the picture in the middle of a paragraph, Text 
places a carriage return where you positioned the 
cursor. The picture starts on the next line, at the 
position you indicated. The remainder of the para- 
graph follows the picture, one line below it, begin- 
ning at the left margin. 

If the position you chose for the picture is not wide 
enough, reposition the cursor, and repeat the proce- 
dure. If the picture does not fit in the remaining 
space on a page, Text moves the picture to the top of 
the next page. If the picture is larger than an entire 
page, Text does not paste the picture; instead, you 
see a warning message. 

Insert Text 
When you create a document, you are in Insert 
mode. This means that anything you type is inserted 
at the cursor’s location. All text that follows the cur- 
sor moves to the right to accommodate the new text. 
You can also use the Overtype mode, which lets you 
type over existing text. (See “Overtype Text.”) 
To determine which mode you are currently using, 
open the Edit Menu (F3). If a check mark appears 
next to the I n s e r t  option, you are in Insert mode. 
Select the I n s e r t  option on the Edit Menu (F3) to 
switch between Insert and Overtype modes. 

Non-ASCII Format 
When you first create a Text document, it is in ASCII 
format (as shown at the bottom of the screen). Your 
document must be in ASCII format if you want to, 
for example, communicate with other computers 
using Telecom or transfer your DeskMate files to 
another computer. Non-ASCII format, however, lets 
you use special word-processing codes that Text 
needs to produce such things as boldface, underline, 
headers, and so on. 
To convert your document to non-ASCII format, you 
simply use one of the Text options that inserts a spe- 
cial word-processing code into the file. The program 
automatically converts the document for you. (You 
immediately see Non- A S C I  I at the bottom of the 
screen.) 
You automatically convert your document to non- 
ASCII format by: 

Selecting any option on the Text Menu (P7) 
except P1 a i  n 

Selecting any option on the Layout Menu (F4) 
Changing any of the default settings for the 
Page se tup  option on the File Menu (FZ) 
Inserting a picture from the Draw application 
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Overtype Text 
When you first access a document, you automat- 
ically begin in Insert mode, and the cursor appears 
as a blinking vertical line. You can change to Over- 
type mode by selecting Insert from the Edit Menu 
(F3). When the check mark next to Insert disap- 
pears, you are in Overtype mode, and the cursor ap- 
pears as a blinking box. You can also switch between 
Insert and Overtype mode by pressing INSERT on 
your keyboard. 
Overtype mode lets you replace a character by 
typing over it. When you type in Overtype mode, 
any existing characters are replaced. If you use the 
BACKSPACE key to correct mistakes, the previous 
character is deleted, leaving a blank space. 
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Worksheet 
Overview 
What Is It? 
DeskMate’s Worksheet application is an electronic spreadsheet or financial 
calculations tool. You can change one number and instantly see the effect 
on the entire worksheet after you press CTRL+C to calculate. 

What Can I Do with I t?  
The Worksheet application contains many practical features that will make 
it easy for you to work with simple or complex spreadsheets. For example, 
you can use Worksheet to: 

Prepare amortization schedules 

Create balance sheets or estimated loan payment schedules 
Keep track of hours you spend on different projects for your business or 
home 

Make financial plans for your clubs or organizations 

How Do I Use It? 
When you open the Worksheet application, a blank worksheet appears (as 
shown at the right). 
Each worksheet has 99 rows and columns that intersect to form cells. See 
the highlight on the screen at the right? It is located on the cell called RlCl 
(row 1, column 1). The default size for each cell is 10 characters, however, 
you can change the size of these cells at any time. Use the arrow keys to 
move the cursor from cell to cell. Or, if you’re using a mouse, point and click 
on the desired cell. 
You can scroll through a worksheet by repeatedly pressing the arrow key for 
the direction in which you want to scroll. Or, if you are using a mouse, simp- 
ly point to the appropriate arrow on the right side of the menu bar, and 
repeatedly click the button. 
As you create worksheets, you can fill cells with text, labels, numbers, or 
fonnulas (so that you can make calculations). 
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To type a block of text, (such as a title for your worksheet), highlight the 
cells where you want the text. To start typing the text, select Start text 
from the Cells Menu (F6). To finish entering the text, select End text from 
the Cells Menu (F6). 
You can use labels to identify the columns and rows of numbers for your 
worksheet. Simply move the cursor to the desired cell, and type. 

Note: You can only use numbers and/or a decimal point if they are imme- 
diately followed by alphabetic characters. 

To type numbers on a worksheet, simply move the cursor to the desired cell 
and type the number. 
Use the Formul a option on the Cells Menu (F6) to assign a formula for cal- 
culation to a specific cell (for example, to add two or more cell values or cal- 
culate the square root of a value). Be sure to see the “Other Worksheet 
Information’’ section for a description of the formulas available in 
DeskMate’s Worksheet. 
You can save and print your worksheets using the Save and Pri n t  options 
on the File Menu (F2). 
To learn the basics about using Worksheet, see the “Worksheet” article in 
the Getting Started magazine. Then, when you’re familiar with Worksheet, 
this chapter will provide you with a quick way to answer specific questions. 
You can look up the step-by-step instructions for each menu option. If you 
want to know which options to use to perform a specific task, check the 
‘Worksheet Tasks’’ section at the end of this chapter. 
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Menu Options 
Worksheet has five menus that list the options you 
can use with the application. The key that you press 
to see each menu appears beside the menu name. 
(For example, press the F2 key to see the File 
Menu.) A shaded option on a menu means that the 
option is not available. Some options have ac- 
celerator keys listed next to them. Use these keys to 
perform tasks without pulling down a menu. For ex- 
ample, when you want to create a formula in 
Worksheet, you can press CTRL+F to select the 
Formul a option on the Cells Menu (F6). 
This section explains each Worksheet menu on the 
menu bar and also contains step-by-step instructions 
on how to use each option on the menus. 

File Menu 
The File Menu (F2) options let you work with your 
DeskMate files. For example, you can create a new 
Worksheet file, open existing files, print a 
Worksheet file, or run another application or pro- 
gram. 

Weld 
Open.. . 
&we 
Saw as. . .  

Page setup.. . 
Pr in t . .  . 
Exit Esc 
Run. I . 

Merge.. . 

I fibout.. . 
New 
Creates a new Worksheet file without returning to 
the desktop. 
1. Select New from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, a new, blank 
worksheet appears. 

2. Select YES, NO, or CANCEL. 
If the worksheet is untitled, Save as : appears. 
Continue with Step 3. 
If the worksheet is titled, a new, blank worksheet 
appears. 

eight or fewer characters. 
Worksheet automatically adds the extension .wks 
to the filename, unless you specify otherwise. 

3. At the Save as : prompt, type a filename using 

4. Select SAVE to complete the task. 
A new, untitled worksheet appears. 

Open 
Opens an existing worksheet from within a 
worksheet or a worksheet in another drive or direc- 
tory without returning to the desktop. 
1, Select Open from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
Step 4. 

2. Select YES, NO, or CANCEL. 

If the worksheet is untitled, Save as : appears. 
Continue with Step 3. 
If your worksheet has a title, continue with Step 
4. 

3. At the Save as : prompt, type a filename using 
eight or fewer characters. 
Worksheet automatically adds the extension .wks, 
unless you specify otherwise. 

4. Select SAVE to complete the task. 
A dialog box appears, listing all the worksheets 
you can open in the current directory. In addi- 
tion, this box lists all available subdirectories and 
drives. (The symbol [..I indicates the parent direc- 
tory.) 

5.  Highlight the file, drive, or directory you want 
to open. 
If the worksheet you want to open is in another 
drive or directory, highlight the appropriate drive 
or directory. 
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6.  Select OK. 
If you chose a specific file, the worksheet is dis- 
played on the screen. 
If you chose another drive or directory, the direc- 
tories and files in the highlighted drive or direc- 
tory you chose are displayed. Other available 
drives appear in the list box. Continue with Step 
7. 

7. Repeat Steps 5 and 6 until the list box displays 
the name of the file you want to open. 

8. Highlight the file that you want to open. 
9. Select OK to complete the task. 

The worksheet you requested appears. 
Note: When you open a file from a different 
drive or directory, subsequent “open” operations 
will display a list of worksheet files, drives, and 
directories from the directory in which the 
opened file resides. 

Save 
Stores changes you have made in an existing 
worksheet without exiting to the desktop. It is a 
good idea to store changes periodically to help 
prevent the loss of information. (If you have not 
named your worksheet, use the Save as option.) 

Worksheet stores the changes you have made on the 
disk, and the file remains on the screen. 

Save as 
Renames an existing file or stores a new file without 
exiting the file. 

Select Save from the File Menu (FZ). 

1. Select Save as from the File Menu (F2). 

2. At the Save as: prompt, type the name you 
A dialog box appears. 

want to give the worksheet, using eight charac- 
ters or fewer. 
Worksheet automatically adds the extension .wks, 
unless you specify otherwise. 

3. Select SAVE to complete the task. 
The Worksheet file and name are stored on the disk, 
and the worksheet remains on the screen. 

Merge 
Combines another worksheet with the current file. 
1. Move the cursor to the position where you want 

the other worksheet to begin. If there is data in 
the cells immediately following the cursor, the 
data will be overwritten. 

2. Select Merge from the File Menu (PZ). 
A dialog box appears, listing all the worksheets 
you can open in the current directory. In addi- 
tion, this box lists all available subdirectories and 
drives. (The symbol [..I indicates the parent direc- 
tory.) 

3. Highlight the worksheet that you want to 
merge, or highlight the drive or directory con- 
taining the worksheet you want to merge. 

If you chose a specific worksheet, it is inserted at 
the cursor location. 
If you chose another drive or directory, the direc- 
tories and worksheets in the highlighted drive or 
directory you chose are displayed. Other avail- 
able drives also appear in the list box. Continue 
with Step 5. 

5. Repeat Steps 3 and 4 until the list box displays 
the name of the worksheet you want to merge. 

6.  Highlight the worksheet you want to merge. 
7.  Select OK to complete the task. 

The worksheet is inserted at the cursor location. 
Because you have inserted additional information 
into your worksheet, you might need to change your 
formulas so that the correct cells are referenced. 

4. Select O K .  

Note: When you merge a worksheet, data may 
be overwritten if there is data in the cells immedi- 
ately following the cursor position. 

Page setup 
Lets you design the page layout for your printed 
worksheet. 

1. Select Page se tup  from the File Menu (FZ). 
A dialog box appears. Some of the options might 
not be available, depending on the type of printer 
you are using. Additional information about each 
option appears after the steps. 

2. Change the desired options. 
3. Select OK to complete the task. 
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Paper size. Choose the size paper you are using. If 
you choose Other, be sure to indicate the correct 
width and height in the appropriate fields. 
Left margin. Type the number of spaces you want 
for the left margin. 
Line width. Type the total number of characters 
you want to print on one line. 
For example, if you are using 8R-inch paper and a 
ten-characters-per-inch font (such as Courier), the 
total line length is 85 character. If you set a left mar- 
gin of lb9 inches (15 spaces) and you want a right 
margin of 1 inch (10 spaces), subtract the left and 
right margin amounts from the total line length (85- 
25=60). The resulting total of 60 spaces (or 6 in- 
ches) is the printed line width. Be sure that the sum 
for the Left margin and Printed line w i d t h  settings 
does not exceed the width of your paper. 
Lines per page. Type the total number of lines on 
each sheet of paper. For example, 8%- by 11-inch 
paper contains 66 lines in portrait mode when 
figured at 6 lines per vertical inch. 
Double space. Choose this option to print the 
worksheet double spaced instead of single spaced. 
(If you choose double space, the program inserts a 
blank line between every line.) 
Pause between pages. If you are not using con- 
tinuous form paper, choose this option so that you 
can insert a new sheet of paper after each page 

Print sideways. Choose this box to print sideways 
on your paper. When printing in this format, Desk- 
Mate only prints ten characters per inch. 
CENTER. By selecting this button, you can center 
your document on the page both vertically and 
horizontally. Enter the Left margin, Line w i d t h ,  and 
L i  nes per page settings as accurately as you can. 
Then, select the CENTER button, and DeskMate will 
automatically adjust the Line w i d t h  and Lines per 
page settings so that the body of the worksheet is 
centered on the paper (based on your current 
printer selection). 

prints. 

Print 
Prints the currently displayed worksheet to the 
screen, on paper, or to another file. 

Note: If you are printing your worksheet on 
paper and the worksheet is wider than 130 
columns when using a laser printer, 80 columns 
when using a daisy wheel printer with 10-point 
type (or longer than 66 rows), you will need to 
print the worksheet in separate sections. High- 
light each section to print it. 
To print a portion of your worksheet, highlight 
the section of the worksheet you want to prht, 
and then proceed with these instructions. To 
print the entire worksheet, select Select a1 1 
from the Edit Menu (F3) before printing. 

Be sure to use the Pr i n te  r option on the Setup 
Accessory's Options Menu to tell DeskMate the type 
of printer you are using. Also, be sure to set up your 
page layout using the File Menu's (F2) Page setup 
option. 

1. Select Pri n t from the File Menu (F2). 

2. At the Print t o :  prompt, select the Screen, 
A dialog box appears. 

Printer, or File button. 
The Screen button lets you print the worksheet to 
the screen so that you can see how it will look on 
the page. 
The Pri nter button lets you print the worksheet 
on paper. 
The F i  1 e button lets you print the worksheet to 
another file. Printing to a file stores the file on 
disk, using the name you give plus the extension. 
prn. You can then use the MS-DOS Print com- 
mand to print the file from another computer 
that is not running DeskMate. Or, you might send 
the file to another computer, using the Telecom 
application. 
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Note:  The printer used to print the file 
from MS-DOS must be the same type 
you are using with DeskMate (the one 
you assigned with the Printer option 
on the Setup Accessory‘s Options 
Menu). If ou want to transmit the file 
using Deshate’s Telecom application, 
choose ASCI I as the printer type. 

3. Follow the appropriate instructions below for 
the button you chose in Step 2. 

If you chose the Screen button: 
a. 

b. 

Select OK to complete the task. 
The worksheet appears on the screen. 
To view more of the worksheet that ap- 
pears on the screen, select the Select a1 1 
option on the Edit Menu (F3) before you 
print to the screen. You can scroll through 
it using the arrow keys or select the Next 
page option on the Options Menu (F2) to 
view the next page. 
When you finish viewing the worksheet, 
select E x i t  from the Options Menu (F2). 
The normal screen display appears. 

If you chose the Printer button: 
Select OK to begin printing. 
The worksheet begins to print, and a dialog 
box appears, containing information about 
the print operation. You can select CANCEL 
at any time to stop the operation. 

Note:  If you chose the Pause between 
pages option when you formatted the 
page layout, the printer stops to let you 
change the sheets of paper when each 
page finishes printing. A dialog box ap- 
pears, asking whether you want to 
reprint the current page. 
To print the next age, insert a new 
sheet of paper anaselect NO. If you 
want to reprint the same page, insert a 
new sheet of paper and select YES. 
Select CANCEL to stop the print opera- 
tion. 
When you finish printing, select NO at 
the Reprint current page? prompt. 

a. At the Fi  1 ename : prompt, type the name 
you want to give the “printed” file, using 
eight or fewer characters. Worksheet auto- 
matically assigns the extension . p r ,  unless 
specified otherwise. 

If you chose the Fi 1 e button: 

Note:  Be sure to type a complete path- 
name of up to 64 characters if you 
want to save the file on a different 
drive or in a different directory. 

b. Select OK to complete the task. 
Note that when you return to the desktop, 
you will not see the .prn file (if you used 
that extension) listed in any application’s 
list box. It does, however, reside on disk. 
You can view it and other files in the direc- 
tory from the desktop View Menu (F5). 

Exit 
Exits Worksheet and returns you to the desktop. 
1. 

2. 

3. 

4. 

Select E x i t  from the File Menu (F2). 
If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, you return to the 
desktop. 
Select YES, NO, or CANCEL. 
If the worksheet is untitled, Save as : appears. 
Continue with Step 3. 
If the worksheet is titled, you return to the 
desktop. 
At the Save as : prompt, type a filename using 
eight or fewer characters. 
Worksheet automatically adds the extension .wks, 
unless you specify otherwise. 
Select SAVE to complete the task. 

The desktop screen is displayed. 

Run 
Runs another DeskMate application file or runs 
another software package without returning to the 
desktop. 
1. Select Run from the File Menu (F2). 

If you made changes to the current file, Save 
changes? appears. Continue with Step 2. 
If you have not made changes, continue with 
Step 5. 

2. Select YES, NO, or CANCEL.  
If the worksheet is untitled, Save as : appears. 
Continue with Step 3. 
If the worksheet is titled, continue with Step 5. 
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3. At the Save as: prompt, type a filename using 
eight or fewer characters. 
Worksheet automatically adds the extension .wks, 
unless you specify otherwise. 

4. Select SAVE to complete the task. 
A dialog box appears. 

5. At the Program: prompt, type the name of the 
application or program you want to run. 
If the program is not a DeskMate application 
(does not have the extension.pdm), include the 
extension when you type the name. Also, if the 
file is in a directory other than the current direc- 
tory, type a full pathname, including the drive 
and directory. 

6. At the Data f i 1 e : prompt, either type the name 
of the data file you want to use with your 
chosen application (or program) or leave the 
prompt blank. 
If you leave the prompt blank, DeskMate runs the 
specified application or program without opening 
a corresponding data file. 

7. Select OK to complete the task. 
DeskMate might ask you to insert the diskette con- 
taining the application or program you specified. In- 
sert the appropriate diskette, and select O K  to run 
the program normally. 
When you finish using the program, exit it. Desk- 
Mate might ask you to insert the diskette that con- 
tains the file desktop.pdm. After you insert the 
diskette and select OK, you return to the desktop. 

About 
Displays the program name, version number, and 
the files DeskMate uses to run the program. 
1. Select About from the File Menu (F2). 

2. Select CANCEL to remove the box from the 
A dialog box appears. 

screen. 

Edit Menu 
The Edit Menu (F3) options let you edit your 
Worksheet files. For example, you can move or copy 
information in a worksheet and place it in another 
worksheet. 

1 cut ShiFttIlel I 

cut 
Removes information within a worksheet. 

Note: Because DeskMate keeps Worksheet infor- 
mation in a special format, you must first print 
the worksheet information to an ASCII file if you 
plan to insert it in another application. You can 
then move the file to the Text application. From 
Text, you can copy the information to another 
Text file or another application. For detailed in- 
structions, see the “Other Worksheet Informa- 
tion” section. 

1. Highlight the information you want to remove. 
2. Select C u t  from the Edit Menu (F3). 

Worksheet removes the highlighted information and 
places it on the Clipboard. 
To place the Clipboard information into another 
worksheet, or at another location in the same 
worksheet, use the Edit Menu’s (F3) Paste option. 

COPY 
Copies information in a worksheet to the Clipboard. 

Note: Because DeskMate keeps Worksheet infor- 
mation in a special format, you must first print 
the worksheet information to an ASCII file if you 
plan to copy it to another application. You can 
then move the file to the Text application. From 
Text, you can copy the information to another 
Text file or another application. For detailed in- 
structions, see the “Other Worksheet Informa- 
tion” section. 
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1. Highlight the information you want to copy. 
2. Select Copy from the Edit Menu (P3). 

Worksheet copies the highlighted information to the 
Clipboard. 
To place copied information into another worksheet, 
or at another location in the same worksheet, use 
the Edit Menu’s (P3) Paste option. 

Paste 
Inserts cut or copied information (Clipboard infor- 
mation) at the cusor location. 

Note: If you are inserting information into a dif- 
ferent worksheet, you must first open the 
worksheet. See the File Menu’s (€72) Run  option 
for instructions. 

the information. 
1. Move the cursor to where you want to place 

2. Select Paste from the Edit Menu (P3). 
Worksheet inserts the Clipboard information at the 
CUrSOr location. 

C l e w  
Deletes Worksheet information. 
1. If you want to delete a portion of your 

worksheet, highlight the cell or cells that con- 
tain the information you want to delete. 
or 
If you want to delete an entire worksheet, select 
Select a1 1 from the Edit Menu (€73). The pro- 
gram highlights all the information in the 
worksheet. 

2. Select Clear from the Edit Menu (F3). 
The highlighted worksheet information is deleted. 

Select all 
Highlights the entire worksheet. 

Select Select a1 1 from the Edit Menu (P3). 

Pad Menu 
The Pad Menu (P4) options let you change the infor- 
mation on your worksheet and perform calculations 
using formulas. For example, you can change the 
width of one or more columns, insert a column, and 
calculate an entire worksheet. 

Colunn width,. . 
Insert colunn 
Delete colunn 
Insert rou 
Delete rou 
Calculate CtrltC 

Column width 
Changes the width of one or more columns to any 
number from 3 to 77. 
If you wish to avoid truncation of sums, particularly 
decimal sums, be sure that the column width is wide 
enough for cells in the column containing a formula 
to accommodate the largest potential result. Some- 
times a row of asterisks (*) will be placed in a cell if 
the result is too large. 
If you are changing the width of all the columns, 
skip the first step. 
1. Move the cursor to the column whose width you 

2. Select Column w i d t h  from the Pad Menu (P4). 

3. Choose Current to change the width of only the 

want to change. 

A dialog box appears. 

highlighted column or A 1  1 to change the width 
of all the columns. 

width. 
4. At the W i d t  h : prompt, type the new column 

Note: Be sure that the column is at 
least two characters wider than the 
longest number used in the calculation. 

5. Select O K  to complete the task. 
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Insert column 
Adds a column between existing columns. 
1. Position the cursor immediately to the right of 

2. Select Insert column from the Pad Menu (F4). 
where you want to add the new column. 

Worksheet adds a new column at the cursor posi- 
tion, and moves the existing columns to the right. 
If the cell references for your formulas are not ab- 
solute (preceded by a #), you might need to update 
all the formulas with references to cells in the new 
column and to the right of the new column. 

Delete column 
Removes a column from your worksheet. 
1. Place the cursor in the column you want to 

2. Select Delete column from the Pad Menu (F4).  

The contents of the specified column are deleted, 
and the contents of subsequent columns are shifted 
left one column. 
If the cell references for your formulas are not ab- 
solute (preceded by a #), you might need to update 
all the formulas with references to cells in and to the 
right of the deleted column. 

I n s e r t  row 
Adds a row to your worksheet. 

delete. 

1. Position the cursor immediately below where 

2. Select Insert row from the Pad Menu (F4). 

Worksheet adds a new row at the cursor position, 
and moves the existing rows down. 
If the cell references for your formulas are not ab- 
solute (preceded by a #), you might need to update 
the formulas with references to cells in the new row 
and below the new row. 

Delete row 
Removes a row from your worksheet. 

you want to add the new row. 

1. Place the cursor in the row you want to delete. 
2. Select Delete row from the Pad Menu (F4). 

The contents of the specified row are deleted, and 
the contents of subsequent rows are shifted up one 
TOW. 

If the cell references for your formulas are not ab- 
solute (preceded by a #), you might need to update 
the formulas with references to cells in and below 
the deleted row. 

Calculate 

Computes your worksheet’s numbers, using the for- 
mula(s) you have entered. You must have at least 
one formula entered in a cell to make a calculation. 
The calculation procedure begins at Row 1, Column 
1 and moves to the right and down until the entire 
worksheet has been scanned. This is important to 
remember when using forward-referencing for- 
mulas. All exponentiation is calculated first. Then, 
all multiplication/division is calculated, and then ad- 
dition/subtraction is calculated. 
Worksheet takes the result of any formula and uses 
it as a number. See “Formulas” in the “Other 
Worksheet Information” section. 

Select Calculate from the Pad Menu (F4). 

Search Menu 
The Search Menu (F5) options can help you locate 
specific labels, numbers, and cells that exist in your 
worksheet. 

Find label 
Lets you find a specific label within a worksheet. 
1. Select Find 1 abel from the Search Menu (PS). 

A dialog box appears. 
2. At the Label : prompt, type the label (up to 18 

characters) you want to find. 
3. Select OK to begin the search. 

If the label you specified is found, it is highlighted. 
If the label is not found on the worksheet, you see 
the message S t r i n g  Not Found. Select OK to remove 
the message from the screen. 
To find subsequent occurrences of the label, ll~e the 
Search Menu’s (F5) F i  nd next Option. 

153 



DesWate User's Reference 

Find number 
Lets you find a specific number in your worksheet. 
1. Select Find number from the Search Menu (F5). 

2. At,the Number: prompt, type the number (up 

3. Select OK to begin the search. 

A dialog box appears. 

to 18 characters) you want to find. 

If the number you specified is found, it is high- 
lighted. If the number is not found on the 
worksheet, you see the message Number N o t  Found.  
Select OK to remove the message from the screen. 
To find subsequent Occurrences of the number, use 
the Search Menu's (F5) Fi nd next option. 

Find cell 
Lets you find a specific cell in your worksheet. 
1. Select Find cell from the Search Menu (F5). 

2. At the Row: prompt, type the row number for 

3. At the Col umn : prompt, type the column num- 

4. Select OK to complete the task. 

A dialog box appears. 

the cell you want to find. 

ber for the cell you want to find. 

The cursor moves to the cell you specified. 

pind next 
Finds subsequent occurrences of a label or number 
(after you have used the Fi nd  option). 

Select F i  nd next from the Search Menu (F5). 
The next occurrence of the label or number is high- 
lighted. If there are no other occurrences, you see 
the S t r i n g  Not Found or Number Not Found message. 
Select OK to remove the message from the screen. 

Cells Menu 
The Cells Menu (F6) options let you change, create, 
and remove elements within the cells of your 
worksheet. 

Fornat. . . 
Input..  , 

1 Formula.. . CtrltF 
' Start t ex t  CLrltT 

1 st$ ?,ex!, [:tPI ild 

Format 
Changes a cell's alignment, type, or number of 
decimal places. 

change. 

A dialog box appears. 

1. Highlight the cells whose format you want to 

2. Select Format from the Cells Menu (F6). 

3. Choose one of the A 1  i g n  buttons: L e f t  or R i g h t .  
Note: When you start a new 
worksheet, cells containing labels are in- 
itially aligned to the left and those con- 
taining numerical data are initially 
aligned to the right. If you align the con- 
tents of a cell formatted for a decimal 
and enter a number with less than the 
maximum number of allotted decimal 
places, Worksheet inserts zeroes in ac- 
cordance with the number of decimal 
places formatted for that cell. 

4. Choose one of the Type buttons: Decimal, 
Integer, or Currency. 

Note: When you start a new 
worksheet, all cells are formatted for 
currency (numbers treated as dollars 
and cents). 
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5. Ifyouchose Decima1,attheDigits: prompt, 
type the number of decimal digits (up to seven) 
you want to appear to the right of the decimal 
point. 

Note:  If you change to a smaller num- 
ber of displayed decimal digits, the 
present contents of the cell will be trun- 
cated. The formula cell should be for- 
matted with at least as many decimal 
places as are in the largest number used 
111 the calculation to avoid truncation 
and rounding off. 

6. Select OK to complete the task. 

Input 
Causes the application to pause and ask you to input 
the contents of a cell each time the worksheet is cal- 
culated. If the input cells are referenced in a for- 
mula, this lets you change the cell’s content before 
calculation proceeds. 
1. Select I n p u t  from the Cells Menu (F6). 

A dialog box appears. 
2. At the Field Name: prompt, type a phrase to 

identify the cell. 
3. At the F i  el d Val ue: prompt, type the numerical 

value YOU think you will use most often in the 
field, or leave the box blank. 

4. Select OK to complete this task. 
When you calculate your worksheet, the formulas 
are executed and the results are displayed. 

Formula 
Lets you change or create a formula on your 
worksheet. 
1. Move the cursor to the cell that contains the for- 

mula you want to change or to the cell(s) where 
you want to place a new formula. 

2. Select Formul a from the Cells Menu (F6). 
A dialog box appears. 

Note:  The arrow keys in the dialog box let 
you scroll around in the worksheet to view 
any part of it. 

If you are changing or deleting a formula, the 
dialog box contains the formula for the high- 
lighted cell. 
If you are creating a formula, there is an edit field 
in the dialog box for entering the formula and a 
list of the operators and functions you can use. 

3. If you are creating or changing a formula, tvpe 
the new formula. To delete a formula, position 
the cursor on the cells containing the formula, 
and press DELETE. 

For an explanation of the types of cell references, 
operators, and functions, see the “Formulas” box 
at the end of this section. 

4. Select OK to complete the task. 
When you highlight a cell that contains a formula, 
the formula is shown at the bottom of the screen. 

Start text 
Lets you change a block of text or enter a new block 
of text. 

I. Move the cursor to the text block you want to 
change, or highlight the entire area where you 
want to place new text. 

A cursor appears in the highlighted area. 

desired text using BACKSPACE and then type 
the new text. If you are entering a block of text, 
simply type the new text. 
You have access to all the editing features avail- 
able with the Text application. For a list of these 
features, see the “Text” chapter in this manual. 
Note: If you entered a block of text, you must 
cancel the Start text option before you can con- 
tinue using your worksheet. To cancel the option, 
use the End text option. 

2. Select Start text from the Cells Menu (P6). 

3. If you are changing a block of text, delete the 

End text 
Lets you cancel the Start text option. 

Select End text from the Cells Menu (F6). 
If you entered a block of text, the new text appears 
on your worksheet. You can use the Edit Menu’s 
(F3) Cut, Copy, and Paste options with the text 
block. If you use these options, you must highlight 
the whole text block. 
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Worksheet 
Tasks 
Add a Column Between Columns 

Pad F 4  (Insert Column) 
Add a Row Between Rows 

Pad F 4  (Insert row) 
Calculate a Worksheet 

Pad F 4  (Cal cul ate) 
Change a Block of Text 

CellsF6 (Start text) 
Cells P6 (End text) 

Cells F6 (Formul a) 

PadF4 (Column width) 

Cells F6 (Formula) 

File F2 (New) 

Edit F3 (C1 ear) 

Edit F3 (C1 ear) 

Change a Formula 

Change the Width of One or More Columns 

Create a Formula 

Create a New Worksheet from Within a Worksheet 

Delete an Entire Worksheet 

Delete Part of a Worksheet 

Display a PrograwApplication Name and Version 
Number 

Duplicate Information in Another Application 
File F2 (About) 

Edit F3 (Copy) 
Edit F3 (Paste) 

Edit F3 (Copy) 
Edit F3 (Paste) 

Edit F3 (Copy) 
Edit F3 (Paste) 

Cells F6 (Start text) 
Cells F6 (End text) 

File F2 (Exit) 

Search F5 (Find cell)  

SearchF5 (Find label) 
Search F5 (Find next) 

Duplicate Information in Another Worksheet 

Duplicate Information Within the Same Worksheet 

Enter a Block of Text 

Exit Worksheet 

Find a Cell 

Find a Label 

Find a Number 
Search F5 (F ind  number) 
Search F5 (Find next) 

Format a Page Layout 
File F2 (Page setup) 

Format Cells 
Cells F6 (Format) 

Highlight an Entire Worksheet 
Edit F3 (Select all)  

Input Cell Contents During Calculation 
Cells F6 (Input) 

Insert Another Worksheet into the Worksheet on the 
Screen 

Move Information to Another Application 
File F 2  (Merge) 

Edit F3 (Cut) 
Edit F3 (Paste) 

Edit F3 (Cut) 
Edit F3 (Paste) 

Edit F3 (Cut) 
Edit F3 (Paste) 

Move Information to Another Worksheet 

Move Information Within the Same Worksheet 

Open an Existing Worksheet from Within a 
Worksheet 

Open an Existing Worksheet in Another Drive or 
Directory 

File F2 (Open) 
Print a Worksheet 

File F 2  (Print) 
Remove a Block of Text 

Edit F3 (C1 ear) 
Remove a Column 

Pad F4 (Delete Column) 
Remove a Formula 

Edit F3 (Clear) 
Remove a Row 

Pad F 4  (Delete row) 
Rename the Worksheet on the Screen 

File F2 (Save as) 
Run Another Application 

File F2 (Run) 
Store Updates to an Existing Worksheet 

File F2 (Save) 
Store Updates to a New Worksheet 

File F2 (Save as) 

File F 2  (Open) 
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Other 
Worksheet 
Information 
ASCII Format 
Because DeskMate keeps Worksheet information in a 
special format, the procedure for copying worksheet 
information and placing it in another application is 
more involved than simply duplicating the informa- 
tion within the same worksheet or to another 
worksheet. 
If you want to insert your worksheet information in 
another application, you must first print the informa- 
tion to an ASCII file. You can then move the file to 
the Text application. From Text, you can copy the in- 
formation to another Text file or another application. 

Note: The instructions that follow tell you how 
to copy a section of a worksheet. To copy an en- 
tire worksheet, simply select Sel ect a1 1 from the 
Edit Menu (F3) instead of highlighting a portion 
of the worksheet. 

To print the information to an ASCII file: 
1. Select Setup from the Accessory Menu (F10). 

The Setup screen appears. 
2. 

3. 
4. 
5. 

6. 

7. 

8. 

9. 

10. 

Select Printer from the Options Menu (F2). 
A dialog box appears, listing the available 
printers. 
Highlight ASCII Printer (Text only). 
Select 0 K . 
Select Exi t from the Options Menu (F2). 
Your worksheet returns to the screen. 
Highlight the section of the worksheet you want 
to copy. 
Select Print from the File Menu (P2). 
A dialog box appears. 
At the Pri n t  to :  prompt, choose the Fi 1 e button. 
At the Fi  1 ename: prompt, type a filename for 
your ASCII file, using eight characters or fewer. 
(You must include the file extension .doc.) 
Select OK. 

11. 

12. 

13. 

Select Run  from the File Menu (F2). 
If you have made changes to the current 
worksheet, Save Changes? appears. Continue with 
Step 12. 
If you have not made changes, continue with 
Step 15. 
Select YES, NO, or CANCEL. 
If the worksheet is untitled, Save as : appears. 
Continue with Step 13. 
If the worksheet is titled, continue with Step 15. 
At the Save as : prompt, type a filename of eight 
characters or fewer. Worksheet automatically 
adds the extension .wks, unless you specify 
otherwise. 

14. Select SAVE to complete this part of the task. 

15. At the Program: prompt, type Text. 
16. At the Data f i l e :  prompt, type the filename 

you used to print the ASCII file. 
17. Select OK to complete the task. 
The Text application appears with the ASCII file on 
the screen. Format the file if necessary. 

A dialog box appears. 

Change a Number or 
a Label 
You can change the label on your worksheet by simp- 
ly moving the cursor to the cell that contains the 
label or number you want to change. Then, type the 
new label or number. 

Correct an Error 
If you make an error as you are typing information 
in a cell, you can press either BACKSPACE or 
DELETE to make corrections. Pressing BACK- 
SPACE erases the character immediately preceding 
the cursor. Pressing DELETE erases all the informa- 
tion in a cell, including the cell's format information. 
The cell is then automatically reformatted to curren- 
CY- 

You can also use the Edit Menu's (F3) C1 ear option 
to erase highlighted information in a cell. 
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Remove a Block of Text 
key. 
You can remove a block of text using the DELETE 

1. Highlight the entire text block that you want to 

2. Press DELETE. 
delete. 

The block of text is deleted from your worksheet. 
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Formulas 
The formulas you can use in your worksheet provide you with a great deal of calculating power. The following 
information describes the different types of formulas and how to use them. 
Cell References 
Cell references are the cells referred to in a formula and whose contents are used by the formula. 

Absolute. Placing a pound sign (#) before a cell reference in a formula defines that cell reference as an 
absolute reference. This type of cell reference lets you use the value in a given cell in calculations, no 
matter where you might move the cell on the worksheet. 
Worksheet updates absolute cell references in formulas whenever the formula and the referenced cells 
are relocated simultaneously. 

Worksheet updates absolute cell references only when you move the value being pointed to by adding 
or deleting columns and/or rows, or merging another worksheet into the one on the screen. If you 
use the Edit Menu to move or copy the value being pointed to by the absolute cell reference and paste 
the value elsewhere in the worksheet, the absolute cell reference is not updated. 

Circular. A circular cell reference is a reference to a cell that refers (through one or more cells) back to 
the current cell. Use circular cell references cautiously because they can give unexpected results. 
Forward. A forward cell reference is a reference to a cell that appears later in the worksheet. 
Although Worksheet allows forward cell references, you see a warning message: 

The worksheet calculation procedure begins at RlCl and moves to the right and down until the entire 
worksheet has been scanned. This is important to remember when using forward referencing, because 
forward references mix the results of current calculations with those of previous calculations. 
Relative. Worsheet uses a relative cell reference unless you specify an absolute cell reference. If you 
move or copy a formula, a relative cell reference will regard a cell in the same relative position as the 
cell containing the formula, instead of the orginally specified cell. 
Self. A self reference is a reference to the same cell. Worksheet does not allow you to write a formula 
that contains a self reference. If you try, an error message appears on the screen, and *ERROR is dis- 
played in the cell containing the formula. 
However, you might encounter a formula that contains a self reference as a result of copying or moving 
a formula that contains an absolute cell reference. If you move the cursor to a cell that contains a self 
reference after pasting or merging, the screen displays an error message in the faulty cell. You can then 
edit the formula to correct the error by using the Formul a option on the Cells Menu (F6). 

Forward reference a t  Cell rowx colx 

Operators (with Sample Formulas) 
The operators you can use in your worksheet indicate a change in a quantity is to be performed. 
+ (Rl+R2) Adds the two cells in Row 1 and Row 2 of the current column. 
- (#C3)-(#RlC4) Subtracts the value of cell R1C4 from the value of the cell in Column 3 of the 

current row. 
* #Cl*#C2 Multiples two cells in the current row. 
/ (RlC2)/2 Divides the value of cell R1C2 by 2. 
! #C6R3!3 Calculates the power (cube-"!3") of the value of cell R3C6. 
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ABS 
ATN 

AVG 

CMT 

cos 

EXP 
INT 
LOG 

MAX 

MIN 

RMT 

SGN 

SIN 

SQR 

SUM 

TAN 

ABS(#R2C3) 
ATN(#R3CS) 

AVG(#C 1) 

CMT(#R4C3) 

COS(#R3C5) 

EXF'(#R4C3) 
INT( #R4C2) 
LOG(#R2C4) 

MAX(#C4) 

MIN(#Rl) 

RMT(#R4C3) 

SGN (#R3C4) 

SIN( #R2C 1) 

SQR(#RSCl) 

SUM(# R5) 

TAN(#R2C3) 

Functions 
Displays the absolute value of the cell in R2C3. 
Displays the arctangent of the value of cell R3C5 - the angle that has 
its tangent equal to the value of cell R3C5. (The result is in radians. 
For a result in degrees, use ATN ((#R3C5)*57.29578).) 
Adds the values in the current row, from Column 1 up to the current cell, 
and divides by the number of cells added. 
Figures a cumulative total for Column 3, starting with Row 4 and ending 
with the current row.* 
Displays the cosine of the value of cell R3C5. (Use COS ((#R3C5)*.01745329) 
if the value in cell R3C5 is in degrees rather than radians.) 
Displays e raised to the power of cell R4C3 (Naperain, natural, or exponential). 
Displays the truncated (Integer) value of cell R4C2. 
Displays the logarithm at the base ten of the value in cell R2C4. Log of zero 
or a negative number produces an error message after calculation. 
Shows the maximum value of the current row, starting with Column 4 and 
ending with the preceding column. 
Shows the minimum value of the current column, starting with Row 1 and 
ending with the preceding row. 
Gives a cumulative total for Row 4, starting with Column 3 and ending with 
the current column.* 
Displays the sign of the value in cell R3C4. The sign is 1.00 if the augment 
is positive, -1.00 if the augment is negative, and 0 if the augment is zero. 
Displays the sine for the value ia cell #R2C1. (Use SIN((#R2C1)*.01745329) 
if the value in cell R2C1 is in degrees rather than radians.) 
Displays the square root of the value in cell R5C1. SQR of a negative 
number produces an * E R R O R  message after calculation. 
Displays the sum of the values in the current column, starting with Row 5 
and ending with the current row. 
Shows the tangent of the value in cell R2C3. (Use TAN((#RZC3)*.01745329) 
if the value in cell R2C3 is in degrees rather than radians.) 

*These formulae should not be placed in the same column as the column currently being totalled. 
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absolute. In Worksheet, a cell reference with a 
pound sign (#) before it. An absolute reference will 
not be adjusted when copied. 
accelerator. A key or key sequence that enables 
you either to activate a dialog box without moving 
the cursor to a specific button or to choose a menu 
option without actually pulling down the menu. 
accessory. A tool that you can use at any time 
during a DeskMate session. The DeskMate acces- 
sories, which appear on the Accessory Menu (FlO), 
are Setup, Spell Checker, Calculator, Phone List, 
Corkboard, Month, Clipboard, Alarm, and Task 
Switch. 
address. In Worksheet, the location of an in- 
dividual cell. For example, the address R4 C5 
denotes the cell at the intersection of Row 4 and 
Column 5. In Address Book, all the information 
about one person in the book. 
address list. In Address Book, a logical grouping 
of addresses, for example, a grouping for all the 
members of a particular club. 
application. A program you can run using Desk- 
Mate. 
application list box. A desktop list box that 
provides access to a single application, such as Text. 
You can use the Desktop Menu’s D i  s p l  ay  option to 
display any application list box not already on the 
desktop. See also PROGRAMS list box. 
ASCII. An abbreviation for American Standard Code 
for Information Interchange, a standard code of eight- 
bit strings used in many computers to represent 
various alphabetic and numeric characters, punctua- 
tion symbols, and control codes. In Telecom, a 
protocol for data transfer. 
ASCII filter. A communication parameter in 
Telecom that lets you remove all the characters 
above 80 (hexadecimal) and control characters 
below 20 (hexadecimal). 
autolog file. A file in Telecom containing a se- 
quence of commands that, together, automatically 
log you onto an information service or another com- 
puter communications system. 

baud rate. The speed (in bits per second) at which 
data is transmitted from one computer to another. 
bit. An abbreviation for binary digit. In Telecom, a 
single information character (either 0 or 1). 
body section. In Form Setup, the part of a report 
layout that contains the fields to be included in the 
report. 
break sequence. In Telecom, a signal to the host 
computer that you are getting ready to send data. 
buffer. An area of your computer’s memory 
reserved for holding transmitted data you choose to 
capture during a Telecom session. 
byte. The basic unit of information for a computer. 
For example, a byte can contain the information to 
produce a single character on the monitor screen. 
carriage return. A code that returns the cursor or 
print head to the left margin. 
cell. In Worksheet, the intersection of a column and 
a row. 
cell reference. A cell in a worksheet that is 
referred to in a formula and whose contents are 
used by the formula. 
character slot. In Form Setup, a small rectangle 
denoting the space to be occupied by one character 
in a record or report format field. 
click. To quickly press and release the button on a 
mouse. 
clipboard. The area in which DeskMate temporari- 
ly stores information you are copying or moving. 
clock speed. The rate at which pulses are emitted 
from a clock. In a computer, the clock speed deter- 
mines the rate at which logical or arithmetic func- 
tions are performed and/or processed. 
column. One of two or more vertical sections Bp- 
pearing side by side. 
command screen. The Telecom screen on which 
you access menus and create communications 
parameters and autolog files. 
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communication parameters. In Telecom, the in- 
structions that set the baud rate, word length, 
parity, and number of stop bits and turn on or off 
flow control, the ASCII filter, and the self-echo 
switch. These settings and switches define the way 
your computer communicates with another com- 
puter system. 
condensed mode. A method of printing that 
causes characters to print closer together than they 
normally would. Using a condensed mode lets you 
print some types of information that use 132 
columns (characters) per line on a printer with a 
capacity of only 80 columns per line. 
control code. A character that causes a particular 
result within a computer operation, such as a car- 
riage return in a printing operation. 
control sequence. A sequence of control charac- 
ters, such as a break sequence in Telecom. 
cosmetic text. Any text on a record or report 
layout that is not part of a field label. You can create 
cosmetic text either by entering it from the keyboard 
or by copying it from the Draw application. 
CPU. An abbreviation for central processing unit. 
The CPU is the primary functioning unit for any com- 
puter system. 
current directory. The directory in which you are 
working at the moment. 
current list. In Address Book, the address list you 
are currently viewing. 
cursor. The small vertical line or box-like marker 
on the screen that indicates where you are entering 
information. 
daisy wheel printer. A printer with a flat, cir- 
cular, vertically rotating print head. The characters 
are arranged around the outside of the head like pe- 
tals on a daisy. 
data file. A DeskMate file that only holds informa- 
tion you have entered, not programming informa- 
tion. You can use data files only in conjunction with 
program files. 
data type. A field attribute on a record layout that 
you use to control the type of information (text or 
numerical) that you can enter in a given field when 
using Filer. On a report layout, a summary field at- 
tribute that lets you specify the type of summary in- 
formation you want (a total or an average of 
information in a numeric field or a count of the num- 
ber of records in the report). 

default. A value or response to a prompt that the 
program provides if you do not specify one. 
delimiter. A special character a file might require 
to mark the end of a series of characters. 
desktop. DeskMate’s central screen that Visually or- 
ganizes all DeskMate’s programs, files, and functions. 
destination disk. The disk that receives infonna- 
tion from the computer. In a copy or backup opera- 
tion, the disk on which the duplicate files are 
created. 
dialog box. In DeskMate, a window that appears 
on the screen when you request certain operations. 
The computer can complete the requested operation 
only after you respond to the prompts in the dialog 
box. 
direct connection. A means of communication 
from one computer to another via a cable that direct- 
ly transfers the output of one computer to another 
computer terminal. 
directory. A special type of file that keeps track of 
other files on a disk. 
diskcopy. An operation that produces an exact 
copy of a diskette. 
diskette. A flexible, round piece of magnetic tape 
enclosed in a protective plastic case. The computer 
writes data to and reads data from the surface of the 
diskette . 
dot matrix printer. A printer on which each char- 
acter is formed by a number of pins appropriately 
selected from a matrix (usually five columns by 
seven rows) of dots. 
double click. To press and release the button on 
your mouse twice in rapid succession. 
double click speed. The interval between the two 
button presses when you double click the mouse but- 
ton. At faster settings, the interval must be shorter if 
the computer is zot to interpret the clicks as distinct 
single clicks. 
drag. To hold down the button on your mouse 
while moving the pointer. 
edit field. An area following a screen prompt in 
which you can enter information. 
element. In Draw, a single shape drawn using one 
tool. 
event. An entry in a Calendar file. 
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exit. To halt the operation of a program or revert to 
a prior level of activity within a program. 
extension. Characters appended to a filename to 
provide further identification of the file. In Desk- 
Mate, extensions on data files identify the applica- 
tions with which the files operate. 
field. A series of character slots treated as a unit of 
information. In Form Setup, you create fields of 
various lengths and types on your record layouts. 
Then, you use Filer to enter information in the fields 
as you complete each record. 
field attributes. In Form Setup, the specific char- 
acteristics that you assign each field. 
file. A block of information your computer uses for 
a particular function or program. Files store dif- 
ferent types of information. One file might contain 
the Draw program, while another might contain a 
particular picture you composed. 
filename. A name containing a maximum of eight 
characters plus an optional three-character exten- 
sion that is used to identify a file. Examples are in- 
vntory.fil and 1etter.doc. 
flow control. In Telecom, a system that pauses 
data transmission when it occurs too rapidly. 
footer. In Form Setup, part of a report layout that 
contains information to appear at the bottom of 
each report page. In Text, reoccurring information 
on the bottom of each document page. 
format. The procedure that organizes the surface 
of a disk so that you can store data on it. 
format character. A character that appears in a 
field as a part of the field. For example, a field in 
which you must type local telephone numbers might 
contain a hyphen (-> as a format character to 
separate the first three digits from the final four. 
formula. A mathematical equation used to calcu- 
late numbers. 
grid. In Calendar, a weekly schedule shown in 15- 
minute “time slots’’ so that you can quickly see how 
heavy your schedule is for the week. 
handles. In Draw, these are attached to a border 
surrounding an object or group of objects you have 
(‘selected.” You can use the handles to change the 
size of the selected area. 
hard copy. A printout of any informationsuch as 
a letter, report, or listing-on paper. 

hard disk. A permanent disk that functions as a 
storage device for computer data. 
header. In Form Setup, the part of a report layout 
that contains information to appear at the top of 
each report page. In Text, reoccurring information at 
the top of each document page. 
hidden label. In Form Setup, a field label that you 
do not want to appear on the screen. 
highlight. An operation that defines a block of in- 
formation on the screen that you want to deal with 
as a unit. For example, you can highlight a word or 
phrase in a document and then duplicate it else- 
where in the document. 
host computer. A computer that can make its 
programs and data storage available to a remote 
computer or terminal. 
Index list box. In Address Book, the list box from 
which you can highlight an address for viewing. 
input cell. On a worksheet, a cell whose value you 
supply only at the point when a calculation requires 
it. 
insert mode. A typing mode in which the charac- 
ters you type appear at the cursor location and exist- 
ing characters shift to the right to accommodate 
them. 
K. Abbreviation for kilo, denoting one thousand. 
Commonly, it refers to kilobytes, units of data 
storage or memory capacity. Each kilobyte consists 
of 1024 bytes. 
labeled cell (label). In Worksheet, a single cell 
containing letters. 
landscape format. A printing format using 
graphics mode that presents the printed copy 
sideways on the page so that you can use the full 
length of the paper as the width of the printed copy. 
linefeed filter. A process that eliminates linefeeds 
from data sent to the printer because the printer 
automatically supplies the line feeds after a carriage 
return. 
list box. In DeskMate, a box that lists available 
choices. 
Member Of list box. In Address Book, the lkt box 
that displays all the address lists that the currently 
displayed address belongs to. 
menu. A list of available options, such as New, Open, 
Save as, Run, and so on. 
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menu bar. The second line on your DeskMate 
screen. Located on the menu bar is a series of menu 
titles. Selecting a menu displays a list of available 
functions. 
modem. An acronym for MOdulator/DEModulator. 
This device, which is required for your computer to 
connect with another computer, transforms com- 
puter signals into telephone signals, and vice versa. 
MS-DOS. The name of the operating system that in- 
itiates the operation of your computer when you 
start up. 
object. In Draw, more than one shape drawn using 
one or more tools; two or more elements joined 
together. 
open. To display the contents of a menu or file. 
operand. A number employed in a mathematical 
operation to produce the result. In the operation 20- 
15=5 the numbers 20 and 15 are operands. 
overtype mode. A typing mode in which the char- 
acters you type appear on the screen in place of the 
character currently at the cursor. The alternate 
mode is Insert mode. 
parent directory. The directory immediately 
above another directory. For example, c:\ is the 
parent directory of c:\desk. The current directory's 
parent directory is symbolized by [..I in DeskMate. 
parity. A system for checking accuracy in binary 
code transmittal. 
pathname. Information, including the drive and 
directory specification, that locates a file in the file 
system. For example, b:\projects\myfile locates a 
file (myfile) in the subdirectory (projects) of the 
root directory on Drive B. 
picture. In Draw, more than one shape drawn 
using one or more tools; all of the objects that ap- 
pear on a canvas. 
pixel. The smallest area of the display screen that 
can be individually manipulated. 
point. To manipulate the mouse so that you move 
the arrow on the screen. Pointing to a particular 
item on the screen entails placing the tip of the 
arrow on that item. 
pointer. The arrow or other symbol depicted on 
the screen and positioned on the screen by 
manipulating the mouse. 

port. In Telecom, the connection point at which the 
host links with the remote site. 
portrait format. A style of printed output that 
presents the text or image in the normal, topto-bot- 
tom fashion. You can print data in portrait format 
using text mode. 
printable area. The portion of a page on which a 
laser printer can actually print text and graphics. 
printed lines per page. The number of lines to 
print on each page, calculated by subtracting the 
sum of the top and bottom margins from the total 
lines per page. 
printed line width. The number of characters to 
print per line, calculated by subtracting the sum of 
the left and right margins from the total line length. 
priority. In Filer or Form Setup, the order in which 
fields are considered when the computer arranges 
records for display or printing. For example, if Last 
Name is the item given first priority, records are 
sorted in alphabetical order by last name. 
program file. A disk file that contains the com- 
mands for operating an application or accessory. 
Programs list box. The desktop list box that 
provides access to all DeskMate applications. 
protocol. In Telecom, the conventions that govern 
the format and timing of data transfer. Sender and 
receiver must adhere to the same set of conventions. 
Telecom supports ASCII and Xmodem protocols, the 
latter developed to improve the accuracy of file 
transfer. 
query. A specific request for data. 
record. In Filer, the information entered for each 
entity in the file. In a client file, for example, each 
client is an individual record. In Address Book, the 
information entered for each person in the book 
(also called an address). 
record layout. In Filer or Form Setup, the format 
set up for entering the information in each record. 
Defining the record layout includes establishing, ar- 
ranging, and labeling the fields that will contain the 
data. 
relationship. In Filer, an element of the selection 
criteria used in finding records. Examples include 
Equal, Not equal, Less or equal, Greater or equal, In 
between, and None. 
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report layout. In Form Setup, the content and ar- 
rangement of the parts of the report. These parts in- 
clude the page headings, the information listed, and 
Various summaries of the data presented. You can 
create the layout, using Form Setup, or copy an exist- 
ing layout, using Filer. 
row. One of two or more horizontal sections appear- 
ing one above the other. 
save. A menu option that enables you to write a file 
to your disk in its current form as a protection 
against accidental loss of data. Some DeskMate ap- 
plications have specific menu options to let you save 
a file. Others such as Address Book, save data auto- 
matically as you update the file. 
scroll. The shifting of screen contents vertically or 
horizontally to reveal information beyond the cur- 
rent margins. Comparable to the way movie credits 
rrroll” at the end of a film. 
scroll arrow. A button on the menu bar or a list 
box. Clicking on a scroll arrow using a mouse 
enables you to scroll the contents of the screen (or 
box) in the indicated direction. 
search criteria. In Filer, the selection rules that 
you establish to display or print only those records 
of interest to you. 
select. To choose an option or command that best 
helps to fulfill a desired task. 
self echo. In Telecom, a setting that helps to dis- 
play typed characters during transmission. 
sort. In Filer or Form Setup, an operation that ar- 
ranges records in an alphabetical or numerical se- 
quence using the fields you specify. For example, a 
teacher could sort the records for a class in al- 
phabetical order using the last names of the students. 
source disk. The disk from which your computer 
reads information. In a backup or copy operation, 
the original disk from which files are duplicated to 
another disk (the destination disk). 
spreadsheet. A data entry format composed of a 
series of consecutive rows and columns, so that each 
item of information is located at a definite point on 
a grid. In DeskMate, the Worksheet application uses 
this data arrangement. 
status line. In Address Book, the line at the bot- 
tom of the screen that reminds you of the current 
field and the number of addresses in the current list 
or the entire book. 

stop bit. A control code used in data transmissions 
to signal the end of a character. 
string. In a search operation, the series of charac- 
ters that you type and the computer, in turn, locates. 
subdirectory. A directory that is located within 
another directory in your file system, enabling you 
to arrange your files in groups or subgroups. Direc- 
tories themselves are simply special files that keep 
track of a group of files. 
summary field. In Form Setup, a field in a report 
layout’s summary section that can perform a simple 
calculation based on a selected field from the file. 
summary report. The part of a Filer report 
generated by the summary section of the report 
layout. 
summary section. In Form Setup, the part of a 
report layout that includes summary information to 
appear at the end of the report. 
system date. The date that you entered (or that 
was displayed) when you turned on the computer. 
system prompt. The prompt that indicates that 
the system is waiting for you to enter a command. In 
MS-DOS, the system prompt identifies the current 
drive and is followed by > . 
terminal buffer. In Telecom, a memory storage 
area that lets you store incoming data from a host 
computer. 
terminal screen. In Telecom, the screen that dis- 
plays the exchange of data between your computer 
and the host computer. 
timeout. In Telecom, a value indicating the num- 
ber of seconds (during file transfer) of inactiviv 
after which the computer closes the file automat- 
ically. 
title bar. The first line on the DeskMate screen, 
which indicates the current application, current 
directory, and so on. 
toggle. A switch that alternately activates or deac- 
tivates an option or condition. Also indicates an ac- 
tion performed by the user to change the switch 
setting. 
tool. In Draw, the instrument used to draw a basic 
shape. 
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total line length. The number of characters that 
would fit across a given page, based on the paper 
width and the printed characters per inch. For ex- 
ample, the total line length for an 8Vz-inch page 
printed with a ten-characters-per-inch font is 85 
characters. 
total lines per page. The number of printed lines 
that would fit on a given page, based on the paper 
length and the lines per vertical inch. For example, 
the total lines per page for an 1 1-inch page printed 
with six lines per vertical inch is 66. 
truncate. In Worksheet, to convert a number to an 
integer by simply eliminating the value to the right 
of the decimal point. Also, used simply to mean 
shorter. For example, in Form Setup labels that ap- 
pear above a field are shortened to the length of the 
field. 
wildcard. A character thar can be matched with 
any of a range of other characters or groups of char- 
acters. Similar to a wildcard in poker that can stand 
for any other card in the deck. 
word length. In Telecom, the number of bits in a 
sequence that is handled as a unit. Set the word 
length so that the host and remote computers agree. 
Xmodem. In Telecom, a protocol for data transfer 
between two computers that controls data transfer 
and checks its accuracy. 
Xoff. In Telecom, a code used by flow control to cre- 
ate a pause in data transfer. 
Xon. In Telecom, a code used by flow control to 
start data transfer. 
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A 
Accessory Menu (F 10) 

Alarm, 15-16 
Calculator, 12- 13 
Clipboard, 17 
Corkboard, 14-15 
To Do List, 16-17 
Month, 15 
options on, 5 
Phone List, 13-14 
selecting options on, 6 
Setup accessory, 7- 10 
shaded options, 7 
Spell Checker, 11-12 
Task Switch, 18 

adding records. See Address Book application; Filer 

Address Book application 
application; Form Setup application 

Address Menu (F5) 
Add option, 28-29 
Add to list option, 29 
Call option, 30 
Copy option, 29 
Delete from list option, 29 
Delete option, 29 
Find next option, 30 
Find option, 29-30 

correcting errors, 32 
Edit Menu (F3) 

Clear option, 26 
Copy option, 26 
Cut option, 26 
Paste option, 26 
Undo option, 27 

About option, 25 
Exit option, 25 
Format labels option, 21 
Print address option, 24-25 
Print document option, 23 
Print form letter option, 23-24 
Print labels option, 21-23 

Files Menu (F2) 

Run option, 25 
highlighting information, 32 
List Menu (F4) 

Merge option, 27 
New option, 27 

placing fields in form letters, 139 
printing phone numbers, 32 
task list, 31 
uses for, 19 
using Address Book, 20 
View Menu (F6) 

All option, 30 
By list option, 30 

viewing addresses on current list, 32 

Alarm/Calendar Alarms option, 15, 45 
Message option, 15 
Quick Alarm Time option, 16 

Alarm Accessory 

aligning objects in drawings, 67 
ALT=, for switching tasks, 18 
application boxes or accessories 

creating, 55 
deleting, 56 
displaying, 54 
moving, 55 
Quick Load box, creating, 55-56 
redefining, 56 
removing, 55 

arc tool, for drawings, 71-72 
ASCII files 

ASCII filter in Telecom, 119 
converting 

documents, 133, 141, 142 
worksheets, 157 

loading, in Telecom buffer, 121-122 
transferring, 120-121, 123 

Call command, 119 
creating, 115 
Delete command, 121 
editing, 125 
Execute command, 121 
Insert command, 121 

autolog files 
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loading and running, 115 
opening, 116 
printing, 116-117 
saving, 116 
Send command, 120 
Set command, 118-119 
stopping, 125 
Transfer command, 120-121 
Wait command, 119-120 

automatically dialing phone numbers, 30 
autoproofing your typing, 12 

B 
bold text 

in documents, 135 
in reports, 103 

breaking objects in drawings, 67 
brush tool for drawing, 69, 71 
buffer for Telecom. See Telecom application 

C 
calculating worksheets, 153 
Calculator Accessory, 12-13 
Calendar application. See also Month Accessory 

Calendars Menu (F7) 
Delete option, 42 
New option, 42 
Open option, 42 

Daily option, 38 
Monthly option, 38 
Weekly option, 38 
Yearly option, 38 

Clear option, 37 
Copy option, 37 
Cut option, 37 
Paste option, 37 

Add option, 40 
Annual occasion option, 41 
Change option, 40-41 
Reminder option, 41 
Remove option, 41 

About option, 37 
Exit option, 36 
Page setup option, 35 

Display Menu (F4) 

Edit Menu (F3) 

Event Menu (F6) 

File Menu (F2) 

Print option, 35-36 
Run option, 36 

highlighting events, 43-44 
moving the cursor, 44 
Search Menu (F5) 

Find date option, 39 
Find next option, 39 
Find option, 39 
Today’s date option, 39 

selecting dates, 44-45 
setting the alarm, 45 
storing updates, 45 
task list, 42-43 
uses for, 33 
using the Calendar, 33-34 

formatting cells, 154-155 
formulas for, 155 
input cells, 155 
starting and ending text, 155 

center lines, in drawings, 74 
centering text in documents, 135 
changing directories, 51 
checking your spelling. See Spell Checker 

clearing. See deleting 
clip art, 64-65 
Clipboard Accessory, 17. See also specific 

applications for use of clipboard 
colors 

cells. See also columns and rows 

accessory 

changing 
in Draw application, 8, 69 
palettes, 8 

monochrome default/color default, 8 
setting up, 8 

columns and rows. See also cells 
calculating worksheets, 153 
deleting 

columns, 153 
rows, 153 

columns, 153 
rows, 153 

Com interrupt, selecting, 7 
COM ports. See serial ports 

inserting 

setting column width, 152 
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communications, setting up, 7-8. See also Telecom 

connections, setting up, 7 
copying. See also cutting and pasting 

addresses, 26, 29 
art or cosmetic text in Form Setup, 95 
calendar events, 37 
diskettes, 53 
drawings, 65 
Filer information, 85-86 
Filer records, 82-84 
files, 49-51 
layouts 

application 

in Filer, 77 
in Form Setup, 90 

text and pictures in documents, 134 
worksheet information, 157-158 

Corkboard Accessory, 14-15 
correcting errors 

in Address Book, 32 
in the desktop, 57 
in Filer, 85 
in Form Setup, 104 
in Telecom, 125 
in Text application, 141 
in text of drawings, 74 
in Worksheet application, 157 

counting Filer records, 84 
creating 

application boxes or accessories, 55-56 
autolog files, 115 
directories, 51-52 
documents in Text, 129 
files in Filer, 85 
Quick Load box, 55-56 
record or report layouts in Filer, 86 

addresses, 26 
calendar events, 37 
documents, 133-134 
drawings, 65 
Filer information, 81-82 
Form Setup information, 95 
worksheets, 151-152 

cutting and pasting. See also copying 

D 
database management. See Address Book 

application; Filer application 

date and time, setting, 9 
deleting. See also removing 

addresses, 26, 27, 29 
application boxes or accessories, 56 
calendar events, 37 
calendars, 42 
directories, 52 
Filer information, 85-86 
Filer records, 82 
files, 50 
Form Setup information, 105-106 
lists, 27 
objects from pictures, 65 
players from Hangman, 111 
Telecom buffer contents, 122 
text in documents, 134 
undeleting text in documents, 134 
worksheet information, 152 

correcting errors, 57 
Desktop Menu (F7) 

desktop 

Create option, 55 
Create quick load option, 55-56 
Delete option, 56 
Display option, 54 
Install option, 54 
Move option, 55 
Redefine option, 56 
Remove option, 55 

Change option, 51 
Create option, 51-52 
Delete option, 52 

Diskcopy option, 52 
Format option, 52 
Get Info option, 52 

About option, 51 
Copy option, 49-50 
Delete option, 50 
Exit option, 51 
Get Info option, 49 
Rename option, 50-51 
Run option, 49 
Update screen option, 51 

highlighting multiple files, 57 

Directory Menu (F3) 

Disk Menu (F4) 

File Menu (F2) 
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Sort by Menu (F6) 
Date, 53 
Name, 53 
Size, 54 

task list, 57 
uses for, 47 
using the desktop, 47-48 
View Menu (F5) 

Files option, 53 
Menus option, 53 
Tree option, 53 

wildcard characters, 58 

Type, 53 

dialing phone numbers automatically, 30 
dictionary, saving and deleting words in, 11-12 
directories 

changing, 51 
creating, 51-52 
deleting, 52 
Tree view, 53 

diskettes 
copying, 52 
formatting, 52 
getting information about, 54 

application boxes or accessories, 54 
calendars, 38 
Telecom buffer contents, 122 

Draw application 
Actions Menu (F4) 

displaying 

Align option, 67 
Break object option, 67 
Duplicate option, 66 
Flip horizontal option, 67 
Flip vertical option, 67 
Make object option, 67 
Move to bottom option, 67 
Move to top option, 66 
Rotate option, 67 

center lines, 74 
changing colors, 8 
correcting errors, 74 

Edit Menu (F3) 
Add corner option, 66 
Clear option, 65 
Clip art option, 64-65 
Copy option, 65 
Cut option, 65 
Delete corner option, 66 
Move corner option, 66 
Move option, 65 
Paste option, 65 
Resize option, 66 
Select all option, 65 

About option, 64 
Exit option, 63-64 
New option, 61 
Open option, 61-62 
Page setup option, 62 
Print option, 63 
Run option, 64 
Save as option, 62 
Save option, 62 

File Menu (F2) 

inserting pictures in documents, 139 
moving the marker, 73 
Options Menu (F6) 

Brush option, 69 
Colors option, 69 
Line option, 69 
Patterns option, 68 
Text option, 69-70 
Use keyboard option, 70 
Use mouse option, 70 

task list, 72-73 
Tools Menu (F7) 

Arc option, 71-72 
Brush option, 71 
Ellipse option, 71 
Filled brush option, 71 
Line option, 71 
Polygon option, 72 
Polyline option, 72 
Rectangle option, 71 
Select option, 70-71 
Text option, 71 

uses for, 59 
using the Draw application, 59-60 
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Zoom Menu (F5) 
Four times option, 68 
Half option, 68 
Normal option, 68 
Quarter option, 68 
Two times option, 68 

duplicating drawings, 66 

E 
Edit Menu (F3) 

Address Book application, 26-27 
Calendar application, 37 
Draw application, 64-66 
Filer application, 81-82 
Form Setup application, 94-95 
Text application, 133-135 
Worksheet application, 151-152 

ellipse tool, for drawings, 71 
events. See Calendar application 

F 
fields. See Filer application; Form Setup application 
file management 

copying files, 49-50 
deleting files, 50 
displaying a list of files, 53 
getting information about files, 49 
highlighting multiple files, 57 
renaming files, 50-51 
sorting files, 53-54 
updating the screen, 51 
wildcard characters in filenames, 58 

Address Book application, 21-25 
Calendar application, 35-37 

Draw application, 61-64 
Filer application, 77-81 
Form Setup application, 91-94 
Telecom application, 115-118 
Text application, 129-133 
Worksheet application, 147-151 

file transfer. See Telecom application 

File Menu (F2) 

desktop, 49-51 

Filer application. See also Form Setup application 
correcting errors, 85 
creating 

new files, 85 
record or report layouts, 86 

Clear option, 82 
Copy option, 81-82 
Cut option, 81 
Paste option, 82 

About option, 81 
Copy layouts option, 77 
Exit option, 81 
Form setup option, 78 
Open option, 77 
Page setup option, 78 
Print record option, 78-80 
Print report option, 80 
Run option, 81 

highlighting information, 86 
Records Menu (F4) 

Add option, 82 
Copy option, 83 
Count option, 84 
Delete option, 82 
Find option, 83-84 
First option, 83 
Last option, 83 
Next option, 83 
Previous option, 83 
Sort option, 84 

Edit Menu (F3) 

File Menu (F2) 

sample layouts, 86 
storing completed records, 86 
switching to, from Form Setup, 93 
task list, 84-85 
uses for, 75 
using Filer, 75-76 
wildcard characters, 86 

filled brush tool, for drawings, 71 
finding 

addresses, 29-30 
calendar dates and text, 39 
Filer records, 83-84 
text in documents, 136 
worksheet information, 157-158 
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flipping drawings 
horizontally, 67 
vertically, 67 

placing fields in, 139 
printing, 23-24, 132 

correcting errors, 105 
cosmetic text, 105 
Edit Menu (F3) 

form letters 

Form Setup application. See also Filer application 

Clear option, 95 
Copy option, 95 
Cut option, 95 
Move picture option, 95 
Paste option, 95 
Size picture option, 95 

Add option, 100-101 
Change option, 101-102 
Format option, 103 
Size option, 102 

About option, 94 
Copy layouts option, 91-92 
Exit option, 94 
Filer option, 93 
New option, 91 
Open option, 91 
Page setup option, 92 
Print option, 93-94 
Run option, 94 

format characters, 105 
highlighting information, 105 
placing graphics in layouts, 106 
Record Menu (F4) 

Field Menu (F6) 

File Menu (F2) 

Define option, 96 
Sort option, 97 

Clear all option, 100 
Define option, 97-98 
Page number option, 99 
Resize section option, 99-100 
Show page option, 98 
Summary option, 99 
Today’s date option, 98-99 

Report Menu (F5) 

switching to, from Filer application, 78 
task list, 104 

Text Menu (F7) 
Bold option, 103 
Plain option, 103 
Underline option, 103 

uses for, 87 
using Form Setup, 87-90 

formatting diskettes, 52 
formulas for worksheets, 155, 159 

H 
Hangman 

Game Menu (F2) 
About option, 110 
Exit option, 110 
New option, 109 
Restore option, 110 
Run option, 110 
Save option, 109 

Add option, 110 
Define option, 110 
Delete option, 111 

playing a saved game, 111 
task list, 111 
using Hangman, 107-308 

hiding pictures in documents, 139 
highlighting 

Address Book information, 32 
Calendar information, 43-44 
Filer information, 85-86 
Form Setup information, 105-106 
multiple files, 57 

Player Menu (F3) 

Z 
indenting text in documents, 136 
installing programs, 54 

L 
labels, printing. See Address Book application 
layouts for Filer 

copying, 77 
creating, 86 
sample layouts, 86 

layouts for Form Setup 
adding 

fields, 100-101 
today’s date, 98-99 
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bold text, 103 
changing 

field or record attributes, 101-102 
field size, 102 

clearing the screen, 100 
copying, 91-92 
defining, 97-98 
designing, 97-98 
displaying a template, 98 
emphasizing text, 103 
format characters, 103, 105 
graphics, 106 
page numbers, 99 
plain text, 103 
printing, 93-94 
resizing sections, 99-100 
summary field, 99 
underlined text, 103 

layouts for Text application 
adding fields from Address Book, 139 
footers, 138 
headers, 137-138 
page numbers, 138 
returning to current document, 137 
today's date, 139 

lines in drawings, 71 
lists 

address lists, 27 
phone number lists, 13-14 

LPT port, 9 

M 
making objects in drawings, 67 
merging 

address lists, 27 
documents in Text, 130 
worksheets, 148 

setting up, 7-8 
modem 

monitors, 8 
Month Accessory, 15 

mouse 
See also Calendar application 

double click speed, 8 
selecting a pointing device, 8 
serial mouse port, 8 
setting up, 8-9 

moving 
application boxes or accessories, 55 
objects in drawings, 65, 66-67 
picture, in Form Setup, 95 

multitasking, 18 

P 
page break, 142 
page setup 

for calendars, 35 
for drawings, 62 
Filer reports, 78 
Form Setup reports, 92 
for Text documents, 130-131 
for Worksheet application, 148-149 

parallel port, 9 
pasting. See cutting and pasting 
patterns in drawings, 68 
Phone List Accessory 

Number Menu (F3) 
Call option, 14 
Work phone/Home phone option, 14 

Exit option, 14 
Print option, 13 

Phone List Menu (F2) 

phone number, dialing automatically, 30 
pictures in documents. See also Draw application 

editing, 142 
hiding, 139 
inserting, 142 
moving, 140 
showing, 139 
sizing, 140 

in documents, 135 
in reports, 103 

plain text 

pointing device, selecting, 8-9 
polygon tool, for drawings, 72 
polyline tool, for drawings, 72 
ports 

com interrupt, 7 
communications port, 7 
port interrupt, 8-9 
printer ports, 9 
serial mouse port, 8 

printers, setting up, 9 
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printing 
addresses in another file, 23 
autolog files, 116-117 
drawings, 63 
form letters, 23-24, 132 
Form Setup layouts, 93-94 
labels, 21-23 
phone lists, 13, 32 
records from Filer, 78-80 
reports from Filer, 80-81 
a single address, 24-25 
Telecom buffer contents, 122-123 
Text documents, 131-132 
worksheets, 149-150 

Q 
Quick Load box, creating, 55-56 

R 
records. See Address Book; Filer application; 

rectangle tool, for drawings, 71 
redefining application boxes or accessories, 56 
removing. See also deleting 

application boxes or accessories, 55 
calendar events, 41 

Form Setup application 

renaming files, 50-51 
replacing text in documents, 136-137 
report layouts. See layouts for Form Setup 
resizing 

drawings, 66 
pictures, 95, 140 
sections of report layouts, 99-100 

rotating drawings, 67 
rows and columns. See columns and rows 
running another program, 25 

S 
saving 

autolog files, 116 
current Hangman game, 109 
dictionary changes, 12 
documents in Text, 130 
drawings, 62 
Telecom buffer contents, 122 
worksheets, 148 

Screen Saver, 10 
Search Menu (F5) 

Calendar application, 39 
Text application, 136-137 
Worksheet application, 153-154 

searching. See finding 
serial ports 

communications port, 7 
serial mouse port, 8 

colors, 8 
communications, 7-8 
date and time, 9 
mouse, 8-9 
Options Menu (F2), 7 
printer, 9 
screen for, 7 
Screen Saver, 10 

Setup accessory 

showing pictures in documents, 139 
sizing. See resizing 
sorting 

Filer records, 84 
files, 53-54 
records for reports, 97 

Dictionary Menu (F4) 
Spell Checker accessory 

Edit option, 12 
Save option, 12 

About option, 11 
Exit option, 11 
Open option, 11 

Options Menu (F3) 
Auto Proof option, 12 
Check Word option, 12 

screen for, 11 
using with documents, 134-135 

spreadsheet. See Worksheet application 
substituting text in documents, 136-137 
switching between tasks, 18 

T 
Task Switch Accessory, 18 
Telecom application 

autolog files 

File Menu (F2) 

creating, 115 
editing, 127 
loading and running, 115 
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opening, 116 
printing, 116-117 
saving, 116 
stopping, 125 

buffer, definition of, 125 
Buffer Menu (F4) 

Buffer off option, 121 
Buffer on option, 121 
Clear option, 122 
Display option, 122 
Load option, 121-122 
Print option, 122-123 
Save as option, 122 

Command screen, 125 
Commands Menu (F3) 

Call, 119 
Delete, 121 
Execute, 121 
Exit, 121 
Insert, 121 
Send, 120 
Set, 118-119 
Transfer, 120-121 
Wait, 119-120 

correcting errors, 125 
File Menu (€72) 

About option, 118 
Autolog option, 115 
Exit option, 117 
New option, 115 
Open option, 116 
Print option, 116-117 
Run option, 117-118 
Save as option, 116 
Save option, 116 

Disconnect option, 124 
Terminal option, 123 
Transfer file option, 123 

Options Menu (F5) 

task list, 124 
Terminal screen, 125 
uses for, 113 
using Telecom, 113-114 

telephone numbers. See Phone List Accessory 
terminal. See monitor 
terminate and stay resident programs, 18 
Text application 

ASCII format, 141, 142 

correcting errors, 141 
Edit Menu (€73) 

Clear option, 134 
Copy option, 134 
Cut option, 133-134 
Insert option, 134 
Paste option, 134 
Proof option, 134-135 
Select all option, 134 
Thesaurus option, 135 
Un-Delete option, 134 

editing pictures, 142 
ending a page, 142 
File Menu (€72) 

To ASCII option, 133 
Merge option, 130 
New option, 130 
Open option, 129-130 
Page setup option, 130-131 
Print form letter option, 132 
Print option, 131-132 
Run option, 133 
Save as option, 130 
Save option, 130 

pictures, 142 
text, 142 

Layout Menu (€76) 
Add field option, 139 
Footer option, 138 
Header option, 137-138 
Page number option, 138 
Return to document option, 137 
Today’s date option, 139 

inserting 

non-ASCII format, 142 
overtyping text, 143 
Picture Menu (€77) 

Hide option, 139 
Move option, 140 
Show option, 139 
Size option, 140 

Find next option, 136 
Find option, 136 
Substitute option, 136-137 

Search Menu (F5) 

task list, 140-141 
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Text Menu (F4) 
Bold option, 135 
Center option, 135 
Indent option, 136 
Plain option, 135 
Underline option, 135 

uses for, 127 
using the Text application, 127-128 

text in drawings, 69, 71 
text in reports 

bold text, 103 
cosmetic text, 105 
plain text, 103 
underlined text, 103 

Thesaurus Companion, 135 
time and date, setting, 9 
To Do List  Accessory 16-17 
tools for drawing, 70-72 
transferring files. See Telecom application 
Tree view, 53 

U 
undeleting text in documents, 134 
underlined text 

in documents, 135 
in reports, 103 

undoing addresses, 27 
updating the screen, 51 

V 
video monitor, 8 
View Menu 

Address Book application, 30 
desktop, 53 

W 
wildcard characters 

in filenames, 58 
in Filer application, 86 

Worksheet application 
ASCII format, 157 
Cells Menu (F6) 

End text option, 155 
Format option, 154-155 
Formula option, 155 
Input option, 155 
Start text option, 155 

changing numbers or labels, 157 
correcting errors, 157 
Edit Menu (F3) 

Clear option, 152 
Copy option, 151-152 
Cut option, 151 
Paste option, 152 
Select all option, 152 

Exit option, 150 
Merge option, 148 
New option, 147 
Open option, 147-148 
Page setup option, 148-149 
Print option, 149-150 
Run option, 150-151 
Save as option, 148 
Save option, 148 

Calculate option, 153 
Column width option, 152 
Delete column option, 153 
Delete row option, 153 
Insert column option, 153 
Insert row option, 153 

File Menu (F2) 

Pad Menu (F4) 

removing blocks of text, 158 
Search Menu (F5) 

Find cell option, 154 
Find label option, 153 
Find next option, 154 
Find number option, 154 

task list, 156 
uses for, 145 
using the Worksheet application, 145-146 

X 
Xmodem protocol, 119, 123 

Z 
Zoom Menu (F5), Draw application, 68 
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TERMS AND CONDITIONS OF SALE AND LICENSE OF TANDY COMPUTER EOUIPMENT AND SOFTWARE PURCHASED 
FROM RADIO SHACK COMPANY-OWNED COMPUTER CENTERS, RETAIL STORES AND RADIO SHACK FRANCHISEES OR 

DEALERS AT THEIR AUTHORIZED LOCATiONS 

USA LIMITED WARRANTY 
I. CUSTOMER OBLIGATIONS 

A. 

B. 

LIMITED WARRANTIES AND CONDITIONS OF SALE 
A. 

CUSTOMER assumes full responsibility that this computer hardware purchased (the “Equipment“), and any copies of software 
Equipment or licensed separately (the “Software”) meets the specifications, capacity, capabilities, versatility, and other requiremeni 
CUSTOMER assumes full responsibility for the condition and effectiveness of the operating environment in which the Equipment an 
function, and for its installation. 

For a period of ninety (90) calendar days from the date of the Radio Shack sales document received upon purchase of the Equipme 
warrants to the original CUSTOMER that the Equipment and the medium upon which the Software is stored is free from manufactu 
warranty is only applicable to purchases of Tandy Equlpment by the origlnal customer from Radio Shack company-owned E 
retail stores, and Radio Shack franchisees and dealers at their authorized locations. The warranty is void if the Equipment or : 
subjected to improper or abnormal use. If a manufacturing defect is discovered during the stated warranty period, the defective Ei 
returned to a Radio Shack Computer Center, a Radio Shack retail store, a participating Radio Shack franchisee or a participating F 
for repair, along with a copy of the sales document or lease agreement. The original CUSTOMER’S sole and exclusive remedy in thc 
is limited to the correction of the detect by repair, replacement, or refund of the purchase price, at RADIO SHACK’S election i 
RADIO SHACK has no obligation to replace or repair expendable items. 
RADIO SHACK makes no warranty as to,the design, capability, capacity, or suitability for use of the Software, except as provided 
Software is licensed on an “AS IS” basis, without warranty. The original CUSTOMER’S exclusive remedy, in the event of a Softw 
defect, is its repair or replacement within thirty (30) calendar days of the date of the Radio Shack sales document received ,UI 
Software. The defective Software shall be returned to a Radio Shack Computer Center, a Radio Shack retail store, a particlpi 
franchisee or Radio Shack dealer along with the sales document. 
Except as provided herein no employee, agent, franchisee, dealer or other person is authorized to give any warranties of any n8 
RADiO SHACK. 
EXCEPT AS PROVIDED HEREIN, RADIO SHACK MAKES NO EXPRESS WARRANTIES, AND ANY IMPLIED WARRANTY OF MER( 
FITNESS FOR A PARTICULAR PURPOSE IS LIMITED IN ITS DURATION TO THE DURATION OF THE WRITTEN LIMITED WARRAI 
HEREIN. 
Some states do not allow limitations on how long an implied warranty lasts, so the above limitation(s) may not apply to  CUSTOME 

111. LIMITATION OF LIABILITY 
EXCEPT AS PROVIDED HEREIN, RADIO SHACK SHALL HAVE NO LIABILITY OR RESPONSIBILITY TO CUSTOMER OR ANY 01 
ENTITY WITH RESPECT TO ANY LIABILITY, LOSS OR DAMAGE CAUSED OR ALLEGED TO BE CAUSED DIRECTLY OR 
“EQUIPMENT” OR “SOFTWARE” SOLD, LEASED, LICENSED OR FURNISHED BY RADIO SHACK, INCLUDING, BUT NOT 1 
INTERRUPTION OF SERVICE, LOSS OF BUSINESS OR ANTICIPATORY PROFITS OR CONSEQUENTIAL DAMAGES RESULTING Ff 
OPERATION OF THE “EQUIPMENT” OR “SOFTWARE.” IN NO EVENT SHALL RADIO SHACK BE LIABLE FOR LOSS OF P 
INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF ANY BREACH OF THIS WARRANTY OR IN ANY MANNER 
OR CONNECTED WITH THE SALE, LEASE, LICENSE, USE OR ANTICIPATED USE OF THE “EQUIPMENT” OR “SOFTWARE.” 
NOTWITHSTANDING THE ABOVE LIMITATIONS AND WARRANTIES, RADIO SHACKS LIABILITY HEREUNDER FOR DAMAGf 
CUSTOMER OR OTHERS SHALL NOT EXCEED THE AMOUNT PAID BY CUSTOMER FOR THE PARTICULAR “EQUIPMENT” 
INVOLVED. 
RADIO SHACK shall not be liable for any damages caused by delay in delivering or furnishing Equipment and/or Software. 
No action arising out of any claimed breach of this Warranty or transactions under this Warranty may be brought more than two 
cause of action has accrued or more than four (4) years after the date of the Radio Shack sales document for the Equipment or SI 
first occurs. 
Some states do not allow the limitation or exclusion of incidental or consequential damages, so the above limitation(s) or exclusioi 
to CUSTOMER. 

IV. SOFTWARE LICENSE 

II.  

E. 

C .  

D. 

E. 

A. 

B. 
C. 

D. 

RADIO SHACK grants to CUSTOMER a non-exclusive, paid-up license to use the TANDY Software on one computer, subject to the foliov 
A. Except as otherwise provided in this Software License, applicable copyright laws shall apply to the Software. 
E. Titie to the medium on which the Software is recorded (cassette and/or diskette) or stored (ROM) is transferred to CUSTOMER, 

Software. 
C. CUSTOMER may use Software on a multiuser or network system only if either, the Software is expressly labeled to be for use 

network system, or one copy of this software is purchased for each node or terminal on which Software is to be used simultaneou 
D. CUSTOMER shall not use, make, manufacture, or reproduce copies of Software except for use on one computer and as is spec 

this Software License. Customer is expressly prohibited from disassembling the Software. 
E. CUSTOMER is permitted to make additional copies of the Software only for backup or archival purposes or if additional copies 

operation of one computer with the Software, but only to the extent the Software allows a backup copy to be made. However, for 
CUSTOMER is permitted to make a limited number of additional copies for CUSTOMER’S own use. 

F. CUSTOMER may resell or distribute unmodified copies of the Software provided CUSTOMER has purchased one copy of the Sof 
sold or distributed. The provisions of this Software License shall also be applicable to third parties receiving copies of 1 
CUSTOMER. 

G. All copyright notices shall be retained on all copies of the Software. 

A. The terms and conditions of this Warranty are applicable as between RADIO SHACK and CUSTOMER to either a sale of the 
Software License to CUSTOMER or to a transaction whereby Radio Shack sells or conveys such Equipment to a third party for lea! 

E. The limitations of liability and Warranty provisions herein shall inure to the benefit of RADIO SHACK, the author, owner and 
Software and any manufacturer of the Equipment sold by Radio Shack. 

V. APPLICABILITY OF WARRANTY 

VI. STATE LAW RIGHTS 
The warranties granted herein give the original CUSTOMER specific legal rights, and the origlnal CUSTOMER may have other right 
state to state. 
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